When running cmake from QtC on a webbrowser-app branch it fails

Bug #1599695 reported by Alexandre Abreu on 2016-07-07
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
webbrowser-app (Ubuntu)
High
Olivier Tilloy

Bug Description

When running cmake from QtC on a webbrowser-app branch in Xenial it fails with the following error:

CMake Error at src/Ubuntu/CMakeLists.txt:31 (message):
  Invalid chromium version: ''

Related branches

description: updated
Olivier Tilloy (osomon) wrote :

I’m not seeing that on my up-to-date xenial setup. Do you have xvfb installed?

Changed in webbrowser-app (Ubuntu):
status: New → Incomplete

@Olivier: yes, I have. what's your QtC & Ubuntu plugin version?

Olivier Tilloy (osomon) wrote :

ii qtcreator 3.5.1+dfsg-2ubuntu2 amd64
ii qtcreator-plugin-ubuntu 3.5.0+16.04.20160419-0ubuntu1 amd64
ii qtcreator-plugin-ubuntu-common 3.5.0+16.04.20160419-0ubuntu1 all

Do you have qmlscene installed?

Does a call to "cmake ." succeed from a terminal (outside of QtCreator) in a clean tree?

I run the same versions as you do,

yes, I have qmlscene installed,

and a local cmake . does work,

Olivier Tilloy (osomon) wrote :

Could you maybe instrument src/Ubuntu/CMakeLists.txt to try and understand what’s not working, and let me know the output?
Something like that:

=== modified file 'src/Ubuntu/CMakeLists.txt'
--- src/Ubuntu/CMakeLists.txt 2016-07-01 13:06:40 +0000
+++ src/Ubuntu/CMakeLists.txt 2016-07-08 05:20:56 +0000
@@ -23,8 +23,11 @@
     OUTPUT_VARIABLE UBUNTU_VERSION OUTPUT_STRIP_TRAILING_WHITESPACE)
 add_definitions(-DUBUNTU_VERSION="${UBUNTU_VERSION}")

+message("xvfb command: ${XVFB_COMMAND}")
+message("current source dir: ${CMAKE_CURRENT_SOURCE_DIR}")
 execute_process(COMMAND ${XVFB_COMMAND} qmlscene --quit ${CMAKE_CURRENT_SOURCE_DIR}/chromium-version.qml
     OUTPUT_VARIABLE CHROMIUM_VERSION OUTPUT_STRIP_TRAILING_WHITESPACE)
+message("chromium version extracted by chromium-version.qml: ${CHROMIUM_VERSION}")
 string(REGEX MATCH "\\[(.*)\\]" _ ${CHROMIUM_VERSION})
 set(CHROMIUM_VERSION ${CMAKE_MATCH_1})
 if(NOT CHROMIUM_VERSION MATCHES "^[0-9]+\\.[0-9]+\\.[0-9]+\\.[0-9]+$")

Andrew Hayzen (ahayzen) wrote :

I have the same issue, I added the extra lines from comment 5 to the CMake files and I get the following output when attempting to run in QtC [0], the output CMakeOutput.log is here [1].

Note that 'This application failed to start because it could not find or load the Qt platform plugin "xcb"
in "".' has now appeared.

Also when running
$ cmake .
I get the following output [2]

The version of my ubuntu-sdk and ubuntu-sdk-ide is here [3], note I'm not using the LXC sdk yet and the same issue occurs on both the desktop and sdk-desktop kits.

0 - http://pastebin.ubuntu.com/19175208/
1 - http://pastebin.ubuntu.com/19175229/
2 - http://pastebin.ubuntu.com/19175268/
3 - http://pastebin.ubuntu.com/19176163/

Olivier Tilloy (osomon) wrote :

Does the following patch make things better, by any chance?

=== modified file 'src/Ubuntu/CMakeLists.txt'
--- src/Ubuntu/CMakeLists.txt 2016-07-01 13:06:40 +0000
+++ src/Ubuntu/CMakeLists.txt 2016-07-12 21:18:57 +0000
@@ -23,7 +23,7 @@
     OUTPUT_VARIABLE UBUNTU_VERSION OUTPUT_STRIP_TRAILING_WHITESPACE)
 add_definitions(-DUBUNTU_VERSION="${UBUNTU_VERSION}")

-execute_process(COMMAND ${XVFB_COMMAND} qmlscene --quit ${CMAKE_CURRENT_SOURCE_DIR}/chromium-version.qml
+execute_process(COMMAND ${XVFB_COMMAND} qmlscene -platform minimal --quit ${CMAKE_CURRENT_SOURCE_DIR}/chromium-version.qml
     OUTPUT_VARIABLE CHROMIUM_VERSION OUTPUT_STRIP_TRAILING_WHITESPACE)
 string(REGEX MATCH "\\[(.*)\\]" _ ${CHROMIUM_VERSION})
 set(CHROMIUM_VERSION ${CMAKE_MATCH_1})

Andrew Hayzen (ahayzen) wrote :

I tried the change in comment 7, and now it errors with:
'This application failed to start because it could not find or load the Qt platform plugin "minimal"'

Full logs here [4] [5].

4 - http://pastebin.ubuntu.com/19270432/
5 - http://pastebin.ubuntu.com/19270459/

Olivier Tilloy (osomon) wrote :

Okay, so same problem really, except that now the QtCreator environment fails to locate the minimal plugin instead of the xcb one. I’m puzzled as it works just fine here on my laptop. There must be something different in our configurations.

@Andrew: could you make sure that you select the right Generator in the Run CMake popup "Ubuntu SDK Desktop Kit" is the right one?

Andrew Hayzen (ahayzen) wrote :

I've been trying both 'Desktop' and 'Ubuntu SDK Desktop Kit', resulting in the same error. If you need logs a particular one let me know.

Olivier Tilloy (osomon) on 2016-08-24
Changed in webbrowser-app (Ubuntu):
assignee: nobody → Olivier Tilloy (osomon)
importance: Undecided → High
status: Incomplete → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package webbrowser-app - 0.23+17.04.20161024.1-0ubuntu1

---------------
webbrowser-app (0.23+17.04.20161024.1-0ubuntu1) zesty; urgency=medium

  [ Andrew Hayzen ]
  * Fix for issue where many tabs causes close button to overlap other
    tabs (LP: #1473630)
  * When page has started, stopped, redirected or errored clear cache for
    history update - which prevents incorrect titles in being set
    (LP: #1603835)
  * Add autopilot tests javascript dialogs to webbrowser and
    webapp-container - alertDialog, beforeUnloadDialog, confirmDialog and
    promptDialog (LP: #1633040)
  * Add user-agent override to display the new twitter mobile interface
    (LP: #1577834)

  [ Florian Boucault ]
  * Improved startup time by 800ms by delaying QML compilation and making
    it asynchronous

  [ Olivier Tilloy ]
  * Replace chromium version in UA overrides at runtime, not at build
    time (LP: #1599695)
  * Initial support for generating a snap package for webbrowser-app
    (LP: #1629009)
  * Do not persist references to incognito downloads on disk
    (LP: #1625519)
  * Increase test coverage (to 97.5%) for DownloadsModel (LP: #1534102)
  * Various performance optimizations linked to load events
    (LP: #1611680)
  * Ensure a tab is loaded when re-opened (LP: #1632246)
  * Fix drag'n'drop of bookmarks within the new tab view (LP: #1584868)
  * Work around a limitation in the sound and microphone policy groups
    to "fix" sound in yakkety an zesty (LP: #1632620)

 -- Olivier Tilloy <email address hidden> Mon, 24 Oct 2016 13:51:59 +0000

Changed in webbrowser-app (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers