First tab is always reloaded when the session is restored

Bug #1580290 reported by Michal Predotka on 2016-05-10
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Bill Filler
webbrowser-app (Ubuntu)
High
Olivier Tilloy
Xenial
Undecided
Unassigned

Bug Description

bq M10 rc-proposed OS build 100
If I have few tabs open and in the first tab is a youtube video, it will start playing even if that tap is in the background after restarting the Browser.

Steps to reproduce:
1. Start Browser
2. Open a tab with a youtube video in it, for example http://summit.ubuntu.com/uos-1605/meeting/22651/convergent-ubuntu-apps
3. Open few more tabs with other websites
4. If necessary move the tab with the video so it's the first from the left
5. Select any other tab
6. Close Browser
7. Start Browser again

Expected result:
I don't hear the sound from the video in the background tab.

What happens instead:
I hear the sound from the video in the background tab.

Related branches

Olivier Tilloy (osomon) wrote :

I can reliably reproduce the issue. What seems to happen is that the first tab in the list is always loaded at startup, regardless of whether there are other open tabs and regardless of the current tab index. This is an unexpected behaviour, only the current tab should be reloaded.

Changed in webbrowser-app (Ubuntu):
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Olivier Tilloy (osomon)
summary: - Video plays in background tab
+ First tab is always reloaded when the session is restored
Olivier Tilloy (osomon) on 2016-05-19
Changed in webbrowser-app (Ubuntu):
status: Confirmed → In Progress
Changed in canonical-devices-system-image:
status: New → Fix Committed
importance: Undecided → High
assignee: nobody → Bill Filler (bfiller)
milestone: none → 12
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package webbrowser-app - 0.23+16.10.20160519-0ubuntu1

---------------
webbrowser-app (0.23+16.10.20160519-0ubuntu1) yakkety; urgency=medium

  * Display the currently hovered hyperlink’s target URL in an overlay.
    (LP: #1499775)
  * Introduce a BrowserPage type for consistency between all pages, and
    use the UITK Page and PageHeader types. (LP: #1511137)
  * Keep the securityStatus property of the address bar always in sync
    with the current webview. (LP: #1581025)
  * Minor packaging updates.
  * Only load the current tab when the session is restored. (LP:
    #1580290)
  * Set a minimum width and height on the browser window. (LP: #1581259)
  * Use QStringLiteral instead of QString in config.h.in.

 -- Olivier Tilloy <email address hidden> Thu, 19 May 2016 18:39:35 +0000

Changed in webbrowser-app (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released

Hello Michal, or anyone else affected,

Accepted webbrowser-app into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/webbrowser-app/0.23+16.04.20161028-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in webbrowser-app (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed
Michal Predotka (mpredotka) wrote :

Hi.
I'm not sure how can I do the testing as that bug was affecting me on Ubuntu tablet. I don't use this app on Ubuntu desktop.

Olivier Tilloy (osomon) wrote :

@Michal: the bug is not device-specific, it’s also affecting desktop users. You can help validating the fix if you have a desktop/laptop running xenial. Thanks!

Olivier Tilloy (osomon) wrote :

Tested and verified in an up-to-date xenial amd64 VM, with webbrowser-app 0.23+16.04.20161028-0ubuntu1.

I verified that the first tab doesn’t get reloaded at startup if another tab was previously selected.

tags: added: verification-done
removed: verification-needed
Steve Langasek (vorlon) wrote :

Hello Michal, or anyone else affected,

Accepted webbrowser-app into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/webbrowser-app/0.23+16.04.20161028-0ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: removed: verification-done
tags: added: verification-needed
Michal Predotka (mpredotka) wrote :

Hi,

I've just tested this version on my Ubuntu desktop running 16.04LTS. The bug seems to be fixed :)

Olivier Tilloy (osomon) wrote :

Tested and verified in an up-to-date xenial amd64 VM, with webbrowser-app 0.23+16.04.20161028-0ubuntu2.

I verified that the first tab doesn’t get reloaded at startup if another tab was previously selected.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package webbrowser-app - 0.23+16.04.20161028-0ubuntu2

---------------
webbrowser-app (0.23+16.04.20161028-0ubuntu2) xenial; urgency=medium

  * SRU for selected bug fixes:
    - LP: #1565055: support for google hangouts
    - LP: #1573017: SAML detection logic broken in webapp container
    - LP: #1572673: invalid variable access error in webapp container
    - LP: #1466427: dynamic Ubuntu version in default UA string
    - LP: #1576639: fine-tune the custom memory-pressure handler
    - LP: #1581025: secure connection icon not showing
    - LP: #1580290: only load the current tab when the session is restored
    - LP: #1577806: browser and container open under the same instance
    - LP: #1565063: dynamic Chromium version in default UA string

 -- Olivier Tilloy <email address hidden> Fri, 28 Oct 2016 09:17:33 +0000

Changed in webbrowser-app (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for webbrowser-app has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers