Sharing from webbrowserapp should include title of the page

Bug #1571361 reported by Dario Cavedon on 2016-04-17
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Medium
Bill Filler
The Webapps-core project
Medium
Alexandre Abreu
webapps-sprint
Undecided
Unassigned
content-hub (Ubuntu)
Medium
Ken VanDine
messaging-app (Ubuntu)
Undecided
Unassigned
webbrowser-app (Ubuntu)
Medium
Olivier Tilloy

Bug Description

Sharing a page from webbrowser should include the title of the page, not only the URL. Steps to reproduce:
- Open webbrowser
- Open a web site
- Share it via "share" button in the top right of the browser
- Choose one of the possible apps (e.g. Twitter)
- It take you to Twitter app, composing a new tweet
- The new tweet has only the URL of the web page

Ubuntu Phone on Meizu MX4 OTA 10.1

Related branches

Olivier Tilloy (osomon) wrote :

As can be seen here: https://bazaar.launchpad.net/~phablet-team/webbrowser-app/trunk/view/head:/src/app/Share.qml#L51

The browser does share both the URL and the title, so it looks like the problem might be on the receiving end, i.e. the twitter webapp. I’m not familiar with that part of the webapp container, assigning to Alex for confirmation.

Changed in webbrowser-app (Ubuntu):
assignee: nobody → Alexandre Abreu (abreu-alexandre)
Torsten Franz (torsten.franz) wrote :

In the dekko browser is also only the url of the website like at the twitter app.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in webbrowser-app (Ubuntu):
status: New → Confirmed
Olivier Tilloy (osomon) wrote :

I’m seeing this in dekko’s log file when sharing a URL from the browser:

qml: [handleContentHubImport] [INFO] ItemText:
qml: [handleContentHubImport] [INFO] ItemUrl: http://m.slashdot.org/
qml: [handleContentHubImport] [INFO] ContentType is Link: http://m.slashdot.org/
qml: [handleContentHubImport] [STATUS] Appending to text body
qml: [ComposePage::appendTextToBody] [INFO] passing text to composer: http://m.slashdot.org/
qml: Appending text to body: http://m.slashdot.org/
qml: [handleContentHubImport] [STATUS] Complete

So it looks like the title of the page is not shared, indeed, which probably is an issue in the browser (or in content-hub itself, need to investigate). That said, dekko doesn’t use the link title either, see https://git.launchpad.net/dekko/tree/qml/main.qml#n146. So I’ll mark dekko also affected.

Olivier Tilloy (osomon) wrote :

I’ve addressed an issue in the browser (see linked branch) which wasn’t sharing the page title along with the URL.
However dekko is still not getting the page title, so I suspect there may be an issue in the content hub itself. Adding a task for it.

Changed in webbrowser-app (Ubuntu):
assignee: Alexandre Abreu (abreu-alexandre) → Olivier Tilloy (osomon)
importance: Undecided → Medium
status: Confirmed → In Progress
Dan Chapman  (dpniel) wrote :

Ah! I hadn't noticed the page title was also available along with the link.

So in Dekko the page title needs to be added as the message subject. Simple enough to add :-)

Changed in dekko:
status: New → Triaged
importance: Undecided → Medium
milestone: none → 1.0-beta
assignee: nobody → Dan Chapman  (dpniel)
Dan Chapman  (dpniel) wrote :

@Olivier did you modify Dekko in any way to find out it still isn't receiving the title?

At the moment the code just assumes only a link is available with ContentType.Link and doesn't check the text property of the ContentItem for a value.

Dan Chapman  (dpniel) wrote :

scrap that last comment. Just realised it logs the text value even if it doesn't sue it :-)

Olivier Tilloy (osomon) wrote :

Yes, dekko’s logging is proving very useful!

Adding the webapps-core project to handle the title in the webapps themselves ...

Changed in webapps-core:
assignee: nobody → Alexandre Abreu (abreu-alexandre)
importance: Undecided → Medium
status: New → Confirmed
Ken VanDine (ken-vandine) wrote :

It looks like when the transfer is charged, we are ignoring the text property if there is a url. We should ensure all properties set on the item makes it through to the dest app.

Changed in content-hub (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Ken VanDine (ken-vandine)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package webbrowser-app - 0.23+16.04.20160509.3-0ubuntu1

---------------
webbrowser-app (0.23+16.04.20160509.3-0ubuntu1) xenial; urgency=medium

  [ CI Train Bot ]
  * Resync trunk.

  [ Olivier Tilloy ]
  * Fine-tune the custom memory-pressure handler, from data gathered on
    several devices. (LP: #1576639)
  * Update translation template.

 -- Olivier Tilloy <email address hidden> Mon, 09 May 2016 17:56:03 +0000

Changed in webbrowser-app (Ubuntu):
status: In Progress → Fix Released
Bill Filler (bfiller) on 2016-06-06
Changed in canonical-devices-system-image:
milestone: none → 12
assignee: nobody → Bill Filler (bfiller)
importance: Undecided → Medium
status: New → Confirmed
Changed in webapps-core:
status: Confirmed → In Progress
Bill Filler (bfiller) wrote :

This needs a content-hub change still

Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Changed in content-hub (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package content-hub - 0.1+16.10.20160610.2-0ubuntu1

---------------
content-hub (0.1+16.10.20160610.2-0ubuntu1) yakkety; urgency=medium

  * Ensure all the properties are set when the url is set on a
    ContentItem (LP: #1571361)

 -- Ken VanDine <email address hidden> Fri, 10 Jun 2016 14:02:46 +0000

Changed in content-hub (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
quandan (2508837716-y) wrote :

hi guys, i've seen the interesting situation here in different apps , isn't shared webpage supposed to be displaying both page tittle and URL though every app ?

current build number: 375
device name: krillin
channel: ubuntu-touch/rc-proposed/bq-aquaris.en
last update: 2016-07-03 23:26:54
version version: 375
version ubuntu: 20160702
version device: 20160606-ab415b2
version custom: 20160701-981-38-14

Steps:
1.Open browser app and visit a valid URL
2.Tap on share button to share the webpage to message app and twitter

Expectation:
No matter what app you choose to share , they all should include both page tittle and URL

Actual result:
In message app, there is only page tittle
In twitter, there is only URL

quandan (2508837716-y) wrote :
Olivier Tilloy (osomon) wrote :

Confirmed. dekko and telegram only use the URL. But as demonstrated by the fact that the messaging app uses the page title, the problem is not in the browser app (it exposes both URL and title), it is in the destination app that chooses to use only one of the two items.

Apps like telegram are capable of displaying an embedded preview of the page along with the title when given a URL, so it seems reasonable that they would use only the URL. But messaging app should clearly use the URL too, I’ll mark it affected.

Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
Dan Chapman  (dpniel) on 2016-08-24
Changed in dekko:
status: Triaged → Fix Committed
Changed in webapps-core:
status: In Progress → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers