[webapps] Cannot save image

Bug #1557566 reported by Víctor R. Ruiz
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
David Barth
The Webapps-core project
High
Alexandre Abreu
webapps-sprint
High
Alexandre Abreu
apparmor-easyprof-ubuntu (Ubuntu)
Undecided
Unassigned
webbrowser-app (Ubuntu)
Undecided
Alexandre Abreu

Bug Description

Test case.
- Open Twitter app.
- Long tap on an image (e.g. an avatar) to display the context menu.
- Select option to save image.
- Select Gallery app.

Expected result.
- Image is saved in the gallery app.

Actual result.
- Nothing happens.

There are some apparmor denials in the dbus.log: http://paste.ubuntu.com/15391947/

current build number: 280
device name: krillin
channel: ubuntu-touch/rc-proposed/bq-aquaris.en

Related branches

Olivier Tilloy (osomon)
Changed in webbrowser-app (Ubuntu):
status: New → Confirmed
Revision history for this message
Alexandre Abreu (abreu-alexandre) wrote :

I am able to repro it on arale r269 with the same logs,

Adding apparmor-easyprof-ubuntu to the bug

Changed in canonical-devices-system-image:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → David Barth (dbarth)
David Barth (dbarth)
Changed in webbrowser-app (Ubuntu):
assignee: nobody → Alexandre Abreu (abreu-alexandre)
Changed in canonical-devices-system-image:
milestone: none → 11
Changed in webapps-sprint:
assignee: nobody → Alexandre Abreu (abreu-alexandre)
milestone: none → sprint-20
importance: Undecided → High
status: New → Confirmed
Revision history for this message
Alexandre Abreu (abreu-alexandre) wrote :

Marking as invalid for webapp-container since it seems to be apparmor related.

Changed in webapps-sprint:
milestone: sprint-20 → sprint-21
Changed in webbrowser-app (Ubuntu):
status: Confirmed → Invalid
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apparmor-easyprof-ubuntu (Ubuntu):
status: New → Confirmed
David Barth (dbarth)
Changed in webapps-sprint:
milestone: sprint-21 → sprint-22
Revision history for this message
Jamie Strandboge (jdstrand) wrote :

Have you specified the content_exchange policy group?

tags: added: application-confinement
Revision history for this message
Alexandre Abreu (abreu-alexandre) wrote :
Revision history for this message
Jamie Strandboge (jdstrand) wrote :

After looking at the denials more closely, you need content_exchange_source (export vs import).

Changed in webapps-core:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Alexandre Abreu (abreu-alexandre)
Changed in webapps-sprint:
status: Confirmed → In Progress
Changed in webapps-core:
status: Confirmed → In Progress
Changed in apparmor-easyprof-ubuntu (Ubuntu):
status: Confirmed → Invalid
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
milestone: 11 → 12
David Barth (dbarth)
Changed in webapps-sprint:
milestone: sprint-22 → sprint-23
Changed in webapps-core:
status: In Progress → Fix Committed
Changed in webapps-sprint:
status: In Progress → Fix Committed
David Barth (dbarth)
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Changed in webapps-core:
status: Fix Committed → Fix Released
Changed in webapps-sprint:
status: Fix Committed → Fix Released
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers