4 autopilot test failures (related to ESC key) on desktop

Bug #1546627 reported by Olivier Tilloy on 2016-02-17
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Zoltan Balogh
ubuntu-ui-toolkit (Ubuntu)
High
Olivier Tilloy
webbrowser-app (Ubuntu)
High
Olivier Tilloy

Bug Description

I just upgraded my desktop machine from wily to xenial, and 4 autopilot tests are now consistently failing:

webbrowser_app.tests.test_keyboard.TestKeyboard.test_find_in_page_ctrl_f
webbrowser_app.tests.test_keyboard.TestKeyboard.test_escape_from_address_bar
webbrowser_app.tests.test_keyboard.TestKeyboard.test_bookmark
webbrowser_app.tests.test_suggestions.TestSuggestions.test_suggestions_escape_on_addressbar

All of them involve pressing the ESC key and expecting something to happen, which is where they fail. I suspect something changed in the UITK (it might have gained default handling of ESC for various components, which overrides our custom implementation?). Needs further investigation.

Related branches

Olivier Tilloy (osomon) on 2016-02-17
Changed in webbrowser-app (Ubuntu):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Olivier Tilloy (osomon)
Olivier Tilloy (osomon) wrote :

At least 3 of the 4 failures appear to be caused by a recent change in the UITK (the fix for bug #1523828). Keys.onEscapePressed accepts the event by default, so it’s not bubbled up, whereas it should if there is no popover to close.

Olivier Tilloy (osomon) wrote :

In fact the 4 failures are a consequence of the fix for bug #1523828. The third one is a bit trickier to address though, as a child item of the popover is catching the ESC press event, so there is no way to override it.

Changed in ubuntu-ui-toolkit (Ubuntu):
assignee: nobody → Olivier Tilloy (osomon)
status: New → In Progress
Olivier Tilloy (osomon) wrote :

The third issue is tracked by a separate bug report: bug #1546677.

Changed in webbrowser-app (Ubuntu):
status: Triaged → In Progress
Changed in ubuntu-ui-toolkit (Ubuntu):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package webbrowser-app - 0.23+16.04.20160223-0ubuntu1

---------------
webbrowser-app (0.23+16.04.20160223-0ubuntu1) xenial; urgency=medium

  [ CI Train Bot ]
  * Resync trunk.

  [ Olivier Tilloy ]
  * Remove the 'formFactor' context property, and replace all its uses
    by more meaningful conditions. (LP: #1446904, #1542375)
  * Update translation template.
  * Work around a bug in the UITK that prevents touch scrolling to the
    left of the address bar by ensuring that the x coordinate of the
    text field is an integer. (LP: #1546346)
  * Work around bug #1546677 (UITK), by destroying the bookmark options
    popover instead of hiding it. (LP: #1546627, #1546677)

 -- Olivier Tilloy <email address hidden> Tue, 23 Feb 2016 11:24:49 +0000

Changed in webbrowser-app (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (7.0 KiB)

This bug was fixed in the package ubuntu-ui-toolkit - 1.3.1872+16.04.20160308-0ubuntu1

---------------
ubuntu-ui-toolkit (1.3.1872+16.04.20160308-0ubuntu1) xenial; urgency=medium

  [ Timo Jyrinki ]
  * Fix gles unit test skipping.
  * Add s390x to the unit test skipping architectures
  * UITK test plan - wily -> xenial. Fixes LP: #1544490

  [ Christian Dywan ]
  * Print errors when QuickUtils fails to create a component.
  * unit tests shouldn't use deprecated Dialog.callera
  * Correctly count only test case results. The result= value is used in suites
    and results.
  * Skip tst_pagehead_visible flakes on non-arm. Fixes LP: #1534651
  * Skip flaky tst_mousefilterTest::doubleClicked. Fixes LP: #1542215
  * Suppress click signal if releasing outside of ListItem. Fixes LP: #1541148.
  * Use gdb in runtest.sh to produce backtraces.
  * Arrow keys change value of a Slider. Fixes LP: #1523824.
  * Only use Maliit when enabled explicitly in the environment

  [ Oliver Tilloy ]
  * Do not try to assign to non-existent property "activeFocusOnPress".
    Fixes LP: #1532953
  * Bubble up ESC key press event if there is no popover to close.
    Fixes LP: #1546627

  [ Loïc Molinari ]
  * Added private items and nodes for the new component styles.
    Fixes LP: #1523836
  * Made use of new private Frame item for the focusing.
  * Fixed performance monitor crash because of a NULL timer pointer dereference.
    Fixes LP: #1546986
  * Fixed performance monitor dangling pointer crash. Fixes LP: #1546984
  * [ProportionalShape] Ensured width/height ratio is correct with default values.
    Fixes LP: #1546546
  * Added a workaround to prevent a crash while changing the QPA scale factor.

  [ Florian Boucault ]
  * Always on performance monitor that logs frames that too long to render.
  * MainView: proceed to selecting the theme automatically at startup too.
    Fixes LP: #1535819
  * MainView: when no gradient color is needed for the background, rely on
    QQuickWindow's GL clear color. Lessens overdraw considerably for most
    apps. Fixes LP: #1439133.
  * Panel: MathUtils used without import prefix was leading to undefined
    reference.
  * Label: use native rendering on low dpi screens (GRID_UNIT_PX <= 10) for
    sharper looking text.
  * Gallery: added palette browser to Colors page.

  [ Tim Peeters ]
  * Support scrolling in ListViews with horizontal orientation to the
    qquicklistview CPO.
  * Add background to AppHeader and remove contents clipping from MainView.
    Fixes LP: #1531016, LP: #1531457.
  * Hide AppHeader when using AdaptivePageLayout. Fixes bug 1531871.
    Fixes LP: #1531871.
  * Implement horizontal flicking in the flickable autopilot CPO.
  * Re-order to list of pages in the gallery to be alphabetical.
  * Fix the autopilot failures introduced with the horizontal scrolling in
    the Flickable CPO.
  * Update documentation for MainView, Page, AdaptivePageLayout to use the new
    PageHeader in all examples. Deprecate old properties. Fixes LP: #1540574
  * Add 'animate' property to new internal AppHeaderBase, and do not show a
    header animation when starting an app without header.
    Fixes LP: #1518002, LP: #1524901.
 ...

Read more...

Changed in ubuntu-ui-toolkit (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: New → Fix Committed
importance: Undecided → High
assignee: nobody → Zoltan Balogh (bzoltan)
milestone: none → ww08-2016
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers