Not able to download office documents through webbrowser-app

Bug #1523452 reported by Stefano Verzegnassi on 2015-12-07
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Medium
Bill Filler
webbrowser-app (Ubuntu)
Medium
Olivier Tilloy

Bug Description

We've recently released an update to Document Viewer which is now capable to open LibreOffice/MS-Office documents.

Even if the application is installed on the device, it's not possible to download office files through browser-app, since no peer is available for handling the content.

I had a look at:
    http://bazaar.launchpad.net/~phablet-team/webbrowser-app/trunk/view/head:/src/app/FileExtensionMapper.js

And it seems that these documents are recognized as ContentType.Unknown.

What we'd need is to add the support to the following file extensions: doc, docx, xls, xlsx, ppt, pptx, odt, ods, odp.
Alternatively, this is the list of mime types supported by Document Viewer: [1]

[1] from line 52, http://bazaar.launchpad.net/~ubuntu-docviewer-dev/ubuntu-docviewer-app/lo-viewer/view/head:/src/plugin/file-qml-plugin/docviewerutils.cpp

Related branches

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in webbrowser-app (Ubuntu):
status: New → Confirmed
Olivier Tilloy (osomon) on 2015-12-07
Changed in webbrowser-app (Ubuntu):
assignee: nobody → Olivier Tilloy (osomon)
importance: Undecided → Medium
status: Confirmed → In Progress
Changed in canonical-devices-system-image:
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Bill Filler (bfiller)
milestone: none → ww02-2016
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package webbrowser-app - 0.23+16.04.20151222.1-0ubuntu1

---------------
webbrowser-app (0.23+16.04.20151222.1-0ubuntu1) xenial; urgency=medium

  * Add keyboard shorcuts for 'next' (Ctrl+G) and 'previous'
    (Ctrl+Shift+G) while in find-in-page mode. (LP: #1522152)
  * Do not allow interacting with tabs and the chrome while the settings
    page is shown. (LP: #1524353)
  * Fix a crash when clearing the navigation history while the new tab
    view is open. (LP: #1525937)
  * Fix deleting multiple domains from the history view. Add unit tests
    for the HistoryView component. (LP: #1527144)
  * Fix some obvious issues in PreviewManager. (LP: #1519019)
  * Fix the tab preview sometimes covering the tab chrome, in the tabs
    view. Offset tab previews by 1px to cover the semi-transparent
    horizontal line at the bottom of the tab chrome asset. (LP:
    #1520624)
  * Recognize openoffice and MS-office file formats as documents, now
    that the document viewer app knows how to render them. (LP:
    #1523452)
  * Update translation template.
  * Use the screen size (diagonal in millimeters) to determine which
    default UA string and which UA overrides to use. An empirical
    threshold of 19cm is being used, it is subject to further
    adjustments. (LP: #1504084)

 -- Olivier Tilloy <email address hidden> Tue, 22 Dec 2015 18:15:54 +0000

Changed in webbrowser-app (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers