some tab previews are missing their handles and close buttons

Bug #1520624 reported by Oliver Grawert on 2015-11-27
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Bill Filler
webbrowser-app (Ubuntu)
High
Olivier Tilloy

Bug Description

after todays update about half of my tabs in the browser session had no handles and close buttons anymore ... both re-appear once i tapped the tab once to load it ...

http://i.imgur.com/0Etae8N.png

in the screenshot you see the phoronix and endgadget tabs exposing the issue, the gizmodo tab used to have the same issue but grew a tab header when i opened it.

Related branches

Olivier Tilloy (osomon) wrote :

Just seen it on my krillin running the latest rc-proposed.

Changed in webbrowser-app (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Olivier Tilloy (osomon) on 2015-12-01
summary: - after update some tabs are missing their handles and cloes buttons
+ some tab previews are missing their handles and close buttons
Bill Filler (bfiller) on 2015-12-01
Changed in canonical-devices-system-image:
milestone: none → ww02-2016
assignee: nobody → Bill Filler (bfiller)
importance: Undecided → High
status: New → Confirmed
Olivier Tilloy (osomon) wrote :

I did some measurements on the attached screenshots (the one attached to that bug and the one attached to the duplicate bug report), and it seems the webview capture overlaps the tab chrome, which is there but below the capture (which explains why in bug #1524815 the reporter was able to tap the close button guessing where it should be, and the tab was closed).

The TabPreview component is a column, basically built like this:

  Column {
    TabChrome {}
    Item { id: capture }
  }

So it’s unclear to me how the capture could possibly overlap the chrome.

Olivier Tilloy (osomon) wrote :

For the record, this looks like it’s yet another regression that was introduced by revision 1280 (tab switching animation improvements). The preview image gained a negative top margin of the height of the tab chrome, which would explain the issue (it doesn’t explain why the issue is not apparent for all tabs though).

Changed in webbrowser-app (Ubuntu):
assignee: nobody → Olivier Tilloy (osomon)
status: Confirmed → In Progress
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package webbrowser-app - 0.23+16.04.20151222.1-0ubuntu1

---------------
webbrowser-app (0.23+16.04.20151222.1-0ubuntu1) xenial; urgency=medium

  * Add keyboard shorcuts for 'next' (Ctrl+G) and 'previous'
    (Ctrl+Shift+G) while in find-in-page mode. (LP: #1522152)
  * Do not allow interacting with tabs and the chrome while the settings
    page is shown. (LP: #1524353)
  * Fix a crash when clearing the navigation history while the new tab
    view is open. (LP: #1525937)
  * Fix deleting multiple domains from the history view. Add unit tests
    for the HistoryView component. (LP: #1527144)
  * Fix some obvious issues in PreviewManager. (LP: #1519019)
  * Fix the tab preview sometimes covering the tab chrome, in the tabs
    view. Offset tab previews by 1px to cover the semi-transparent
    horizontal line at the bottom of the tab chrome asset. (LP:
    #1520624)
  * Recognize openoffice and MS-office file formats as documents, now
    that the document viewer app knows how to render them. (LP:
    #1523452)
  * Update translation template.
  * Use the screen size (diagonal in millimeters) to determine which
    default UA string and which UA overrides to use. An empirical
    threshold of 19cm is being used, it is subject to further
    adjustments. (LP: #1504084)

 -- Olivier Tilloy <email address hidden> Tue, 22 Dec 2015 18:15:54 +0000

Changed in webbrowser-app (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers