touch events go through expanded history view header

Bug #1518904 reported by Olivier Tilloy on 2015-11-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
Medium
Bill Filler
webbrowser-app (Ubuntu)
Medium
Olivier Tilloy

Bug Description

Steps to reproduce (on a touch device or on desktop, in narrow mode):

 1) from the drawer menu, open the history view
 2) scroll it down slightly to ensure that an entry for a domain name is at the top of the screen/window
 3) tap/click any entry in the list to open the expanded view for that domain
 4) in the expanded view, tap/click on the header (left of the "Less" button)

Expected result: nothing happens

Current result: a new expanded view opens for the entry that was at the top of the history view, because tap/click events go through the header.

Related branches

Changed in canonical-devices-system-image:
status: New → Fix Committed
importance: Undecided → Medium
assignee: nobody → Bill Filler (bfiller)
milestone: none → ww02-2016
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package webbrowser-app - 0.23+16.04.20151126-0ubuntu1

---------------
webbrowser-app (0.23+16.04.20151126-0ubuntu1) xenial; urgency=medium

  [ CI Train Bot ]
  * Resync trunk.

  [ Olivier Tilloy ]
  * Add missing import statements, and add missing unit tests for
    BookmarksView.qml and BookmarksViewWide.qml. (LP: #1515631)
  * Code cleanup: remove unused include statements and forward
    declarations, and convert unnecessary include statements to forward
    declarations.
  * Make the drawer menu flickable so that all its actions can be
    accessed even on a small mobile screen in landscape orientation.
    (LP: #1513348)
  * Prevent click events from propagating through the expanded history
    view to the view below. (LP: #1518904)
  * Use the capture device display names instead of their unique ID.
    (LP: #1518931)

 -- Olivier Tilloy <email address hidden> Thu, 26 Nov 2015 13:42:25 +0000

Changed in webbrowser-app (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers