[regression] All options in the drawer menu always visible

Bug #1495297 reported by Olivier Tilloy
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
webbrowser-app (Ubuntu)
Fix Released
High
Olivier Tilloy

Bug Description

Since the landing of the UITK version 1.3.1627+15.04.20150908-0ubuntu1, all the options in the drawer menu are always visible, even those that shouldn’t be (those are disabled, but still visible).

This breaks a couple of autopilot tests in the webbrowser-app test suite:

    webbrowser_app.tests.test_findinpage.TestFindInPage.test_find_in_page_not_in_menu_in_new_tab
    webbrowser_app.tests.test_private.TestPrivateView.test_going_in_and_out_private_mode

Related branches

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package webbrowser-app - 0.23+15.10.20150913-0ubuntu1

---------------
webbrowser-app (0.23+15.10.20150913-0ubuntu1) wily; urgency=medium

  [ CI Train Bot ]
  * New rebuild forced.
  * Resync trunk. added: po/mr.po

  [ Olivier Tilloy ]
  * Allow saving canvas images from the context menu.
  * Handle HTTP authentication requests by showing an authentication
    dialog. (LP: #1422534)
  * Remove the workaround for bug #1471181 now that oxide 1.9 has been
    released with a proper fix. (LP: #1471181)
  * Set the 'visible' property of actions instead of 'enabled' to ensure
    the visibility of the corresponding entries in the drawer menu
    matches. (LP: #1495297)
  * Use SIGABRT instead of SIGSEGV to crash a renderer process in tests.
    (LP: #1493825)
  * Use the new WebContext.userAgentOverrides API (new in Oxide 1.9).
    (LP: #1410753)

  [ Ugo Riboni ]
  * Handle HTTP authentication requests by showing an authentication
    dialog. (LP: #1422534)

 -- Olivier Tilloy <email address hidden> Sun, 13 Sep 2015 21:25:02 +0000

Changed in webbrowser-app (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Olivier Tilloy (osomon) wrote :

Re-opening as the fix for bug #1495408 in the UITK re-introduced the issue. Reverting the fix in webbrowser-app does the trick.

Changed in webbrowser-app (Ubuntu):
status: Fix Released → Confirmed
status: Confirmed → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package webbrowser-app - 0.23+15.10.20150928-0ubuntu1

---------------
webbrowser-app (0.23+15.10.20150928-0ubuntu1) wily; urgency=medium

  [ CI Train Bot ]
  * New rebuild forced.
  * Resync trunk.

  [ Michael Sheldon ]
  * Add support for alternative mimetype header for vcards (LP:
    #1498992)

  [ Olivier Tilloy ]
  * Add a context menu to each tab in the tab bar, allowing to insert a
    new tab just after, close or reload the current tab.
  * Fix a couple of autopilot test failures on desktop. (LP: #1495297,
    #1499411)
  * Update translation template.

  [ Ugo Riboni ]
  * Add a context menu to each tab in the tab bar, allowing to insert a
    new tab just after, close or reload the current tab.

 -- Olivier Tilloy <email address hidden> Mon, 28 Sep 2015 08:15:15 +0000

Changed in webbrowser-app (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers