When resized to narrow, history view becomes blank

Bug #1484555 reported by Olivier Tilloy
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
webbrowser-app (Ubuntu)
Fix Released
Medium
Arthur Mello

Bug Description

The responsive history view landed with webbrowser-app 0.23+15.10.20150812.1-0ubuntu1, so that there are two different layouts depending on the width of the window.

To reproduce the issue:
 1) launch the browser on desktop
 2) open the history view (with e.g. Ctrl+H)
 3) resize the window horizontally to narrow it

Expected result: at some point the narrow layout replaces the wide layout.
Current result: at the point where the narrow layout replaces the wide layout, the view is empty.

I’m suspecting that the model is not correctly set when switching view, due to implementation that delays setting the model by 1ms with a Timer (http://bazaar.launchpad.net/~phablet-team/webbrowser-app/trunk/view/head:/src/app/webbrowser/Browser.qml#L768).

Related branches

Arthur Mello (artmello)
Changed in webbrowser-app (Ubuntu):
status: Triaged → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package webbrowser-app - 0.23+15.10.20150817-0ubuntu1

---------------
webbrowser-app (0.23+15.10.20150817-0ubuntu1) wily; urgency=medium

  [ Arthur Mello ]
  * Make sure to set the historyModel to the HistoryView component when
    browser wide property changes (LP: #1484555)
  * Wait for OptionSelector's collapsing transition to finish (LP:
    #1484175)

  [ Colin Watson ]
  * Fix versioned dependencies on qtdeclarative5-ubuntu-ui-toolkit-
    plugin to allow qtdeclarative5-ubuntu-ui-toolkit-plugin-gles.

 -- CI Train Bot <email address hidden> Mon, 17 Aug 2015 09:59:08 +0000

Changed in webbrowser-app (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers