[convergence] Save image option not appearing when right clicking on image

Bug #1477310 reported by Bill Filler
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
webbrowser-app (Ubuntu)
Medium
Olivier Tilloy

Bug Description

When running webbrowser-app on desktop, there is no option to Save Image on the context menu as there should be.

Related branches

Bill Filler (bfiller)
no longer affects: ubuntu-ux
Revision history for this message
Olivier Tilloy (osomon) wrote :

The SaveImage action is displayed only touch devices, where the content hub can handle saving the image. Ideally, we would delegate this to content hub on desktop too. Need to investigate if that’s feasible.

Changed in webbrowser-app (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
tags: added: desktop
Olivier Tilloy (osomon)
tags: added: contextmenu
Olivier Tilloy (osomon)
Changed in webbrowser-app (Ubuntu):
assignee: nobody → Olivier Tilloy (osomon)
status: Confirmed → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package webbrowser-app - 0.23+15.10.20150827.3-0ubuntu1

---------------
webbrowser-app (0.23+15.10.20150827.3-0ubuntu1) wily; urgency=medium

  [ CI Train Bot ]
  * New rebuild forced.
  * Resync trunk.

  [ Olivier Tilloy ]
  * Use the contextMenu API new in oxide 1.8. Update the visuals for the
    context menu in narrow and wide form factors. Add text editing
    commands to the context menu. Add unit and autopilot tests for the
    context menu features. This bumps the runtime dependency of webapp-
    container and qtdeclarative5-ubuntu-web-plugin on liboxideqt-
    qmlplugin to 1.8. This also removes the qtdeclarative5-ubuntu-web-
    plugin-assets binary package, which contained only one PNG asset
    which is not used anywhere any longer. (LP: #1477310, #1477315,
    #1471181, #1264493, #1487090, #1326070, #1477309, #1450430,
    #1438046)

 -- CI Train Bot <email address hidden> Thu, 27 Aug 2015 14:02:08 +0000

Changed in webbrowser-app (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Mateusz Stachowski (stachowski-mateusz) wrote :

Saving images now works on the desktop in 15.10 but it does weird things.

When I save image it is immediately opened in my default webbrowser. If it really must be opened after saving (totally unwanted action) then I would at least expect that it would display in default image viewer. Also where are the images saved on the desktop.

Revision history for this message
Olivier Tilloy (osomon) wrote :

Right, the desktop use case is not very well handled: since the ubuntu-download-manager is not available in main, the browser cannot depend on it, and as a consequence the download is delegated to the default browser. I filed bug #1491279 to track this issue.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers