Should ship a PNG icon instead of using the theme

Bug #1365408 reported by Michał Sawicz on 2014-09-04
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu Application Launcher
Fix Released
High
Ted Gould
Ubuntu UX
High
Matthieu James
address-book-app (Ubuntu)
High
Renato Araujo Oliveira Filho
dialer-app (Ubuntu)
High
Gustavo Pichorim Boiko
dialer-app (Ubuntu RTM)
Undecided
Unassigned
indicator-messages (Ubuntu)
Undecided
Unassigned
mediaplayer-app (Ubuntu)
High
Renato Araujo Oliveira Filho
mediaplayer-app (Ubuntu RTM)
Undecided
Unassigned
messaging-app (Ubuntu)
High
Tiago Salem Herrmann
messaging-app (Ubuntu RTM)
Undecided
Unassigned
sync-monitor (Ubuntu)
Undecided
Unassigned
ubuntu-app-launch (Ubuntu)
Undecided
Unassigned
ubuntu-system-settings (Ubuntu)
High
Ken VanDine
webbrowser-app (Ubuntu)
High
Olivier Tilloy

Bug Description

By design request, all apps, click or not, should ship their own icon as PNG instead of using icons from the theme.

Please download the respective icon from http://bazaar.launchpad.net/~ubuntu-art-pkg/ubuntu-themes/trunk/files/head:/suru-icons/apps/256/ and include in your packages.

Related branches

Michał Sawicz (saviq) on 2014-09-04
no longer affects: webbrowser-app
Sebastien Bacher (seb128) wrote :

Thanks Michał, do you know in what directory we should install those icons? /usr/share/pixmaps or in the icon theme?

Michał Sawicz (saviq) wrote :

As far as I can tell, in your own data dir.

Pat McGowan (pat-mcgowan) wrote :

I see conflicting goals here
1) we don't want random theme packs to override these
2) we do want OEMs/carriers to be able to override these

So putting the icons in each app seems wrong, or somehow we need a default location even if its not strictly part of the theme

John Lea (johnlea) on 2014-09-09
Changed in ubuntu-ux:
assignee: nobody → Matthieu James (tiheum)
importance: Undecided → High
status: New → Fix Committed
John Lea (johnlea) wrote :

@pat-mcgowan; I've followed up on this one, and apparently there has been a long conversation already about this. As I understand App icons are not currently one of the items that are in-scope for OEM theming. Matthieu and Jouni will be able to follow up with a more detailed explanation.

Changed in ubuntu-system-settings (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
importance: Undecided → High
status: New → Confirmed
tags: added: rtm14
tags: added: touch-2014-09-25
Bill Filler (bfiller) on 2014-09-10
Changed in sync-monitor (Ubuntu):
status: New → Invalid
Changed in webbrowser-app (Ubuntu):
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Olivier Tilloy (osomon)
Changed in messaging-app (Ubuntu):
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Tiago Salem Herrmann (tiagosh)
Changed in mediaplayer-app (Ubuntu):
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Renato Araujo Oliveira Filho (renatofilho)
Changed in dialer-app (Ubuntu):
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Gustavo Pichorim Boiko (boiko)
Changed in address-book-app (Ubuntu):
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Renato Araujo Oliveira Filho (renatofilho)

And about the symbolic icon used by messaging indicator. (The small mono color icon that appear on the side of the message) As I know the indicator looks for this icon on the theme.

Lars Karlitski (larsu) wrote :

I've added support for X-Ubuntu-SymbolicIcon in indictor-messages to get around the problem Renato described.

However, I'd like to get rid of that patch and make applications use the theme again. Processes that open one application icon tend to open a bunch of them, so they benefit a lot from the icon cache. Also, we already have specified ways for dealing with symbolic icons, overrides, and fallbacks; all of which we're losing with this change.

This bug doesn't give a proper rationale for this change. If it is because click packages are not allowed to install icons outside of their directory, I suggest making the installer unpack application icons and add them to the icon cache.

Matthieu James (tiheum) wrote :

I did a merge request 3 weeks ago. It's approved for a long time but unfortunately not merged yet: https://code.launchpad.net/~tiheum/ubuntu-themes/suru-icons/+merge/231533

It includes too major updates for the Suru theme:

- All the scalable colourful icons (apps and weather) have been moved to 'sources' directories in the corresponding category folders. These new directories are not mentioned in the index.theme file. This way, only the PNGs can be found by the icon lookup process. So, if a core app uses the icon from the theme, the PNG will be always displayed instead of the SVG.

- The System Settings and Browser app icons have been updated. If you want to download the latest PNG for the corresponding app, don't follow the link in the bug description but this one: http://bazaar.launchpad.net/~tiheum/ubuntu-themes/suru-icons/files/head:/suru-icons/apps/256/

Changed in address-book-app (Ubuntu):
status: Confirmed → In Progress
Changed in mediaplayer-app (Ubuntu):
status: Confirmed → In Progress
Changed in ubuntu-system-settings (Ubuntu):
status: Confirmed → In Progress
Ted Gould (ted) wrote :

The problem that compounds there is that the icon theme directory is not writable, so they can't be added the standard icon cache. We'd have to define a new icon cache that was built from the icons in click packages. Not impossible.

I think that probably a better solution for components that need to use icons in click packages to install click hooks that are appropriate for the icons they're interested in so they can build a cache of what they need. A generic cache here doesn't seem as useful when we can adequately detect changes on a per-component basis and evaluate fallbacks at package install time instead of runtime.

Ted Gould (ted) wrote :

For the OEM thememing question I think that in the cases that an OEM wanted to change the icon, it's probably not the only change they want to make to an app. We provide mechanisms for them to replace or override any click package, so replacing the click package with the icon in it makes sense as a mechanism for adjusting applications (visual or other changes).

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-system-settings - 0.3+14.10.20140917-0ubuntu1

---------------
ubuntu-system-settings (0.3+14.10.20140917-0ubuntu1) utopic; urgency=low

  [ Ken VanDine ]
  * Include an icon instead of using the themed icon (LP: #1365408) (LP:
    #1365408)

  [ Mathieu Trudel-Lapierre ]
  * [bluetooth] don't try to enable Discoverable if the device isn't
    powered yet. (LP: #1355904)
 -- Ubuntu daily release <email address hidden> Wed, 17 Sep 2014 02:19:38 +0000

Changed in ubuntu-system-settings (Ubuntu):
status: In Progress → Fix Released
Changed in address-book-app (Ubuntu):
status: In Progress → Fix Committed
Ted Gould (ted) wrote :

Adding a UAL task to support the X-Ubuntu-SymbolicIcon path handling in the desktop hook.

Changed in ubuntu-app-launch:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Ted Gould (ted)
Changed in address-book-app (Ubuntu):
status: Fix Committed → Fix Released
Olivier Tilloy (osomon) on 2014-09-25
Changed in webbrowser-app (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-messages - 13.10.1+14.10.20140925-0ubuntu1

---------------
indicator-messages (13.10.1+14.10.20140925-0ubuntu1) utopic; urgency=low

  [ Lars Uebernickel ]
  * Support X-Ubuntu-SymbolicIcon in desktop files (LP: #1365408)
 -- Ubuntu daily release <email address hidden> Thu, 25 Sep 2014 14:41:04 +0000

Changed in indicator-messages (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-app-launch - 0.4+14.10.20140925-0ubuntu1

---------------
ubuntu-app-launch (0.4+14.10.20140925-0ubuntu1) utopic; urgency=low

  [ Martin Pitt ]
  * Upstart dep updated to trunk

  [ Ted Gould ]
  * Upstart dep updated to trunk
  * Add handling for X-Ubuntu-SymbolicIcon in desktop hook (LP:
    #1365408)

  [ CI bot ]
  * Adjust upstart recommends to upstart-bin (LP: #1351306)
 -- Ubuntu daily release <email address hidden> Thu, 25 Sep 2014 14:43:28 +0000

Changed in ubuntu-app-launch (Ubuntu):
status: New → Fix Released
Ted Gould (ted) on 2014-10-02
Changed in ubuntu-app-launch:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mediaplayer-app - 0.20.5+14.10.20141002-0ubuntu1

---------------
mediaplayer-app (0.20.5+14.10.20141002-0ubuntu1) 14.09; urgency=low

  [ Akiva Avraham ]
  * upgrade: import Ubuntu.Components 1.1 import Ubuntu.Components.xxxx
    1.0 except: import Ubuntu.Components.Extras 0.1 // stayed the same
    because I could not find 1.0 in use in any other projects after a
    google search

  [ Alan Pope ]
  * Fix text.

  [ Ubuntu daily release ]
  * New rebuild forced

  [ Leo Arias ]
  * Skip the seekbar tests on the devices that do not have space for it.
    (LP: #1359040)

  [ Pawel Stolowski ]
  * Added X-Ubuntu-Default-Department-ID key to the desktop file. This
    is required by click scope to support departments for preinstalled
    applications.

  [ Renato Araujo Oliveira Filho ]
  * Added comments for TRANSLATORS.
  * Show a proper message if the video format is not supported. (LP:
    #1365497)
  * Fixed images copyright. (LP: #1194916)
  * Update application icon. Avoid using themed icons for application
    icon. Added symbolic icon. (LP: #1365408)

mediaplayer-app (0.20.5+14.10.20140918-0ubuntu1) utopic; urgency=medium

  [ Ted Gould ]
  * Register for video:/// URLs in URL dispatcher
 -- Ubuntu daily release <email address hidden> Thu, 02 Oct 2014 19:12:00 +0000

Changed in mediaplayer-app (Ubuntu RTM):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package webbrowser-app - 0.23+14.10.20141003-0ubuntu1

---------------
webbrowser-app (0.23+14.10.20141003-0ubuntu1) utopic; urgency=low

  [ CI bot ]
  * Resync trunk

  [ Alexandre Abreu ]
  * Add a simple mechanism (simpler than the one already in place) to
    override user agents for a given webapp. (LP: #1370975)

  [ Alberto Mardegan ]
  * Fix handling of host cookies

  [ Olivier Tilloy ]
  * Ship a PNG icon instead of an SVG, and install it under the app’s
    own data dir. (LP: #1365408)
  * Make an autopilot test more robust by ensuring that the drawer menu
    is dismissed but not clicked. (LP: #1365304)
  * Persistently cache favicons on disk to avoid re-downloading them
    across application runs. (LP: #1340585)
  * Ensure that at most 2 webviews are instantiated at all times, to
    reduce memory consumption. (LP: #1376418)
 -- Ubuntu daily release <email address hidden> Fri, 03 Oct 2014 14:42:27 +0000

Changed in webbrowser-app (Ubuntu):
status: In Progress → Fix Released
Changed in dialer-app (Ubuntu):
status: Confirmed → In Progress
Changed in messaging-app (Ubuntu):
status: Confirmed → In Progress
Changed in messaging-app (Ubuntu RTM):
status: New → In Progress
Changed in dialer-app (Ubuntu RTM):
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mediaplayer-app - 0.20.5+14.10.20141002-0ubuntu1

---------------
mediaplayer-app (0.20.5+14.10.20141002-0ubuntu1) 14.09; urgency=low

  [ Akiva Avraham ]
  * upgrade: import Ubuntu.Components 1.1 import Ubuntu.Components.xxxx
    1.0 except: import Ubuntu.Components.Extras 0.1 // stayed the same
    because I could not find 1.0 in use in any other projects after a
    google search

  [ Alan Pope ]
  * Fix text.

  [ Ubuntu daily release ]
  * New rebuild forced

  [ Leo Arias ]
  * Skip the seekbar tests on the devices that do not have space for it.
    (LP: #1359040)

  [ Pawel Stolowski ]
  * Added X-Ubuntu-Default-Department-ID key to the desktop file. This
    is required by click scope to support departments for preinstalled
    applications.

  [ Renato Araujo Oliveira Filho ]
  * Added comments for TRANSLATORS.
  * Show a proper message if the video format is not supported. (LP:
    #1365497)
  * Fixed images copyright. (LP: #1194916)
  * Update application icon. Avoid using themed icons for application
    icon. Added symbolic icon. (LP: #1365408)

mediaplayer-app (0.20.5+14.10.20140918-0ubuntu1) utopic; urgency=medium

  [ Ted Gould ]
  * Register for video:/// URLs in URL dispatcher
 -- Ubuntu daily release <email address hidden> Thu, 02 Oct 2014 19:12:00 +0000

Changed in mediaplayer-app (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package messaging-app - 0.1+14.10.20141007.1-0ubuntu1

---------------
messaging-app (0.1+14.10.20141007.1-0ubuntu1) 14.09; urgency=low

  [ Bill Filler ]
  * use header in splash screen (LP: #1378379)

  [ Ubuntu daily release ]
  * New rebuild forced

  [ Gustavo Pichorim Boiko ]
  * Ship the messaging-app icon together with the package (LP: #1365408)

  [ Tiago Salem Herrmann ]
  * Add initial support for the new information messageType. Notify
    users when the active sim card was switched. (LP: #1356950)
  * Don't show the attachment popup on onClicked(). Update bottom edge
    behavior (LP: #1368718)
  * Add support for sim lock. (LP: #1371661)
  * Fix black image in the mms preview. (LP: #1373462)
  * Make conversations view header fixed.
 -- Ubuntu daily release <email address hidden> Tue, 07 Oct 2014 16:58:07 +0000

Changed in messaging-app (Ubuntu RTM):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dialer-app - 0.1+14.10.20141007.1-0ubuntu1

---------------
dialer-app (0.1+14.10.20141007.1-0ubuntu1) 14.09; urgency=low

  [ Bill Filler ]
  * use header in splash screen (LP: #1378379)

  [ Ubuntu daily release ]
  * New rebuild forced

  [ Gustavo Pichorim Boiko ]
  * Display different labels when in emergency mode and when the sim
    card is locked.
  * Remove some code duplication and make sure emergency calling is
    always available.
  * Ship the dialer-app icon in the package. (LP: #1365408)

  [ Tiago Salem Herrmann ]
  * Add support for sim lock detection (LP: #1371661)
  * Remove some code duplication and make sure emergency calling is
    always available.

  [ Albert Astals ]
  * Add i18n.tr
 -- Ubuntu daily release <email address hidden> Tue, 07 Oct 2014 17:02:04 +0000

Changed in dialer-app (Ubuntu RTM):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package messaging-app - 0.1+14.10.20141007.1-0ubuntu1

---------------
messaging-app (0.1+14.10.20141007.1-0ubuntu1) 14.09; urgency=low

  [ Bill Filler ]
  * use header in splash screen (LP: #1378379)

  [ Ubuntu daily release ]
  * New rebuild forced

  [ Gustavo Pichorim Boiko ]
  * Ship the messaging-app icon together with the package (LP: #1365408)

  [ Tiago Salem Herrmann ]
  * Add initial support for the new information messageType. Notify
    users when the active sim card was switched. (LP: #1356950)
  * Don't show the attachment popup on onClicked(). Update bottom edge
    behavior (LP: #1368718)
  * Add support for sim lock. (LP: #1371661)
  * Fix black image in the mms preview. (LP: #1373462)
  * Make conversations view header fixed.
 -- Ubuntu daily release <email address hidden> Tue, 07 Oct 2014 16:58:07 +0000

Changed in messaging-app (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dialer-app - 0.1+14.10.20141007.1-0ubuntu1

---------------
dialer-app (0.1+14.10.20141007.1-0ubuntu1) 14.09; urgency=low

  [ Bill Filler ]
  * use header in splash screen (LP: #1378379)

  [ Ubuntu daily release ]
  * New rebuild forced

  [ Gustavo Pichorim Boiko ]
  * Display different labels when in emergency mode and when the sim
    card is locked.
  * Remove some code duplication and make sure emergency calling is
    always available.
  * Ship the dialer-app icon in the package. (LP: #1365408)

  [ Tiago Salem Herrmann ]
  * Add support for sim lock detection (LP: #1371661)
  * Remove some code duplication and make sure emergency calling is
    always available.

  [ Albert Astals ]
  * Add i18n.tr
 -- Ubuntu daily release <email address hidden> Tue, 07 Oct 2014 17:02:04 +0000

Changed in dialer-app (Ubuntu):
status: In Progress → Fix Released
Matthieu James (tiheum) on 2015-08-03
Changed in ubuntu-ux:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers