Cannot focus the address bar the first time after reboot

Bug #1361312 reported by Olivier Tilloy on 2014-08-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-keyboard (Ubuntu)
Critical
Michael Sheldon
webbrowser-app (Ubuntu)
Undecided
Unassigned

Bug Description

I can reliably reproduce the issue on image #207 both on flo and krillin.

Steps to reproduce:
 - reboot the device
 - launch the browser app
 - wait for the current page to finish loading
 - tap the address bar to focus it

 Expected result: the address bar is and remains focused, the OSK shows up and the list of suggestions too

 Actual result: the address bar is very briefly focused (the list of suggestions flashes in and out) and then unfocused again, the OSK doesn’t show up.

This is a recent regression, not sure whether the root cause is in webbrowser-app itself or in the OSK.

Subsequent attempts to focus the address bar work as expected, the issue can be observed only the first time after a reboot.

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: webbrowser-app 0.23+14.10.20140821-0ubuntu1
Uname: Linux 3.4.0-3-flo armv7l
ApportVersion: 2.14.6-0ubuntu2
Architecture: armhf
Date: Mon Aug 25 19:29:32 2014
InstallationDate: Installed on 2014-08-25 (0 days ago)
InstallationMedia: Ubuntu Utopic Unicorn (development branch) - armhf (20140825-020205)
SourcePackage: webbrowser-app
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Olivier Tilloy (osomon) wrote :
Olivier Tilloy (osomon) wrote :

It seems this started happening in image #204. Since that image, smoke tests started failing in the dashboard with an error similar to that:

Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/webbrowser_app/tests/test_addressbar_selection.py", line 46, in test_second_click_deselect_text
    self.assert_osk_eventually_shown()
  File "/usr/lib/python3/dist-packages/webbrowser_app/tests/__init__.py", line 94, in assert_osk_eventually_shown
    Eventually(Equals("shown")))
  File "/usr/lib/python3/dist-packages/testtools/testcase.py", line 406, in assertThat
    raise mismatch_error
testtools.matchers._impl.MismatchError: After 10.0 seconds test on KeyboardRectangle.state failed: 'shown' != dbus.String('hidden', variant_level=1)

(see e.g. http://ci.ubuntu.com/smokeng/utopic/touch/mako/204:20140822:20140811.1/9853/webbrowser_app/1565605/)

Olivier Tilloy (osomon) wrote :

Unfortunately image #204 contained changes to both webbrowser-app and ubuntu-keyboard, which won’t make it easy to spot the culprit: http://people.canonical.com/~lzemczak/landing-team/204.commitlog. The changes to webbrowser-app look like a good potential culprit, so I’ll look into them first.

Olivier Tilloy (osomon) wrote :

This seems to be an ubuntu-keyboard regression after all. To demonstrate that I:

 - installed image #203, and verified that focusing the address bar after boot worked
 - upgraded the webbrowser-app packages only to 0.23+14.10.20140821-0ubuntu1, rebooted and verified that the test still worked
 - upgraded the ubuntu-keyboard packages only to 0.99.trunk.phablet2+14.10.20140820-0ubuntu1, rebooted and verified that the test failed
 - installed image #203 again, and verified that focusing the address bar after boot worked
 - upgraded the ubuntu-keyboard packages only to 0.99.trunk.phablet2+14.10.20140820-0ubuntu1, rebooted and verified that the test failed

Changed in webbrowser-app (Ubuntu):
status: New → Invalid
Bill Filler (bfiller) wrote :

possibly related to the new keyboard animation?

Changed in ubuntu-keyboard (Ubuntu):
importance: Undecided → Critical
assignee: nobody → Michael Sheldon (michael-sheldon)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-keyboard - 0.99.trunk.phablet2+14.10.20140826-0ubuntu1

---------------
ubuntu-keyboard (0.99.trunk.phablet2+14.10.20140826-0ubuntu1) utopic; urgency=low

  [ Michael Sheldon ]
  * Allow ActionKeys to override default CharKey PressArea behaviour
    instead of creating their own overlapping MouseAreas.
  * Add translation template generation. (LP: #1357616)
  * Place the default extended key in the center of the extended keys
    pop up, making it the initially selected option.
  * Display the correct character in the magnifier when the keyboard is
    in shifted mode.
  * Update haptic effect values to match those used in AbstractButton.
  * Fix keyboard show/hide animation when maliit has first started. (LP:
    #1361312)

  [ Danilo Šegan ]
  * Implement a basic Serbian keyboard layout with diacritics.

  [ Ubuntu daily release ]
  * New rebuild forced
 -- Ubuntu daily release <email address hidden> Tue, 26 Aug 2014 17:27:04 +0000

Changed in ubuntu-keyboard (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers