[browser] Can't download random files

Bug #1354391 reported by Albert Astals Cid on 2014-08-08
192
This bug affects 38 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Bill Filler
Ubuntu UX
High
James Mulholland
webbrowser-app (Ubuntu)
High
Michael Sheldon
webbrowser-app (Ubuntu RTM)
High
Unassigned

Bug Description

I am trying to download a foo.tar.xz file and the browser won't let me.

My use case:
 * Wifi driver in laptop is broken
 * Phone can download stuff
 * Download driver, pass it via adb, mtp or some other way to laptop
 * Be happy again

This is an hypothetic scenario but i have had this in the past.

UX specification: https://docs.google.com/presentation/d/1Qrd4Flfs3EH-fI79IfrYgLdAx2nce-L7ve8NKLCX324/edit#slide=id.g1da5cf439_00

Related branches

Olivier Tilloy (osomon) wrote :

To elaborate a bit more on what happens: when trying to download a file that no installed application knows how to handle, the user is presented with a message from the content hub saying exactly that, and a cancel button. The user is not allowed to download a random file with no associated application.

I don’t know what the proper solution to this problem is. Maybe make the file manager app able to handle any file type by default?

Changed in webbrowser-app:
status: New → Triaged
Changed in webbrowser-app (Ubuntu):
status: New → Confirmed
Pat McGowan (pat-mcgowan) wrote :

Why not just save it to Downloads and inform the user in addition "File will be saved to Downloads area"
The problem is there is no local UI to view or delete. If the browser grew a download viewer that would resolve it for me.

Olivier Tilloy (osomon) wrote :

That would require the browser to advertise itself as a content handler for any type of file, which as a consequence would also show it as a handler when trying to download a file from another application.

In any case we’ll need design guidance, adding an ubuntu-ux task.

Changed in webbrowser-app (Ubuntu):
importance: Undecided → High
summary: - Can't download random files
+ [browser] Can't download random files

We will have a downloads folder for the browser post-rtm. It will be available through the content-hub.
Design is already completed.

Changed in ubuntu-ux:
assignee: nobody → Giorgio Venturi (giorgio-venturi)
importance: Undecided → Medium
importance: Medium → Wishlist
status: New → Fix Committed
Jean-Baptiste Lallement (jibel) wrote :

This affects downloading zip files from 7Digital which is one of the main music provider in the music scope. So user purchases music and cannot download it.

tags: added: beta qa-daily-testing
Pat McGowan (pat-mcgowan) wrote :

That specific use case is being supported per bug 1365993
This bug is for files that cannot really be used on the device

tags: removed: beta qa-daily-testing
Olivier Tilloy (osomon) on 2014-10-21
tags: added: design-gap
Changed in webbrowser-app:
importance: Undecided → Low
tags: added: usability
Changed in ubuntu-ux:
assignee: Giorgio Venturi (giorgio-venturi) → James Mulholland (jamesjosephmulholland)
Olivier Tilloy (osomon) on 2015-06-08
Changed in webbrowser-app (Ubuntu):
status: Confirmed → Triaged
importance: High → Low
importance: Low → High
no longer affects: webbrowser-app
Changed in webbrowser-app (Ubuntu):
assignee: nobody → Olivier Tilloy (osomon)
Pat McGowan (pat-mcgowan) wrote :

Can we fit this in for the next ota?

Changed in canonical-devices-system-image:
assignee: nobody → Bill Filler (bfiller)
importance: Undecided → High
milestone: none → ww28-2015
status: New → Confirmed
Olivier Tilloy (osomon) on 2015-06-23
description: updated
Changed in canonical-devices-system-image:
milestone: ww28-2015 → ww34-2015
TenLeftFingers (tenleftfingers) wrote :

I think this is the same issue so I'll add it here. Please let me know if I should file a separate bug:

Avi does not work at all because the browser asks which app to open with, but only suggests the Gallery app. It then downloads the .avi to .cache/com.ubuntu.gallery/HubIncoming/4/
The Gallery app doesn't show the movie afterwards so it is inaccessible and difficult to delete unless you know how to use the terminal.

Olivier Tilloy (osomon) wrote :

@TenLeftFingers: this is related indeed. Although the fact that the gallery app doesn’t show the file afterwards seems to be a bug in the gallery app itself (or maybe an unsupported codec?). Feel free to file a bug at https://bugs.launchpad.net/ubuntu/+source/gallery-app/+filebug with details on the file you’re downloading.

I tested wget and can download a .png for example

Bill Filler (bfiller) on 2015-08-12
Changed in canonical-devices-system-image:
milestone: ww34-2015 → ww40-2015
Changed in webbrowser-app (Ubuntu):
status: Triaged → In Progress
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Changed in canonical-devices-system-image:
milestone: ww40-2015 → ww46-2015
Bill Filler (bfiller) on 2015-10-30
Changed in canonical-devices-system-image:
milestone: ww46-2015 → ww02-2016
Olivier Tilloy (osomon) on 2015-11-30
Changed in webbrowser-app (Ubuntu):
assignee: Olivier Tilloy (osomon) → Michael Sheldon (michael-sheldon)
Timo Jyrinki (timo-jyrinki) wrote :

webbrowser-app (0.23+15.04.20151221-0ubuntu1) vivid; urgency=medium

  [ Michael Sheldon ]
  * Add support for handling downloads internally within the browser.
    (LP: #1354391)

 -- CI Train Bot <email address hidden> Mon, 21 Dec 2015 20:39:36 +0000

Changed in webbrowser-app (Ubuntu RTM):
importance: Undecided → High
status: New → Fix Released
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package webbrowser-app - 0.23+16.04.20151221-0ubuntu1

---------------
webbrowser-app (0.23+16.04.20151221-0ubuntu1) xenial; urgency=medium

  [ Michael Sheldon ]
  * Add support for handling downloads internally within the browser.
    (LP: #1354391)

 -- CI Train Bot <email address hidden> Mon, 21 Dec 2015 20:39:36 +0000

Changed in webbrowser-app (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
Changed in ubuntu-ux:
status: Fix Committed → Fix Released
Changed in ubuntu-ux:
importance: Wishlist → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers