The top panel is not restored after toggling full screen off

Bug #1328839 reported by Olivier Tilloy on 2014-06-11
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
platform-api (Ubuntu)
High
Robert Carr
qtubuntu (Ubuntu)
High
Robert Carr
webbrowser-app (Ubuntu)
High
Olivier Tilloy

Bug Description

I’m implementing fullscreen mode for the browser application, and I’m seeing two issues, which can be reliably reproduced with the following piece of QML:

import QtQuick 2.0
import QtQuick.Window 2.1
import Ubuntu.Components 0.1
Window {
  id: window
  Button {
    anchors.centerIn: parent
    text: "toggle fullscreen"
    onClicked: window.visibility = (window.visibility == Window.FullScreen ? Window.AutomaticVisibility : Window.FullScreen)
  }
}

Issue #1: when toggling fullscreen on, the top panel is hidden as expected, and consequently the coordinates of the window change on screen, but the contents of the window are not redrawn, so in the example above tapping the button has no effect (one needs to tap slightly above it to activate it)

Issue #2: when toggling fullscreen off, the top panel is not restored.

Related branches

Michał Sawicz (saviq) on 2014-06-12
summary: - Fullscreen window issues
+ Toggling fullscreen causes wrong window behaviour

The surface dimensions are currently handled in qtubuntu, but this will change with the qt compositor landing, at which point it's unity8 that will make this happen.

Bill Filler (bfiller) on 2014-06-18
Changed in qtubuntu:
importance: Undecided → High
Changed in unity8:
importance: Undecided → High
tags: added: rtm14
Bill Filler (bfiller) wrote :

this one is kind of critical for the browser, as we can now fullscreen a youtube video and the experience is kind of bad with this bug

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in webbrowser-app (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package webbrowser-app - 0.23+14.10.20140620-0ubuntu1

---------------
webbrowser-app (0.23+14.10.20140620-0ubuntu1) utopic; urgency=low

  [ Olivier Tilloy ]
  * Re-enable the geolocation permission request dialog, now that it is
    implemented in oxide. Fix it in the webkit-based webapp container.
    (LP: #1182658)
  * Temporarily work around bug #1328839 in qtubuntu by not toggling
    fullscreen on the window on devices. Once the Qt compositor work
    lands (scheduled for mid July), the bug should be resolved and this
    workaround can be removed. (LP: #1328839)
 -- Ubuntu daily release <email address hidden> Fri, 20 Jun 2014 09:27:06 +0000

Changed in webbrowser-app (Ubuntu):
status: Confirmed → Fix Released
Changed in qtubuntu:
status: New → Confirmed
status: Confirmed → New
Gerry Boland (gerboland) wrote :

We've not tested QtMir/Unity8 handling an app changing to fullscreen and then back to normal, so that needs to be done.

Also need to check qtubuntu allows a client app to ask for fullscreen and back again to normal.

Changed in qtmir:
status: New → Confirmed
importance: Undecided → High
Gerry Boland (gerboland) on 2014-08-01
Changed in qtmir:
assignee: nobody → Gerry Boland (gerboland)
Florian Boucault (fboucault) wrote :

qtubuntu's code looks fine from a quick glance

Daniel d'Andrada (dandrader) wrote :

Probably another instance of the same bug:

1- launch calendar (notice that calendar is a non-fullscreen app)
2- switch to dash
3- go to spread
4- kill calendar from the terminal
5- tap on the (dead) calendar in the spread

expected outcome:
calendar is restarted as non-fullscreen

actual outcome:
calendar is restarted as fullscreen

Olivier Tilloy (osomon) wrote :

I just tested reverting the workaround in webbrowser-app now that the Qt compositor has landed, and while the situation has improved a bit, issue #2 as described in the original report is still present: when exiting fullscreen mode, the top panel is not restored.

kevin gunn (kgunn72) on 2014-09-02
summary: - Toggling fullscreen causes wrong window behaviour
+ The top panel is not restored after toggling full screen off
tags: added: touch-2014-10-02
Michał Sawicz (saviq) on 2014-09-03
Changed in unity8 (Ubuntu):
importance: Undecided → High
Michał Sawicz (saviq) on 2014-09-09
no longer affects: unity8
kevin gunn (kgunn72) on 2014-09-09
Changed in qtmir:
assignee: Gerry Boland (gerboland) → Daniel d'Andrada (dandrader)
Changed in unity8 (Ubuntu):
assignee: nobody → Daniel d'Andrada (dandrader)
kevin gunn (kgunn72) on 2014-09-11
tags: added: touch-2014-10-30
removed: touch-2014-10-02
kevin gunn (kgunn72) on 2014-09-16
no longer affects: qtubuntu
kevin gunn (kgunn72) on 2014-09-16
Changed in qtmir:
assignee: Daniel d'Andrada (dandrader) → Robert Carr (robertcarr)
Changed in unity8 (Ubuntu):
assignee: Daniel d'Andrada (dandrader) → Robert Carr (robertcarr)
Robert Carr (robertcarr) wrote :

The start of the problem is in platform API, where there is no way to requestleaving fullscreen!

Changed in qtmir:
status: Confirmed → In Progress
Changed in platform-api (Ubuntu):
status: New → In Progress
Changed in unity8 (Ubuntu):
status: New → In Progress
Changed in qtubuntu (Ubuntu):
status: New → In Progress
assignee: nobody → Robert Carr (robertcarr)
Changed in platform-api (Ubuntu):
assignee: nobody → Robert Carr (robertcarr)
kevin gunn (kgunn72) wrote :

@bfiller
currently this bug has a workaround in place it seems.
so is this really rtm14 ??

Changed in platform-api (Ubuntu):
importance: Undecided → High
Changed in qtubuntu (Ubuntu):
importance: Undecided → High
Changed in webbrowser-app (Ubuntu):
importance: Undecided → High
Olivier Tilloy (osomon) on 2014-10-06
Changed in platform-api (Ubuntu):
status: In Progress → Fix Released
Changed in qtubuntu (Ubuntu):
status: In Progress → Fix Released
Olivier Tilloy (osomon) wrote :

@Kevin: we had a workaround in place in webbrowser-app indeed, but the bug has now been fixed in platform-api and qtubuntu, so I’ve submitted a change in webbrowser-app to remove the workaround. With that, I guess it’s fine if we keep the rtm14 tag.

kevin gunn (kgunn72) on 2014-10-06
Changed in unity8 (Ubuntu):
status: In Progress → Invalid
Changed in qtmir:
status: In Progress → Invalid
no longer affects: qtmir
no longer affects: unity8 (Ubuntu)
Olivier Tilloy (osomon) on 2014-10-06
Changed in webbrowser-app (Ubuntu):
assignee: nobody → Olivier Tilloy (osomon)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers