install-default-webapps-in-launcher.py crashed with signal 5 in g_settings_get_mapped()

Bug #1206314 reported by Herbert Seraphim Coelho on 2013-07-30
348
This bug affects 89 people
Affects Status Importance Assigned to Milestone
WebApps: Applications Data
Undecided
Unassigned
webapps-applications (Ubuntu)
High
Robert Bruce Park

Bug Description

o sitema não emula corretamente travando.

ProblemType: Crash
DistroRelease: Ubuntu 13.10
Package: unity-webapps-common 2.4.16+13.10.20130719-0ubuntu1
ProcVersionSignature: Ubuntu 3.10.0-6.17-generic 3.10.3
Uname: Linux 3.10.0-6-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.11-0ubuntu1
Architecture: amd64
Date: Mon Jul 29 21:29:14 2013
ExecutablePath: /usr/share/session-migration/scripts/install-default-webapps-in-launcher.py
InstallationDate: Installed on 2013-07-14 (15 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Alpha amd64 (20130529)
InterpreterPath: /usr/bin/python2.7
MarkForUpload: True
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/share/session-migration/scripts/install-default-webapps-in-launcher.py
Signal: 5
SourcePackage: webapps-applications
StacktraceTop:
 g_settings_get_mapped () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
 ffi_call_unix64 () from /usr/lib/x86_64-linux-gnu/libffi.so.6
 ffi_call () from /usr/lib/x86_64-linux-gnu/libffi.so.6
 g_callable_info_invoke () from /usr/lib/libgirepository-1.0.so.1
 g_function_info_invoke () from /usr/lib/libgirepository-1.0.so.1
Title: install-default-webapps-in-launcher.py crashed with signal 5 in g_settings_get_mapped()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

Related branches

StacktraceTop:
 g_settings_get_mapped (settings=0x2019030, key=0x1ed6f40 "favorites", mapping=0x7f2c52be7010, user_data=0x2018ed0) at /build/buildd/glib2.0-2.37.3/./gio/gsettings.c:1520
 ffi_call_unix64 () at ../src/x86/unix64.S:76
 ffi_call (cif=cif@entry=0x7fff66d7aa90, fn=fn@entry=0x7f2c5040eec0 <g_settings_get_mapped>, rvalue=rvalue@entry=0x7fff66d7aa70, avalue=avalue@entry=0x7fff66d7a990) at ../src/x86/ffi64.c:522
 g_callable_info_invoke (info=info@entry=0x1f90a30, function=0x7f2c5040eec0 <g_settings_get_mapped>, in_args=in_args@entry=0x1ed7240, n_in_args=n_in_args@entry=4, out_args=out_args@entry=0x0, n_out_args=n_out_args@entry=0, return_value=return_value@entry=0x7fff66d7ac68, is_method=is_method@entry=1, throws=0, error=error@entry=0x7fff66d7ac18) at girepository/gicallableinfo.c:680
 g_function_info_invoke (info=0x1f90a30, in_args=0x1ed7240, n_in_args=4, out_args=0x0, n_out_args=0, return_value=0x7fff66d7ac68, error=0x7fff66d7ac18) at girepository/gifunctioninfo.c:274

Changed in webapps-applications (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in webapps-applications (Ubuntu):
status: New → Confirmed
Dimitri John Ledkov (xnox) wrote :

This error pops up in default install, after booting and logging in for the first time.

information type: Private → Public
Changed in webapps-applications (Ubuntu):
importance: Medium → High
Changed in webapps-applications (Ubuntu):
assignee: nobody → Robert Bruce Park (robru)

In my case this crash happens every time logging is done.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1206314

tags: added: iso-testing
Allison Lortie (desrt) wrote :

Line 1520 in that file looks like so:

    g_error ("The mapping function given to g_settings_get_mapped() for key "
             "'%s' in schema '%s' returned FALSE when given a NULL value.",
             key, g_settings_schema_get_id (settings->priv->schema));

which is a pretty good indicator of what's probably happening here.

Quoth the docs:

If the mapping function fails for all possible values, one additional attempt is made: the mapping function is called with a NULL value. If the mapping function still indicates failure at this point then the application will be aborted.

Allison Lortie (desrt) wrote :

So indeed, the script contains this code:

first_mapping = [True]
def mapping_callback(value, first_mapping):
    if not value:
        return (True, [])
    if first_mapping[0]:
        first_mapping[0] = False
        return (False, value)
    return (True, value)

def get_default_value_for(settings, key):
    return settings.get_mapped(UNITY_LAUNCHER_FAVORITE_KEY, mapping_callback, first_mapping)

Which looks like it's fine because of:

    if not value:
        return (True, [])

but for some reason, the python bindings are unable to deal with this. Running the script gives warnings like so:

** (process:21913): WARNING **: (pygi-argument.c:903):_pygi_argument_from_object: runtime check failed: (transfer == GI_TRANSFER_NOTHING)

before crashing with the error from the previous comment.

An easier way of getting the default value of a key (and the one most commonly used by other developers) is this pattern:

1) create a GSettings object
2) .delay()
3) .reset('key')
4) .get('key')
5) free the object without calling .apply()

Robert Bruce Park (robru) wrote :

Thanks for clearing this up Ryan, I'll submit a patch for this shortly.

Changed in webapps-applications (Ubuntu):
status: Confirmed → In Progress
Changed in webapps-applications (Ubuntu):
status: In Progress → Fix Committed
arith (s-arithmetic) on 2013-08-09
Changed in webapps-applications (Ubuntu):
status: Fix Committed → Fix Released
Changed in webapps-applications:
status: New → Fix Released
Adolfo Jayme (fitojb) on 2013-08-11
Changed in webapps-applications (Ubuntu):
status: Fix Released → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:webapps-applications at revision 553, scheduled for release in webapps-applications, milestone 2.4.2

Changed in webapps-applications:
status: Fix Released → Fix Committed
Changed in webapps-applications:
status: Fix Committed → Fix Released
Changed in webapps-applications (Ubuntu):
status: In Progress → Fix Released
Brian Murray (brian-murray) wrote :

This is actually just Fix Committed as the fix is still in the -proposed repository. Launchpad will automatically set this to Fix Released when the package is available in the archive.

Changed in webapps-applications (Ubuntu):
status: Fix Released → Fix Committed
Robert Bruce Park (robru) wrote :

Oops, sorry. I just saw http://bazaar.launchpad.net/~webapps/webapps-applications/trunk/revision/554 and assumed that it was released for real.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu Package testing tracker.

A list of all reports related to this bug can be found here:
http://packages.qa.ubuntu.com/qatracker/reports/bugs/1206314

tags: added: package-qa-testing
osmeest (osmeest) wrote :

Happens automatically when launching the saucy salamander image (both 32b and 64b).

Carlos Carmona (carmonacr75) wrote :

Ubuntu 13.10 (Saucy Salamander) 64-bit PC (AMD64) desktop image
http://cdimage.ubuntu.com/daily-live/current/
I think it might be that my system is intel and not AMD but still 64-bit

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package webapps-applications - 2.4.16+13.10.20130814-0ubuntu1

---------------
webapps-applications (2.4.16+13.10.20130814-0ubuntu1) saucy; urgency=low

  [ Robert Bruce Park ]
  * Get default gsettings value without crashing. (LP: #1206314). (LP:
    #1206314)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 553
 -- Ubuntu daily release <email address hidden> Wed, 14 Aug 2013 18:05:27 +0000

Changed in webapps-applications (Ubuntu):
status: Fix Committed → Fix Released
Jake (jakeworldlynk) wrote :

Intel Westmere board install of web apps failed at first login after install.

Robert Bruce Park (robru) wrote :

Jake, are you running raring? If not, just update to the latest saucy packages, this was fixed a while ago.

Anton Piatek (anton-piatek) wrote :

I just tried installing from the saucy 13.10 final beta, and hit this issue!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers