Ubuntu

webapps are not working :(

Reported by jondecker76 on 2012-10-19
710
This bug affects 170 people
Affects Status Importance Assigned to Milestone
WebApps: Applications Data
Undecided
Alexandre Abreu
WebApps: unity-chromium-extensions
Undecided
Unassigned
unity-chromium-extension (Ubuntu)
High
Unassigned
webapps-applications (Ubuntu)
High
Unassigned

Bug Description

After upgrading my 12.04 to 12.10 - web apps do not work out of the box (I had to install the chromium extension myself). Additionally, even after installing the extension, webapps are not working fully. Please see thread here:

http://ubuntuforums.org/showthread.php?t=2073068

Phillip Lickteig (pmlickteig) wrote :

I am also affected by this, having just done a clean install to 12.10 yesterday. None of the webapps, including Facebook, function in the message indicator, nor in the launcher.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1068662/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
mexlinux (mcanedo) wrote :

If I look in synaptics what are the installed files from a package like unity-webapps-gmail, I can see that there is nothing in
/usr/share/applications/

So I guess that the problem is that the corresponding .dektop files are not installed.

The only ones installed are the ones that came by default:
/usr/share/applications/UbuntuOneMusiconeubuntucom.desktop
/usr/share/applications/ubuntu-amazon-default.desktop

mexlinux (mcanedo) on 2012-10-20
affects: ubuntu → webapps-applications (Ubuntu)
Adam Niedling (krychek) wrote :

I have the same issue after upgrading from 12.04 to 12.10. I use chromium as my default browser.
I had to manually install "unity-chromium-extension" after the upgrade but the webapps integration still does not work. I get no notification to create a webapp icon in the launcher when I visit launchpad.net and when I start a webapp chromium forgets all my previously opened webpages so I can't continue on with my last session.

Adam Niedling (krychek) wrote :

I just restarted my comp and now I get notification however my session is still lost after starting a webapp.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-chromium-extension (Ubuntu):
status: New → Confirmed
mexlinux (mcanedo) on 2012-10-21
Changed in unity-chromium-extension:
status: New → Confirmed
chad (crossroads1112) wrote :

I have the same problem . It shows up in the messaging menu but not in the HUD. I also had to install the chromium extension manually.

mexlinux (mcanedo) wrote :

I just noticed that webapps do not work with google apps (my own domain), but they work with regular gmail account....

The same problem, when clean install.

Andrei Coman (comandrei) wrote :

After upgrading to 12.10 I can't get webapps running with using Firefox. When going to Edit - > Preferences -> General there is no Desktop integration.

Changed in webapps-applications (Ubuntu):
importance: Undecided → High
tags: added: quantal
Changed in unity-chromium-extension (Ubuntu):
importance: Undecided → High

At first I had the same problem, but after installing the unity-webapp-* packages I managed to install gmail, gplus, facebook, calendar and youtube. The only issue is that the counter doesn't work on the icons.

For example, the gmail icon on unity left panel doen't display the counter of new messages. The same happens with facebook and google plus (in this case I receive at least a notification of new posts). When I tried webapps in ubuntu 12.04 that worked at least for gmail.

Wadelius (wadelius) wrote :

It does not work completely on my installation, using firefox. I upgraded from 12.04. It works for Google Calendar, Launchpad and OMG Ubuntu, but not for Gmail. It offered integration when I visited Gmail, but Gmail does not show up when I type "webapps" in the dash.

I tried uninstalling unity-webapps-gmail. It then offered to install the next time i visited gmail.com, but it's still not working.

Elias K Gardner (zorkerz) wrote :

Not sure how to tell if all these issues are related or not. I also upgraded from 12.04 to 12.10.

I have found sporadic offers to install webapps. For instance the google docs webapp did not ask to be installed until after at least two days of using it regularly (both with a gmail account and a google apps account with different domain).

I have also found that the webapps do not show up in alt + tab unless they are tabs in firefox this effectively makes them useless because there is no way to switchbetween them with alt + tab.

Lenovo laptop
Country : Canada
Language : English
Default browser : Firefox
Upgraded from 12.04 to 12.10

Step 1
I manually added my gmail and facebook accounts via the settings/online accounts control panel.

Step 2
Went to the following websites which were successfully identified by ubuntu, and prompted integration: facebook, linkedin, youtube, launchpad

Of these, youtube does not seem to work properly.

Step 3
Unable to get gmail or google calendar integration to work. Looks like picasa and other integrations are listed in the "online accounts" control panel. Perhaps gmail integration is not ready...

MaTachi (matachi) wrote :

I have upgraded from 12.04, and it doesn't work for me neither.

When I visited Gmail it prompted me if I wanted to install the webapp, which I chose to do, and I can find it through the Dash. But it doesn't appear in the Launcher when I launch it. And I can't manage to get any other sites (such as Twitter, Facebook, Reddit) to ask me if I want desktop integration. And when I open the preferences window in Firefox I can't find anything about desktop integration. Apparently you should be able to see this in the preferences window: http://1.bp.blogspot.com/-QxPXtxj4Wes/UGZfb4sUU4I/AAAAAAAAKas/FZc920qnAzA/s1600/webapps-firefox-exceptions.png

I installed Twitter through the terminal (unity-webapps-twitter), but I couldn't find it through Dash and I couldn't see any difference when I visited the site.

However, I have reinstalled Firefox, created new profiles, installed and removed Firefox Aurora from Mozilla's PPA, etc. So maybe I have managed to break something along the way. I'm running stock Firefox (version 16.0.1) from Ubuntu's repository now, but is there something else I should try to reinstall?

Devin (8basepairs) wrote :

@matachi, I think I had the same problem with not being able to see the Desktop Integration in the Preferences window of firefox. But, after I restarted Firefox it showed up. This might have happened if I did my first Software Update after a fresh install between the time I started the session that did not show the option and the time I started a new session because the webapp packages nor the "technical items", which they are members of, show up in Ubuntu Software Center until you do the first Software Update after installing Ubuntu 12.10, at least for fresh installs.

MaTachi (matachi) wrote :

@8basepairs, I have updated my system, both through the terminal (sudo apt-get update ; sudo apt-get dist-upgrade) and through Ubuntu's Update Manager. Everything is up-to-date, (including version 16.0.2 of Firefox). I still can't see any Desktop Integration in the Preferences window. I also installed the Grooveshark webapp through the Software Center, and it didn't appear in the Dash or in the Launcher, and when I visited the site I didn't get any desktop integration.

Devin (8basepairs) wrote :

Okay, good to know. What that means is that the Edit>Preferences>General>Desktop Integration is another thing which randomly appears (the other being some of the queries for installing webapps that show up on sites sometimes only during page loads). In fact, I just started up the preferences window several times, and the first time the Desktop Integration was the first thing on the list of General Preferences, the rest of the following times it was on the bottom like in your picture, matachi. Already I mentioned that I also have experienced no option for Desktop Integration, and the following times after that computer session showed it normally. Now it is jumping in different places; weird.

Installed unity-chromium-extension, all the unity-webapp-* and reinstalled chromium they work flawlessy for me.

As soon as I browse a website that is supported it asks me to install it and i get unity integration in both notification and an icon in my dash...

Sweet!

Devin (8basepairs) wrote :

@vincenzo-ampolo, do you think that will help us because you experienced the bug too before fixing it that way?

grooveshark not working at all here, even if the webapp has been installed on a 64bit machine..

a quantal feature

Changed in webapps-applications:
status: New → Confirmed
Daniel Walker (dwalker-p) wrote :

For grooveshark.com it never asked me to install the webapp, _until_ I commented out a couple of lines of javascript.

//if (isCorrectPage()) {
    Unity.init({ name: "Grooveshark",
   domain: 'grooveshark.com',
   homepage: 'http://grooveshark.com',
                 iconUrl: "icon://unity-webapps-grooveshark",
                 onInit: wrapCallback(musicPlayerSetup) });
//}

In this file,

/usr/share/unity-webapps/userscripts/unity-webapps-grooveshark/grooveshark.user.js

the isCorrectPage() seems to check if the page has some specific elements in it.. Also I'm using grooveshark's new interface which would likely have some new element names or someting like that.

I didn't actually install the webapp when it asked, since if the webpage is different I'm guess it won't work anyway.

Daniel Walker (dwalker-p) wrote :

Looks like I got it working now.. However, it only works with http://retro.grooveshark.com which is kind of a bummer..

So you just basically change "grooveshark.com" to "retro.grooveshark.com" in the files below,

/usr/share/unity-webapps/userscripts/unity-webapps-grooveshark/grooveshark.user.js
/usr/share/unity-webapps/userscripts/unity-webapps-grooveshark/manifest.json

then goto "retro.grooveshark.com" .. It worked for me, hope it does for anyone else that tries it.

Maxim Ermilov (zaspire) on 2012-11-12
Changed in webapps-applications:
assignee: nobody → Alexandre Abreu (abreu-alexandre)
MaTachi (matachi) wrote :

I ran into some problems with my AMD drivers, and during my hassle I purged `compiz` (and packages it depends on) and then I reinstalled the packages `compiz` and `ubuntu-desktop`. That made my Firefox installation to ask whether I want to install a web app when I visit a compatible site, at least I think so. However, the web apps don't seem to install. And I'm not sure which specific package that you need to reinstall, I'm neither sure if I messed something up (like removed or installed too many packages).

Not sure if this helps, but when I run Firefox from the terminal I get the following errors before Firefox opens.

** (firefox:5823): WARNING **: Failed to open webapp application path dir /usr/share/ubuntu/unity-webapps/userscripts: Error opening directory '/usr/share/ubuntu/unity-webapps/userscripts': No such file or directory

** (firefox:5823): WARNING **: Failed to open webapp application path dir /usr/share/gnome/unity-webapps/userscripts: Error opening directory '/usr/share/gnome/unity-webapps/userscripts': No such file or directory

** (firefox:5823): WARNING **: Failed to open webapp application path dir /usr/local/share/unity-webapps/userscripts: Error opening directory '/usr/local/share/unity-webapps/userscripts': No such file or directory

(firefox:5823): Gdk-CRITICAL **: IA__gdk_error_trap_pop: assertion `gdk_error_traps != NULL' failed

Davide Radaelli (azel-j) wrote :

Not sure if this helps, fresh install 12.10 64bit, account gmail managed by google apps and gmail webapp doesn't work.
It ask for install, but when installed nothing happen, only a new icon added to the launcher, no new notify etc etc

Commander (artur-olech) wrote :

I got the same issues here, only few works like googleplus launchpad and gmail and calendar. Tried youtube and nothing shows up. Tried to add in dconf manager youtube.com as allowed in web apps but that did not help it.

removed all webapps, did
sudo apt-get install unity-webapps-* and the chrome extension manually and it did also not work.
Did a reboot after this and checked dconf again but no avail, youtube is still not working for me.

Bart Janssens (bartholomeus-j) wrote :

Same problem here with chromium, this is the output when starting from command line:

      $ chromium-browser
** (exe:5950): WARNING **: Failed to open webapp application path dir /usr/share/ubuntu/unity-webapps/userscripts: Error opening directory '/usr/share/ubuntu/unity-webapps/userscripts': No such file or directory

** (exe:5950): WARNING **: Failed to open webapp application path dir /usr/share/gnome/unity-webapps/userscripts: Error opening directory '/usr/share/gnome/unity-webapps/userscripts': No such file or directory

** (exe:5950): WARNING **: Failed to open webapp application path dir /usr/local/share/unity-webapps/userscripts: Error opening directory '/usr/local/share/unity-webapps/userscripts': No such file or directory

These directories don't exist but I did find the relevant files in:
/usr/share/unity-webapps/userscripts

Same on 13.04..

in 12.10 AMD64, having trouble with Amazon Cloud Reader as a webapp. Cloud Reader works in Firefox when loaded as a regular web page, but while running as a webapp in Chromium, the window freezes with the first page that loads, then I'm forced to close the window.

rarely, if I fiddle around with the Cloud Reader webapp, it suddenly fuctions.

my other webapps work o.k.

***

also, while any webapp is running, the omnibox no longer works in Chromium Browser.

***

I am unable to install unity-webapp-preview because, apt-get dist-upgrade wants to remove unity while dist-upgrad'ing compiz

same problem here on my desktop with firefox
on my laptop it works fine.

siebertm (siebertm) wrote :

I have the same problem on a fresh install of 12.10, both on firefox and chromium.

I can confirm the messages on the console about the missing directories.

issue #1

Amazon Cloud Reader WebApp does not work in Chromium Browser or Google Chrome—it appears to run stable as it opens, but when I try to open next page, nothing happens because app is frozen—though it does allow me to quit app with close button in upper corner.

ACRW freezing problem started after dist-upgrade from 12.04 from 12.10. unity and compiz are up to date. nvidia driver: nvidia-current. Chromium and Chrome: latest versions.

issue #2

Pandora WebApp does not open at all in Firefox(problem might be caused by experimental version or security settings), but Pandora site runs normal with command line: chromium-browser --app http://www.pandora.com, so I'm content with that, since I can not find a 'chromium-browser --app' equivalent in Firefox.

note: sometimes Firefox window does not display at all, so I try to load Firefox more than once, then find multiple instances of Firefox in System Monitor>>Processes tab

the good news...

ACRW works well in experimental Firefox(Aurora version 20.0a2, 1-19-2013), so I changed default browser from Chromium to experimental Firefox(Aurora). so far, I am able to run all but one webapp with unity-webapps-runner: facebookmessenger, gmail, launchpad, livemail, yahoomail, youtube, amazoncloudreader (Pandora runs as app with 'chromium-browser --app')

I could not get Amazon Cloud Reader to work with command line 'chromium-browser --app https://read.amazon.com/' so I doubt the webapp will ever work until it can run as --app first

I have this issue on two computers, both upgraded from 12.04 to 12.10. I've mostly given up hope on ever running webapps at all but recently I discovered some new stuff.

1) Creating an syslink in /usr/local/share/ to /usr/share/unity-webapps/ seems to work. This is even after purging a all possible packages that are related to webapps!

Even after doing this I still can't run any webapps but the Twitter webapps keep showing up, even after I removed the package. My guess is that somehow older configuration stuff from the PPA is still on my system and is looking at the older files.

Also:

Works:
unity-webapps-runner --amazon

Everything else doesn't work, no gmail, no google calendar and no launchpad. Twitter also doesn't work even though I have a twitter icon in my applications settings.

I'm not sure if this works for everybody, but I reseted firefox and now webapps works perfectly in my upgraded ubuntu 12.10.

Check this link for more info: http://support.mozilla.org/en-US/kb/reset-firefox-easily-fix-most-problems

Santiago Scolari (santiagosco) wrote :

I solved this problem.
I deleted the folder: /home/myname/.config/chromium
When I started the chromium again, the webapps works correctly.

deleting /home/foo/.config/chromium worked for me as well. so, after upgrading from 12.04 to 12.10, it seems like a good idea to delete that directory.

other problems that seemed to be solved by deleting .config/chromium:

1. volume control remains synced while using webapps like pandora.com
2. no longer seeing unclosable unity icons in side menubar that were being left behind by chromium

Martin Beltov (mbeltov) wrote :

Affects me as well on 13.04

Adam Niedling (krychek) wrote :

The amazon webapp is working for me with Chromium. But the I went to my Gmail, Chromium asked me if I wanted to install the Gmail webapp I said yes and nothing happened after that. I also tried to log out and log back in. I'm using Ubuntu 13.04.

Pius (pijus-navickas) wrote :

I installed fresh 13.04 x64 a couple days ago. I use Gmail and Drive frequently but didn't see a single dialog suggesting to install a web app. I tried installing packages my self (using Software Center) but functionality wasn't there anyway.

I use Chromium from Software Center as my default browser.

Kirill Jakovlev (special-k) wrote :

iconUrl doesn't work If application not installed

spi (spi-gmxpro) wrote :

I've got a long list of Ubuntu updates and am currently running 13.04. Webapps also didn't work in the beginning of 13.04 and do work now a bit.

My issues:
1) Chromium asked for every single site if I want to use the Unity integration, despite I answered yes or no I was prompted again for that site
2) Chromium never created an icon (i.e. desktop file in ~/.local/share/applications
3) Gmail integration in messages indicator didn't work
4) no "Installed Websites" settings in Chromium settings
5) browser app mode didn't work (still saw all the browser menus)

What I did:
I only deleted "~/.config/chromium/Local State" as it contained legacy video card settings

Now
- Chromium only prompts for Unity integration for supported sites (issue 1 solved)
- I see the "Installed Websites" settings in Chromium settings (issue 4 solved)
- browser app mode works (issue 5 solved)

To get the desktop files created I use Firefox and open the url - Firefox prompts for Unity integration and creates the desktop file (issue2 solved).

Gmail integration in the messages indicator still doesn't work. As a workaround I edited applications under com.canonical.indicator.messages with dconf-editor and added GMailmailgooglecom.desktop. My application string now is:
['empathy.desktop', 'thunderbird.desktop', 'skype.desktop', 'GMailmailgooglecom.desktop']

I can launch now Gmail by clicking the icon in the messages menu but unfortunately the unread email counter still doesn't work. I'm still digging into this.

Chromium is my default browser and if I launch a webapp the Unity Launcher doesn't highlight the webapp's icon but the Chromium icon instead. So this is still an issue.

spi (spi-gmxpro) wrote :

Got Gmail webapp to support the message indicator - but only in Firefox. Launching Gmail with Chromium still doesn't support the message indicator.

As somebody already posted in
https://bugs.launchpad.net/ubuntu/+source/unity-webapps-gmail/+bug/1073397/comments/24 and https://bugs.launchpad.net/ubuntu/+source/unity-webapps-gmail/+bug/1073397/comments/25
I changed two lines in /usr/share/unity-webapps/userscripts/unity-webapps-gmail/GMail.user.js which were:

1st original line
var tag = document.evaluate('//div[@aria-label="Navigate to"]/span', document, null, XPathResult.ANY_UNORDERED_NODE_TYPE, null).singleNodeValue;

translated into German and changed to
var tag = document.evaluate('//div[@aria-label="zu wechseln"]/span', document, null, XPathResult.ANY_UNORDERED_NODE_TYPE, null).singleNodeValue;

2nd line
if (tag.textContent != 'Gmail' && tag.textContent != 'Mail') {

changed to
if (tag != null && tag.textContent != 'Gmail' && tag.textContent != 'Mail') {

Then deleted the webapp integration and restarted all unity-webapps services and daemons, recreated webapp integration with Firefox for Gmail and saw the unread message counter. But as mentioned in the beginning as soon I use Chromium the message counter is not set in the message indicator.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions