wayland is need libcairo2-dev but it isn't select for install. Broken packages

Bug #793399 reported by Maróti Ádám
16
This bug affects 4 people
Affects Status Importance Assigned to Milestone
wayland
New
Undecided
Unassigned
wayland (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

Binary package hint: wayland

If i try install the wayland package(sudo apt-get install wayland). I can't becouse i get these error:
(my ubuntu isn't english so i translate the errors)

Some packages could not be installed. This may mean that
an impossible situation or if you are using the unstable distribution
then you use some required packages have not yet been, or who
been moved out of Incoming.
The following information may help resolve the situation:

The following packages have unmet dependencies:
  libaccess-bridge-java: Depends: default-jre but it is to be installed or
                                        OpenJDK-6-jre but it is to be installed or
                                        sun-java6-jre but it is not installable
                          Recommended: libaccess-java-bridge-but the JNI is to be installed
  Wayland: Depends: libcairo2-dev (> = 1.10.2-2) but it is not selected for installation
E: Broken packages

If I install libcairo2-dev the problem is same, wayland install drop the error.

edit: i tried install sun-java6-jre but it's not available.

Related branches

description: updated
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wayland - 0.1.0~0-1ubuntu1

---------------
wayland (0.1.0~0-1ubuntu1) oneiric; urgency=low

  * Merge with Debian (experimental) packaging.
    - Update to newer snapshot, to 98d8256b from June 10, 2011.
      (LP: #729614, #733889)
    - Splits out demos to separate package
      (LP: #793399)
    - control: Provide client and server libs together in libwayland0
      binary package. Use shorter dependencies list. New package
      descriptions.
  * Remaining Ubuntu changes:
    - control: Replaces/Conflicts on previous binary names
    - control: Include wayland homepage
    - copyright: dep5 metadata
    - libwayland0.symbols.in: omit blank line (dpkg-gensymbols warning)
 -- Bryce Harrington <email address hidden> Tue, 12 Jul 2011 12:41:44 -0700

Changed in wayland (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers