[xorg-edgers] Wayland fails to start

Bug #700986 reported by shankao
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
wayland (Ubuntu)
Wishlist
Bryce Harrington

Bug Description

Binary package hint: xorg

I have added the wayland repo and launched the program with the following error:

shankao@emilia:~/dev/natty$ wayland-compositor -b /usr/share/backgrounds/space-01.jpg &
[1] 6288
shankao@emilia:~/dev/natty$ wayland-compositor: error while loading shared libraries: libEGL.so.1: cannot open shared object file: No such file or directory

As a side note, some of the last ubuntu versions in that repo does not seem to have build. The version that I get when I apt-get install wayland is 0.1~git20101124.32ff6901-0ubuntu1~natty, so It has not some of the last fixes made to the package neither the wstart script.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: xorg 1:7.5+6ubuntu6
ProcVersionSignature: Ubuntu 2.6.37-12.26-generic 2.6.37
Uname: Linux 2.6.37-12-generic i686
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/allscreens/options/active_plugins'
CompositorRunning: compiz
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1024x600
 edid-base64: AP///////wAGryAQAAAAAAESAQOAEwt4CvpWklZUmCQaT1QAAAABAQEBAQEBAQEBAQEBAQEBsBMAQEFYGSAYiAMBw3EAAAAYAAAADwAAAAAAAAAAAAAAAAAgAAAA/gBBVU8KICAgICAgICAgAAAA/gBBMDg5U1cwMSBWMCAKABk=
DRM.card0.VGA.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1280x1024 1280x1024 1280x960 1280x960 1280x960 1152x864 1152x864 1152x864 1024x768 1024x768 1024x768 832x624 800x600 800x600 800x600 800x600 640x480 640x480 640x480 640x480 720x400
 edid-base64: AP///////wAFI1B02CEAACcPAQNtIht46iwSolpKmSUbTla/7wBxQHFKcU+BQIFKgU+BgAEBMCoAmFEAKkAwcBMAUg4RAAAeAAAA/QAxSxhQDgAKICAgICAgAAAA/ABGLTQxNwogICAgICAgAAAA/wA4NjY0CiAgICAgICAgACM=
Date: Mon Jan 10 12:29:17 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus: virtualbox-ose, 3.2.12, 2.6.37-12-generic, i686: installed
EcryptfsInUse: Yes
GraphicsCard:
 Subsystem: ASUSTeK Computer Inc. Device [1043:830f]
   Subsystem: ASUSTeK Computer Inc. Device [1043:830f]
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
MachineType: ASUSTeK Computer INC. 901
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 LC_MESSAGES=en_US.utf8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.37-12-generic root=UUID=3d38f4d7-5c67-4834-8246-1b1e1ac2123b ro vt.handoff=7 quiet splash
Renderer: Hardware acceleration
SourcePackage: xorg
UnitySupportTest: Mesa warning: couldn't open libtxc_dxtn.so, software DXTn compression/decompression unavailable
dmi.bios.date: 07/08/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1001
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: 901
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: x.xx
dmi.chassis.asset.tag: 0x00000000
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTek Computer INC.
dmi.chassis.version: x.x
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1001:bd07/08/2008:svnASUSTeKComputerINC.:pn901:pvrx.x:rvnASUSTeKComputerINC.:rn901:rvrx.xx:cvnASUSTekComputerINC.:ct10:cvrx.x:
dmi.product.name: 901
dmi.product.version: x.x
dmi.sys.vendor: ASUSTeK Computer INC.
version.libdrm2: libdrm2 2.4.23+git20101221.bad5242a-0ubuntu0sarvatt
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.0+git20101118.3dcc3153-0ubuntu1~bryce10~natty
version.xserver-xorg: xserver-xorg 1:7.5+6ubuntu6
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.13.2-1ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.13.901-2ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20100805+b96170a-0ubuntu1

Related branches

Revision history for this message
shankao (shankao) wrote :
bugbot (bugbot)
affects: xorg (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
bugbot (bugbot)
tags: added: edgers
Revision history for this message
Bryce Harrington (bryce) wrote :

Yeah, I got the maverick packages working but the natty versions are still a work in progress.

Changed in xserver-xorg-video-intel (Ubuntu):
assignee: nobody → Bryce Harrington (bryce)
importance: Undecided → Wishlist
status: New → Triaged
Revision history for this message
Bryce Harrington (bryce) wrote :

This is fixed now

affects: xserver-xorg-video-intel (Ubuntu) → wayland (Ubuntu)
Changed in wayland (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers