package libwayland-dev 1.15.0-2 failed to install/upgrade: trying to overwrite '/usr/lib/x86_64-linux-gnu/pkgconfig/wayland-egl.pc', which is also in package libegl1-mesa-dev:amd64 18.0.5-0ubuntu0~18.04.1

Bug #1781440 reported by Till Kamppeter on 2018-07-12
38
This bug affects 6 people
Affects Status Importance Assigned to Milestone
wayland (Ubuntu)
Undecided
Timo Aaltonen
Bionic
Undecided
Unassigned
Cosmic
Undecided
Unassigned

Bug Description

[impact]

upgrade from bionic fails if libwayland-dev & libegl1-mesa-dev was installed

[test case]

install libwayland-dev & libegl1-mesa-dev on bionic, upgrade to cosmic

[regression potential]

none, the fix only changes the version numbers in Breaks/Replaces

--

Occured when upgrading from Bionic to Cosmic.

ProblemType: Package
DistroRelease: Ubuntu 18.10
Package: libwayland-dev 1.15.0-2
ProcVersionSignature: Ubuntu 4.15.0-24.26-generic 4.15.18
Uname: Linux 4.15.0-24-generic x86_64
ApportVersion: 2.20.10-0ubuntu5
Architecture: amd64
CompositorRunning: None
Date: Thu Jul 12 18:41:26 2018
DistUpgraded: Fresh install
DistroCodename: cosmic
DistroVariant: ubuntu
ErrorMessage: trying to overwrite '/usr/lib/x86_64-linux-gnu/pkgconfig/wayland-egl.pc', which is also in package libegl1-mesa-dev:amd64 18.0.5-0ubuntu0~18.04.1
GraphicsCard:
 Intel Corporation HD Graphics 620 [8086:5916] (rev 02) (prog-if 00 [VGA controller])
   Subsystem: Lenovo HD Graphics 620 [17aa:224e]
InstallationDate: Installed on 2018-02-07 (155 days ago)
InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Alpha amd64 (20180207)
MachineType: LENOVO 20JDCTO1WW
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-24-generic root=UUID=150ad8bc-1d20-4de9-a767-b2b0679455f3 ro quiet splash acpi_osi= vt.handoff=1
Python3Details: /usr/bin/python3.6, Python 3.6.6, python3-minimal, 3.6.5-3
PythonDetails: /usr/bin/python2.7, Python 2.7.15, python-minimal, 2.7.15-3
RelatedPackageVersions:
 dpkg 1.19.0.5ubuntu3
 apt 1.7.0~alpha2
SourcePackage: wayland
Title: package libwayland-dev 1.15.0-2 failed to install/upgrade: trying to overwrite '/usr/lib/x86_64-linux-gnu/pkgconfig/wayland-egl.pc', which is also in package libegl1-mesa-dev:amd64 18.0.5-0ubuntu0~18.04.1
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 10/26/2017
dmi.bios.vendor: LENOVO
dmi.bios.version: N1NET33W (1.20 )
dmi.board.asset.tag: Not Available
dmi.board.name: 20JDCTO1WW
dmi.board.vendor: LENOVO
dmi.board.version: SDK0J40709 WIN
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 31
dmi.chassis.vendor: LENOVO
dmi.chassis.version: None
dmi.modalias: dmi:bvnLENOVO:bvrN1NET33W(1.20):bd10/26/2017:svnLENOVO:pn20JDCTO1WW:pvrThinkPadX1Yoga2nd:rvnLENOVO:rn20JDCTO1WW:rvrSDK0J40709WIN:cvnLENOVO:ct31:cvrNone:
dmi.product.family: ThinkPad X1 Yoga 2nd
dmi.product.name: 20JDCTO1WW
dmi.product.version: ThinkPad X1 Yoga 2nd
dmi.sys.vendor: LENOVO
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.92-1
version.libgl1-mesa-dri: libgl1-mesa-dri 18.1.3-1ubuntu1
version.libgl1-mesa-glx: libgl1-mesa-glx 18.1.3-1ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.19.6-1ubuntu4
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:18.0.1-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20171229-1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.15-2

Till Kamppeter (till-kamppeter) wrote :
Till Kamppeter (till-kamppeter) wrote :

I upgraded from Bionic to Cosmic by editing /etc/apt/sources.list replacing all occurences of bionic by cosmic and then running

sudo apt update
sudo apt dist-upgrade

After some time the error occured and I cleaned up with

sudo apt install -f

and completed the upgrade with another

sudo apt dist-upgrade

which this time completed without errors.

In the end I did

sudo apt autoremove

to finish up.

So the error occured only once and after cleaning up I could complete the upgrade.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in wayland (Ubuntu):
status: New → Confirmed
Timo Aaltonen (tjaalton) wrote :

uhm, so there's a bug in the versions for Breaks/Replaces.. '-0' is lower than '0ubuntu0~' which is what bionic has.

Changed in wayland (Ubuntu):
assignee: nobody → Timo Aaltonen (tjaalton)
Timo Aaltonen (tjaalton) on 2018-11-27
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wayland - 1.16.0-1ubuntu2

---------------
wayland (1.16.0-1ubuntu2) disco; urgency=medium

  * control: Bump Breaks/Replaces again to match reality. (LP: #1781440)

 -- Timo Aaltonen <email address hidden> Tue, 27 Nov 2018 21:41:23 +0200

Changed in wayland (Ubuntu):
status: Confirmed → Fix Released

Hello Till, or anyone else affected,

Accepted wayland into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/wayland/1.16.0-1ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in wayland (Ubuntu Cosmic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-cosmic
Changed in wayland (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed-bionic
Adam Conrad (adconrad) wrote :

Hello Till, or anyone else affected,

Accepted wayland into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/wayland/1.16.0-1ubuntu1.1~18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Till Kamppeter (till-kamppeter) wrote :

Now the update from Bionic to Cosmic is correctly working. Thank you for the fix.

tags: added: verification-done verification-done-bionic verification-done-cosmic
removed: verification-needed verification-needed-bionic verification-needed-cosmic
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers