upgrade to wayland 1.2

Bug #1203015 reported by Sandra Karuving
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
wayland (Ubuntu)
Wishlist
Unassigned

Bug Description

With wayland/weston 1.2 release we've got a stable server API. only for this it would be good to have it in the saucy release, because of developers that want to test it

Please consider an upgrade to 1.2 of wayland/weston

http://lists.freedesktop.org/archives/wayland-devel/2013-July/010278.html
____

with tarballs available from

  http://wayland.freedesktop.org/releases.html

as usual. Between the release candidate (1.1.91) and 1.2.0, we
(mostly Brian Lovin) managed to drum up a few bugs which we (mostly
Rob Bradford) promptly fixed. We have a lot of changes since the last
major release (1.1.0) three months ago. The notable features this
time are:

 - Stable wayland-server API. When 1.0 was release we didn't proise a
   stable API for libwayland-server.so. This means that with every
   major Wayland release, compositor might break. When it was just
   weston, it wasn't a big deal, but as more external wayland
   compositors appear, we have to stop breaking this. Much of the
   input logic was split in an awkward way and has bee moved to
   weston. The remaining structs (mostly just wl_resource) have been
   made opaque. Finally, versioning didn't work correctly with the
   old API, so we had to replace a few functions. Much of this work
   was done by Jason Ekstrand.

 - Color management: Richard Hughes worked on color mangement for
   Wayland and implemented two schemes in Weston: a simple cms plugin
   that reads a profile from weston.ini and a more advanced plugin
   that integrates with colord. Here's a screenshot of how that in
   turn integrates with the GNOME control center:

     https://plus.google.com/107928060492923463788/posts/X62VdJxB2UK

 - The Wayland Input Method Framework from Jan Arne Petersen is
   feature complete, but we're keeping it in weston for now. We need
   a little more real world exposure and feedback before we promote
   this to official Wayland API. We have a sample on-screen keyboard
   in weston, and Maalit has also been ported to the framework.

 - Subsurface protocol from Pekka Paalanen. This extension lets us
   build up application windows from multiple Wayland surface,
   potentially combining surfaces with different color spaces or
   buffer types.

 - Output scaling (HiDPI) from Alex Larsson. Alex describes the
   feature best in this blog entry:

     http://blogs.gnome.org/alexl/2013/06/28/hidpi-support-in-gnome

   It's worth noting that this is not an arbitrary scaling mechanism,
   it is for scaling an entire output by an integer factor.

 - Rasperry Pi backend and renderer from Collabora. There was a lot
   of coverage on this one: Pekkas post is the most technical, Daniels
   gives a good overview and then there's the Collaboras case stuy and
   a linux.com article among others.

     http://ppaalanen.blogspot.com/2013/05/weston-on-raspberry-pi-accelerated.html
     http://fooishbar.org/tell-me-about/wayland-on-raspberry-pi/
     http://www.collabora.com/services/case-studies/raspberrypi
     http://www.linux.com/news/embedded-mobile/mobile-linux/721510-raspberry-pi-gains-graphics-speed-as-wayland-replaces-x

 - Improved thread safety and relaxed thread-model assumptions in
   libwayland-client. One of the restrictions in the client side
   library was that we assume that the toolkit or application will
   provide a "main thread" which is responsible for reading events and
   distributing them to event queues for the other threads. We also
   assume that there will always only be one such thread. It turs out
   that this breaks in many cases, in particular, it clashes with the
   threading model of EGL. The client side event processing has been
   reworked to not make those assumptions.

 - Multi seat support from Rob Bradford. We can now configure how
   input devices gets assigned to wl_seats by setting udev properties
   on the devices. This lets us setup multiple seats in weston,
   similar to multi-pointer X, where each seat gets its own pointer
   and keyboard focus. Additionally, a pointer can be confined to a
   given output.

 - New example client that illustrates the "application compositor"
   idea. Some clients need to share buffers - a popular example is
   process separation in web browsers. One client wants to render to
   a surface, the other client wants to use the result as a texture.
   In wayland, this is achieved by having one client act as a
   compositor to the other, and nested is a minimal example of how
   this is done.

 - Make libxkbcommon support optional from Matt Roper. Some use cases
   don't need a full PC keyboard, for example a car dashboard or a
   set-top box panel has buttons but not a keyboard in the traditional
   sense. In these cases, we only need keycodes, and libxkbcommon is
   just dead weight.

There's a lot of minor features and improved functionality as well and
we have a lot of bugs fixes in this cycle too. Just from commit
messages, I count at least

  66793, 66798, 66802, 66795, 63360, 57637, 63796, 65913, 63510,

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: libwayland-server0 1.1.0-2ubuntu1
ProcVersionSignature: Ubuntu 3.10.0-3.12-generic 3.10.1
Uname: Linux 3.10.0-3-generic x86_64
ApportVersion: 2.11-0ubuntu1
Architecture: amd64
Date: Fri Jul 19 13:01:54 2013
InstallationDate: Installed on 2013-06-06 (42 days ago)
InstallationMedia: Kubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
MarkForUpload: True
SourcePackage: wayland
UpgradeStatus: Upgraded to saucy on 2013-06-17 (31 days ago)

Revision history for this message
Sandra Karuving (lumks) wrote :
tags: added: upgrade-software-version
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in wayland (Ubuntu):
status: New → Confirmed
Revision history for this message
Robert Hooker (sarvatt) wrote :

Mesa doesn't build against it so we need to hold off a bit.

Changed in wayland (Ubuntu):
importance: Undecided → Wishlist
Revision history for this message
Jackson Doak (noskcaj) wrote :

You'll first need to get the new version into debian.

Revision history for this message
Oibaf (oibaf) wrote :
Revision history for this message
Oibaf (oibaf) wrote :

trusty has 1.3 now.

Changed in wayland (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.