wallpaper-tray always displays pictures from /usr/share/backgrounds

Bug #355081 reported by Mathieu Marquer on 2009-04-04
54
This bug affects 7 people
Affects Status Importance Assigned to Milestone
wallpaper-tray (Fedora)
Fix Released
Medium
wallpaper-tray (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: wallpaper-tray

I've asked wallpaper-tray to only display pictures from /media/docs/wallpapers, but it also displays pictures that are in /usr/share/backgrounds

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 9.04
NonfreeKernelModules: nvidia
Package: wallpaper-tray 0.5.5-0ubuntu2 [modified: usr/lib/gnome-panel/wp_tray]
ProcEnviron:
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: wallpaper-tray
Uname: Linux 2.6.29-020629-generic x86_64

Description of problem: Since the update to 0.5.3 (AFAIR) wp_tray is also using
/usr/share/backgrounds/images. I don't have this directory enabled in the settings.

Version-Release number of selected component (if applicable):
wp_tray-0.5.3-2.fc7

How reproducible:

Steps to Reproduce:
1. wait some time or manually use "Forward" to change the wallpaper
2.
3.

Actual results:
Some wallpapers are used from /usr/share/backgrounds/images

Expected results:
Since this directory is not configured in settings no wallpapers from there
should be used.

Additional info: cat ~/.gconf/apps/wp_tray/%gconf.xml

<?xml version="1.0"?>
<gconf>
        <entry name="b_follow_links" mtime="1178044064" type="bool" value="false">
        </entry>
        <entry name="b_img_check" mtime="1178044064" type="bool" value="true">
        </entry>
        <entry name="b_wp_logon" mtime="1178044064" type="bool" value="true">
        </entry>
        <entry name="b_timeout" mtime="1178044064" type="bool" value="true">
        </entry>
        <entry name="n_timeout" mtime="1178044064" type="int" value="15">
        </entry>
        <entry name="dir_list" mtime="1178044064" type="list" ltype="string">
                <li type="string">
                        <stringvalue>/daten/install/Wallpaper/Abtract</stringvalue>
                </li>
                <li type="string">
                        <stringvalue>/daten/install/Wallpaper/Fedora</stringvalue>
                </li>
                <li type="string">
                        <stringvalue>/daten/install/Wallpaper/Nature</stringvalue>
                </li>
                <li type="string">

<stringvalue>/daten/install/Wallpaper/Political</stringvalue>
                </li>
        </entry>
</gconf>

Right, this is actually not a bug. It seems to be a feature added to 0.5.3.
Essentially when it sets a random background, it will always add the wallpapers
list from the standard Gnome Desktop Background tool (from the file
~/.gnome2/backgrounds.xml).

Though i admit this is a pretty annoying feature. I'll provide a patch to make
this optional from the Preferences.

Fixed, added a patch to make the 0.5.3 "feature" optional in the Preferences
dialog. SRPM is available here :

http://www.poolshark.org/src/wp_tray-0.5.3-3.fc7.src.rpm

Please let me know if it fixes your problem.

(In reply to comment #2)
> Fixed, added a patch to make the 0.5.3 "feature" optional in the Preferences
> dialog. SRPM is available here :
>
> http://www.poolshark.org/src/wp_tray-0.5.3-3.fc7.src.rpm
>
> Please let me know if it fixes your problem.

It seems to work. I've set "Rotate Interval" to 1 minute and waited an hour.
I've also used "Forward" several times. No wallpaper from /usr/share/backgrounds
were used.

wp_tray-0.5.3-4.fc7 has been pushed to the Fedora 7 stable repository. If problems still persist, please make note of it in this bug report.

Mathieu Marquer (slasher-fun) wrote :
Patrick (veinor) wrote :

Same issue here; Ubuntu 9.04. I have it set to display images from /home/veinor/Pictures/dualwallpapers, but /usr/share/backgrounds is getting in there as well somehow.

LSimon (nessie7) wrote :

I am having the same problem. Just one folder should be displayed but it also displays other pictures. In my case wallpaper-tray uses pictures from all over my filesystem.
I erased one of these folders from the drive. Eversince it goes all black if it tries to run one of the pictures within this folder.
Already uninstalled (completeley) and reinstalled the App --> no change.

Same problem here, just like LSimon. Ubuntu 9.04. I also tried erasing a few files, and it still attempts to display them and gives me a blank screen. There has to be a list somewhere with all those filepaths, and it just keeps going back to that list without being able to update it. I did a search for wp_tray and looked through all the files it found on my system, but none of them appeared to have a path or file-list stored in them. Configuration editor shows the correct directory path (the one that it appears to be ignoring), so no luck there.

I created a testing account and checked how it worked there. There were no problems, so I am completely sure it's a problem with a configuration file somewhere in my home directory (because that is the only directory that was on its own partition when I did the 9.04 install, and everything else was wiped clean). The only problem is that there are a ton of configuration files and folders, and none of them are named wp_tray. So... it appears that Wallpaper Tray is getting that directory list from some file in there, and I'm not sure how to figure out which one.

ppetr (petr-podrouzek) wrote :

the same with me...always tries to pull out the default ubuntu wallpapers

Negro (emiliocolombo3) wrote :

I have the same problem, in Ubuntu 9.04.
Wallpaper Tray displays pictures that are in /usr/share/backgrounds and "black wallpapers" (when it goes black, I put the cursor over wallpaper-tray and it says "/home/<my_user>/Im")

Mark Howard (mh-tildemh) wrote :

I also have this problem, with i386 intel, so the amd64 tag may be misleading

tags: removed: amd64
Mark Howard (mh-tildemh) wrote :

This is also reported in redhat bugzilla. They have patched it to make this behaviour optional (no mention of sending the patch upstream :( )
Could we get the patch in ubuntu and forwarded upstream?

https://bugzilla.redhat.com/show_bug.cgi?id=239426

Changed in wallpaper-tray (Fedora):
status: Unknown → Fix Released

Patch from Fedora. Sent upstream, but they don't seem active.

https://sourceforge.net/tracker/?func=detail&aid=2797463&group_id=240143&atid=1112374

summary: - wallpaper-tray displays pictures from /usr/share/backgrounds
+ wallpaper-tray always displays pictures from /usr/share/backgrounds
Changed in wallpaper-tray (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Mark LaCore (nerdymark) wrote :

I was having the /usr/share/backgrounds issue and blank screen issue. I was able to resolve this on my install by removing ~/.gnome2/backgrounds.xml. Many stale entries in there that weren't properly removed. I suppose you can hand-edit the file but I'd rather zap/recreate it.

mlaverdiere (mlaverdiere) wrote :

Removing ~/.gnome2/backgrounds.xml also solved the problem for me, on Jaunty, using Wallpaper Tray 0.5.5. Thanks.

Dalle1985 (mortendalgaard) wrote :

Was experiencing the same issue, however, instead of removing the entire file (seems a bit blunt to just remove the entire file) I just opened the backgrounds.xml and removed all entries with the <wallpaper deleted="true"> value. I think the problem is that Wallpaper Tray just read this file without checking the above parameter, so it tries to load all the deleted pictures.

I have found another related bug while fighting this one btw: It doesn't understand strings with "non-english" signs in them. I have folders with the danish letters "æ", "ø" and "å" in them, and it just completely ignores these letters meaning it won't display pictures in these folders either. The xml-file includes the ascii code for the sign, but Wallpaper Tray can't translate them and therefore, it can't locate the pics!

I tried the fix suggested here, and it worked. However, it stopped working when I opened the "Change Desktop Background" window. I suspect that that dialog automatically updates the gnome2/backgrounds.xml file and ruins everything.

davidxy01 (davidxy01) on 2009-11-01
Changed in wallpaper-tray (Ubuntu):
status: Triaged → Confirmed
Anders Lauritsen (ducklord) wrote :

I hade a quick look at the code in wallpaper tray. When it selects a random wallpaper, i does not only load the wallpapers in the path selected, it always also consider all the wallpapers in the gnome wallpaper selector. (The list you can see when you right click the desktop, and select "Change desktop backgrounds") All of those are stored in the .gnome2/backgrounds.xml file, but that file will be regenerated when you open the "Change desktop backgrounds". Some one might contact the developer of Wallpaper tray and request af feature to disable the loading of the gnome backgrounds.

Gerald (gfe) wrote :

I had the same problem when using Karmic and Wallpaper Tray 0.5.5. Removing ~/.gnome2/backgrounds.xml also solved the problem.

David Futcher (bobbo) on 2010-06-10
tags: added: patch-forwarded-upstream
Chris Savery (chrissavery) wrote :

I have this problem as well and I think it's damn silly to allow selecting directories and then force users to have to also use the default one.

I don't know why this would be marked as low priority. It would seem to be an easy fix and so many users have complained about it. Is there a feeling that we darn well have to use the default backgrounds and so therefore this isn't a bug? I don't get it.

Why can't it just be fixed by adding the default directory into the list as with other directories so that the users can remove it if they wish or leave it if they wish.

Changed in wallpaper-tray (Fedora):
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.