wallch does not change wallpapers

Bug #1305203 reported by Pausanias on 2014-04-09
28
This bug affects 6 people
Affects Status Importance Assigned to Milestone
wallch (Ubuntu)
Undecided
Alex Solanos

Bug Description

The latest version of wallch does not change wallpapers.

All options work; the wallpaper shows up inside the wallch window; all preferences can be set. But the actual unity wallpaper does not change.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: wallch 4.0-0ubuntu4
ProcVersionSignature: Ubuntu 3.13.0-23.45-generic 3.13.8
Uname: Linux 3.13.0-23-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.14.1-0ubuntu1
Architecture: amd64
CurrentDesktop: Unity
Date: Wed Apr 9 10:32:53 2014
InstallationDate: Installed on 2014-03-17 (22 days ago)
InstallationMedia: It
SourcePackage: wallch
UpgradeStatus: No upgrade log present (probably fresh install)

Pausanias (pausanias) wrote :
Alex Solanos (hakermania) wrote :

Hello Pausanias! Nice name, and thanks for the bug report!

Are you sure you haven't altered the Desktop Environment option from the 3rd tab of the Preferences dialog?

On first run, Wallch does a guess on what desktop environment it runs, based on some files inside your filesystem. Its guess may be wrong though, so it may have set that option in the Preferences in something else than Unity.

Pausanias (pausanias) wrote :

It detects Unity.

When I click on a background in the wallpaper selector, the picture of it shows up on little preview window inside of wallch. However, the actual unity background does not change.

I tried clicking on "Start," and the timer starts running, but again, the background is not affected by wallch---it stays on whatever I set it to be prior to running wallch. I also tried clicking "Next," etc. No effect.

Just anecdotally, I tried wallch on a 14.04 system without an nvidia driver (running unity 2D) and it worked fine. The problem occurs on a system which is running compiz and the nvidia 3D driver.

Alex Solanos (hakermania) wrote :

Wallch internally uses the same mechanism (libraries) to change the wallpaper as the command 'gsettings set org.gnome.desktop.background file://direct-picture-path' does.

Can you please confirm, through a terminal, that this doesn't work?

Also, I think that Compiz is able to control the desktop. If Compiz has taken over the desktop control, then the desktop may not change? I really do not know :/

Pausanias (pausanias) wrote :

I can confirm that the above command does not work. The command that works for me is

gsettings set org.gnome.desktop.background picture-uri file:///direct-picture-path

gsettings spits out an error when I type in the command without 'picture-uri' as you suggest.

Pausanias (pausanias) wrote :

Also when I run wallch from the command line, I get this:

QEventLoop: Cannot be used without QApplication
QDBusConnection: system D-Bus connection created before QCoreApplication. Application may misbehave.

Not sure if this is relevant.

Pausanias (pausanias) wrote :

OK---I found the problem! In the integration settings tab I changed theme from "Autodetect" to "Radiance" and now everything works.

So the issue is that having the theme on "Autodetect" causes the wallpaper not to change for some reason.

Alex Solanos (hakermania) wrote :

Yeah, I mistyped the command.

This must truly be a bug. I'm going to test it right now. If reproducible, then I am going to confirm this.

The weird part is that "Autodetect" is the default option and I have tested multiple clear installations of Wallch with no problem at all.

Also, please take a look at the function of Wallch that changes the wallpaper: http://bazaar.launchpad.net/~wallch/wallpaper-changer/trunk/view/107/src/glob.cpp#L466

It has nothing to do with the current theme or whatever. I'm going to investigate the issue, anyway :D

Alex Solanos (hakermania) wrote :

Sorry, I cannot reproduce. I just downloaded the latest Ubuntu 14.04 nightly build, clean install. Installed Wallch, and it just works.

http://youtu.be/Oq1Yfb0B0Pg

Maybe your background manager was stuck or something. Nothing to do with your theme selection.

Mahdi Tohidian (m-tohidian) wrote :

Hi

I had a similar problem on Ubuntu 14.04.
After reading this conversation, I check the the Integration tab of Preference and saw Current Desktop Environment is set to XFCE!.

Though thanks for the clue.

Alex Solanos (hakermania) wrote :

Specifically for XFCE, Wallch searches for the file /usr/bin/xfconf-query

If it exists, then the DE will be guessed to be XFCE.

Glad I helped!

Rob (robsparks7) wrote :

This may be a little after the fact but I had the same exact problem. Receintly upgraded to 14.04 and can can confirm that changing theme manually out of auto and then changing current desktop environment to unity made Wallch function as designed. Thanks for the sollution.

Pausanias (pausanias) wrote :

Yes, clearly for some people on a fresh 14.04 install, wallch does not work properly. But once the theme has been changed from "Auto" to "Radiance" and desktop environment to "Unity" it works fine. Note that both changes ("theme" and "desktop environment") are required for wallch to work. Following this, switching the theme back from "Radiance" to "Auto" does not reproduce the bug.

Alex Solanos (hakermania) wrote :

Hello guys, we've found what is causing the problems and to be honest I cannot find a connection between changing the theme, but anyway, if this workaround works for all, then it would be good to follow it.

I am currently working to fix all the critical bugs mentioned the last days and trying to push an update to the main repos for 14.04.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in wallch (Ubuntu):
status: New → Confirmed
Changed in wallch (Ubuntu):
assignee: nobody → Alex Solanos (hakermania)
status: Confirmed → Fix Committed

Has this update being pushed to the current 14.04? It still does not seem to work.

Alex Solanos (hakermania) wrote :

This change can be obtained from the PPA https://launchpad.net/~wallch/+archive/ubuntu/wallch-4.0 but NOT from the official repository.

gnowair (womble-dung) wrote :

it just DOSNT WORK!
unity background does not change. nothing mentioned above helps.
also,where do i find anywhere to change from "radiance to auto", and timer does not start, and most of the time it crashes after ten seconds, after a few tries it now crashes a few seconds or as soon as i click start.

the only way i can think to solve it, is to uninstall it.

i may however try to fix suggested by downloading the ppa stuff.

gnowair (womble-dung) wrote :

no, i just realised just as i was about to go get the pps stuff for 4.0 that i already have 4.0, and it does not work (for me)
i can only uninstall it.
such a shame as i was looking so forward to some nice creativity and color.
good luck with any future fixes. this one however does NOT work(for me)

Alex Solanos (hakermania) wrote :

Please try downloading the PPA. It is not the 4.0 version, it is 4.16 i think.

Pausanias I had the same issue and just fixed it now thanks. Seems they should have that looked at as it seems to be happening alot here.

I am new to linux OS.

Ubuntu 10 was my first attempt and that ended badly and had to go back to windows but 14.04 seems to be here to stay. Anyways long story short I might actually send in a donation soon if everything goes well.

1 week in and sofar sogood.

Thanks again. To all linux users

Changed in wallch (Ubuntu):
status: Fix Committed → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers