walinuxagent 2.2.12

Bug #1690854 reported by Daniel Sol on 2017-05-15
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
walinuxagent (Ubuntu)
High
Łukasz Zemczak
Trusty
Undecided
Unassigned
Xenial
Undecided
Unassigned
Yakkety
Undecided
Unassigned
Zesty
Undecided
Unassigned

Bug Description

[Impact]
This release contains both bug-fixes and new features and we would like to
make sure all of our supported customers have access to these improvements.

See the changelog entry below for a full list of changes and bugs.

[Test Case]
The following development and SRU process was followed:
https://wiki.ubuntu.com/walinuxagentUpdates

The Microsoft Azure Linux Agent team will execute their testsuite, which
includes extension testing , against the walinuxagent that is in -proposed. A successful run will be required before the proposed walinuxagent can be let into -updates.

The CPC team will be in charge of attaching a summary of testing to the bug. CPC team members will not mark ‘verification-done’ until this has happened.

[Changelog]

- 2.2.12:
    [#711] There are too many log print to /var/log/waagent.log
    [#714] Questionable split call in common/conf.py
    [#717] Remove extension logs during deprovision
    [#720] Reset of RDMA drivers not taking effect
    [#721] WALA deprovision process not clean up all cloudinit files
    [#724] Location of configuration file should be editable issue
    [#725] v2.2.11 can throw unexpected exceptions on provisioned VMs
    [#727] v2.2.11 cannot update status for RDFE VMs

- 2.2.11:
    [#463] Ensure the transport certificate expires in no more than two years enhancement
    [#470] Emit goal state processing performance metrics enhancement
    [#518] Align with the Azure Stack protocol enhancement
    [#531] Location of configuration file should be editable feature request
    [#604] v2.2.x - Need new OS.SshDir in waagent.conf feature request
    [#631] Will "waagent -deprovision[+user]" wipe the cloud-init data? feature request
    [#668] Agent continuously logs error on FIPS compliant server
    [#679] Enable auto-update for AzureStack feature request
    [#682] Default route is not added if it already exists cla-not-required
    [#684] mkfs options out of order
    [#685] Change option order for mkfs. Alpine is being picky cla-already-signed
    [#686] Use of hostnameclt causes hostname rename lowercase for RHEL 7.x
    [#687] Enable customer-supported cloud-init
    [#688] Agent should purge /var/lib/waagent/events if it gets full
    [#689] Remove superseded extension folders / zip files
    [#693] Agent should remove unused extension directories and zip files enhancement
    [#694] Agent should not issue an HTTP HEAD to determine status blob type enhancement
    [#695] Ensure all udev rules are copied in Ubuntu cla-not-required
    [#699] [2.2.10] Some questions about Extension clean up
    [#701] Reduce polling time for extension processing
    [#706] Provision Event is not Fired if Customer Forgets to Deprovision VM

- 2.2.10:
    [#675] Clean up extension directories
    [#673] Provisioning logging improvements
    [#674] Override decode custom data
    [#670] Add Arch distro support

[Original Description]
It is with great pleasure I am pleased to announce that the Linux Agent (WALA) version 2.2.12 has now been signed off and is in Master now, it is of huge thanks to the dev team behind it who have really done a great job and for those of you who have contributed with feedback to make it better.

There are multiple fixes in here, some callouts:
1) This will be the version for Azure Stack support
2) FIPS support – we have some customers waiting on this.
3) Performance enhancements for improved extension provision times.

Next Steps
Please find the details of the items built into this release.
https://github.com/Azure/WALinuxAgent/releases

We would like you to take this version and test it within your images, please can you file any bugs in Github, as this is monitored by our dev team.

If you have any questions please reach out to me directly or raise it through Github.

Thanks,

tags: added: upgrade-software-version
Joshua Powers (powersj) on 2017-05-17
tags: added: artful server-next
Changed in walinuxagent (Ubuntu):
status: New → Triaged
importance: Undecided → High
Changed in walinuxagent (Ubuntu):
assignee: nobody → Łukasz Zemczak (sil2100)
Changed in walinuxagent (Ubuntu):
status: Triaged → In Progress
Łukasz Zemczak (sil2100) wrote :

I'm re-using the same bug for the release of 2.2.12 since the previous release had Ubuntu-related issues. Handling this now.

summary: - walinuxagent 2.2.11
+ walinuxagent 2.2.12
description: updated
description: updated
description: updated

Hello Daniel, or anyone else affected,

Accepted walinuxagent into zesty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/walinuxagent/2.2.12-0ubuntu1~17.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in walinuxagent (Ubuntu Zesty):
status: New → Fix Committed
Changed in walinuxagent (Ubuntu Yakkety):
status: New → Fix Committed
Andy Whitcroft (apw) wrote :

Hello Daniel, or anyone else affected,

Accepted walinuxagent into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/walinuxagent/2.2.12-0ubuntu1~16.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in walinuxagent (Ubuntu Xenial):
status: New → Fix Committed
Andy Whitcroft (apw) wrote :

Hello Daniel, or anyone else affected,

Accepted walinuxagent into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/walinuxagent/2.2.12-0ubuntu1~16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in walinuxagent (Ubuntu Trusty):
status: New → Fix Committed
Andy Whitcroft (apw) wrote :

Hello Daniel, or anyone else affected,

Accepted walinuxagent into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/walinuxagent/2.2.12-0ubuntu1~14.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package walinuxagent - 2.2.12-0ubuntu1

---------------
walinuxagent (2.2.12-0ubuntu1) artful; urgency=medium

  * New upstream release (LP: #1690854).
    - Refreshed debian/patches/disable_import_test.patch.

 -- Łukasz 'sil2100' Zemczak <email address hidden> Thu, 18 May 2017 19:58:02 +0200

Changed in walinuxagent (Ubuntu):
status: In Progress → Fix Released
tags: added: verification-done-trusty verification-done-xenial verification-done-yakkety verification-done-zesty
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package walinuxagent - 2.2.12-0ubuntu1~14.04.1

---------------
walinuxagent (2.2.12-0ubuntu1~14.04.1) trusty; urgency=medium

  * Backport artful version to trusty.
  * New upstream release (LP: #1690854).
    - Refreshed debian/patches/disable_import_test.patch.

 -- Łukasz 'sil2100' Zemczak <email address hidden> Thu, 18 May 2017 19:58:02 +0200

Changed in walinuxagent (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for walinuxagent has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package walinuxagent - 2.2.12-0ubuntu1~16.04.1

---------------
walinuxagent (2.2.12-0ubuntu1~16.04.1) xenial; urgency=medium

  * Backport artful version to xenial.
  * New upstream release (LP: #1690854).
    - Refreshed debian/patches/disable_import_test.patch.

 -- Łukasz 'sil2100' Zemczak <email address hidden> Thu, 18 May 2017 19:58:02 +0200

Changed in walinuxagent (Ubuntu Xenial):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package walinuxagent - 2.2.12-0ubuntu1~17.04.1

---------------
walinuxagent (2.2.12-0ubuntu1~17.04.1) zesty; urgency=medium

  * Backport artful version to zesty.
  * New upstream release (LP: #1690854).
    - Refreshed debian/patches/disable_import_test.patch.

 -- Łukasz 'sil2100' Zemczak <email address hidden> Thu, 18 May 2017 19:58:02 +0200

Changed in walinuxagent (Ubuntu Zesty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package walinuxagent - 2.2.12-0ubuntu1~16.10.1

---------------
walinuxagent (2.2.12-0ubuntu1~16.10.1) yakkety; urgency=medium

  * Backport artful version to yakkety.
  * New upstream release (LP: #1690854).
    - Refreshed debian/patches/disable_import_test.patch.

 -- Łukasz 'sil2100' Zemczak <email address hidden> Thu, 18 May 2017 19:58:02 +0200

Changed in walinuxagent (Ubuntu Yakkety):
status: Fix Committed → Fix Released
tags: added: id-591ce22edbda6317e2d5defb
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers