[SRU] Updated walinuxagent to 2.0.16

Bug #1549789 reported by Ben Howard on 2016-02-25
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
walinuxagent (Ubuntu)
High
Patricia Gaughen
Precise
High
Patricia Gaughen
Trusty
High
Patricia Gaughen

Bug Description

[IMPACT] Microsoft has released a bug fix release for walinuxagent that fixes several bugs. Microsoft has asked that the 2.0.14 version for Ubuntu 12.04 and 14.04 be updated to 2.0.16.

[Test Case 1]
1. Boot instance
2. Update walinuxagent from -proposed
3. Reboot
4. Confirm that /var/log/waagent.log is clean
5. Capture instance; boot new instance from captured instance
6. Confirm that instance provisions, /var/log/waagent.log is clean of errors and that /var/log/cloud-init.log is clean

[Test Case 2]
1. Create new image built from -proposed
2. Boot instance from new image
3. Confirm instance is accessable via SSH
4. Confirm /var/log/waagnet.log is clean
5. Confirm /var/log/cloud-init.log is clean of errors

[Common for both test cases]
1. Make that dataloss warning is in /mnt
2. Follow instructions on disabling the dataloss warning, reboot
3. Make sure that dataloss warning file is not present on reboot
4. Enable boot diagnostics for the instance in the Azure console
5. Make sure that SSH logging appears on the boot console.

[ORIGINAL REPORT]

WALinuxAgent has a new up release for 2.0.16.

Github Release: https://github.com/Azure/WALinuxAgent/releases/tag/v2.0.16
Changelog:
    Add timeout for http request
    Handle http 410 when reporting health
    Fix plugin version comparison
    Change swap file permission to 0600
    Add retry on restarting network interface
    Add retry on environment detection
    Add log for status report
    Copy status files from old plugin dir to new during upgrade
    Remove old plugin dir after upgrade

description: updated
summary: - Updated walinuxagent to 2.0.16
+ [SRU] Updated walinuxagent to 2.0.16
Changed in walinuxagent (Ubuntu Precise):
assignee: nobody → Ben Howard (utlemming)
Changed in walinuxagent (Ubuntu Trusty):
assignee: nobody → Ben Howard (utlemming)
Changed in walinuxagent (Ubuntu Precise):
importance: Undecided → High
Changed in walinuxagent (Ubuntu Trusty):
importance: Undecided → High
Changed in walinuxagent (Ubuntu Trusty):
assignee: Ben Howard (utlemming) → Robert C Jennings (rcj)
no longer affects: walinuxagent (Ubuntu Trusty)
Changed in walinuxagent (Ubuntu Precise):
assignee: Ben Howard (utlemming) → nobody
Changed in walinuxagent (Ubuntu Trusty):
importance: Undecided → High
assignee: nobody → Ben Howard (utlemming)
Changed in walinuxagent (Ubuntu Precise):
assignee: nobody → Ben Howard (utlemming)

Hello Ben, or anyone else affected,

Accepted walinuxagent into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/walinuxagent/2.0.16-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in walinuxagent (Ubuntu Trusty):
status: New → Fix Committed
Brian Murray (brian-murray) wrote :

Hello Ben, or anyone else affected,

Accepted walinuxagent into precise-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/walinuxagent/2.0.16-0ubuntu1~12.04.0 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in walinuxagent (Ubuntu Precise):
status: New → Fix Committed
Stephen A. Zarkos (stevez) wrote :

Can you please take the patch to the upstart file as well from this commit:
https://github.com/Azure/WALinuxAgent/commit/c5c9f763b30f50597e239cbfbf7b0e01edc237a8

Version 2.0.16 has half of this commit already, but since the Ubuntu packaging is different than what's in the repo it looks like we missed the other half.

Chris Halse Rogers (raof) wrote :

Hello Ben, or anyone else affected,

Accepted walinuxagent into precise-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/walinuxagent/2.0.16-0ubuntu2~12.04.0 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Liz Zhang (lizzha) wrote :

Test pass against the package in precise-proposed

Changed in walinuxagent (Ubuntu):
assignee: Ben Howard (utlemming) → Patricia Gaughen (gaughen)
Changed in walinuxagent (Ubuntu Precise):
assignee: Ben Howard (utlemming) → Patricia Gaughen (gaughen)
Changed in walinuxagent (Ubuntu Trusty):
assignee: Ben Howard (utlemming) → Patricia Gaughen (gaughen)
Robert C Jennings (rcj) wrote :

Precise testing was a success but Trusty failed.

In Trusty the agent works fine, but the respawn logic in the package for Ubuntu 14.04 is missing. The respawn logic in /lib/systemd/system/walinuxagent.service is present, but not in the upstart config (/etc/init/walinuxagent.conf). Precise does have the upstart job change (and changelog indicates that it was a backport from Trusty). Updating the Trusty package and getting it uploaded to have the proper upstart change.

tags: added: verification-done-precise verification-failed-trusty
Robert C Jennings (rcj) wrote :

Trusty fix: Restart walinuxagent via upstart when agent fails.

This is in precise-proposed already.

Chris J Arges (arges) wrote :

Hello Ben, or anyone else affected,

Accepted walinuxagent into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/walinuxagent/2.0.16-0ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Stephen A. Zarkos (stevez) wrote :

Tested, respawn logic works now, thanks!

tags: added: verification-done-trusty
removed: verification-failed-trusty
Robert C Jennings (rcj) on 2016-04-27
tags: added: verification-done
removed: verification-done-precise verification-done-trusty
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package walinuxagent - 2.0.16-0ubuntu2~12.04.0

---------------
walinuxagent (2.0.16-0ubuntu2~12.04.0) precise; urgency=medium

  * Backport of 2.0.16 from 14.04 (LP: #1549789):
    - restart walinuxagent via upstart when agent fails.

 -- Ben Howard <email address hidden> Mon, 04 Apr 2016 09:35:04 -0600

Changed in walinuxagent (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for walinuxagent has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package walinuxagent - 2.0.16-0ubuntu2

---------------
walinuxagent (2.0.16-0ubuntu2) trusty; urgency=medium

  * Restart walinuxagent via upstart when agent fails. (LP: #1549789)

 -- Robert C Jennings <email address hidden> Mon, 25 Apr 2016 12:47:17 -0500

Changed in walinuxagent (Ubuntu Trusty):
status: Fix Committed → Fix Released

The attachment "walinux_2.0.16-0ubuntu2_trusty.patch" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Michael Terry (mterry) wrote :

As this bug was only about SRUs, I'm just going to mark the master (yakkety) task invalid to clean this bug up.

Changed in walinuxagent (Ubuntu):
status: In Progress → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers