[SRU] Update walinuxagent package for Precise to v2.0.5

Bug #1321427 reported by Stephen A. Zarkos on 2014-05-20
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
walinuxagent (Ubuntu)
High
Ben Howard
Precise
High
Ben Howard
Trusty
High
Ben Howard

Bug Description

SRU Justification

IMPACT:
WALinuxAgent 1.3.2 lacks features and bug fixes; these features and fixes are not being backported.

For 14.04, the current code base is 2.0.4; 2.0.5 is largely a selection of bug fixes. The current extension handlers are not robust and may leak an exception, causing the agent to crash mid boot. There are also numerous fixes in the plugin handling.

TEST CASES
New Image
 * Build new image from -proposed, confirm that it boots
 * Boot new instance w/ user-data
   - confirm cloud-init consumed user-data

Upgrade:
 * Upgrade 12.04 and 14.04 instance w/ -proposed walinuxagent
   * for 12.04, replace waagent.conf when prompted, confirm it comes up properly
   * for 12.04, don't replace waagent.conf when prompted, confirm is comes up properly
 * Reboot, confirm instance came back up
 * Rebundle instance, confirm that new rebundling works
 * Upgrade 12.04 to 14.04, reboot. Confirm that instance comes up

REGRESSION POTENTIAL:
There is some risk of regression potential. MS has confirmed that that 2.0.5 has been thoroughly tested by MS on 12.04. However, for 12.04 it is a shift from 1.3.2 series to 2.0.5.

For 14.04, the regession potential lower, as the changes are bug fixes to 2.0.4 version.

ORIGINAL REPORT:
This is a request from Microsoft to please update the walinuxagent package for Ubuntu 12.04 from v1.3.2 to the latest WALinuxAgent 2.0.5.

The Microsoft team has implemented new features and bugfixes into the 2.0 branch that will not be backported to the 1.x branch. The most important of these is the support for extension handlers on Azure, which will be a widely used and compelling feature for Azure moving forward.

Thanks,
Steve

Ben Howard (utlemming) on 2014-05-20
Changed in walinuxagent (Ubuntu):
assignee: nobody → Ben Howard (utlemming)
status: New → Confirmed
importance: Undecided → High
Ben Howard (utlemming) on 2014-05-20
description: updated
summary: - Update walinuxagent package for Precise to v2.0.5
+ [SRU] Update walinuxagent package for Precise to v2.0.5
description: updated
Ben Howard (utlemming) wrote :

Attached debdiff of walinuxagent_1.3.2-0ubuntu4~12.04.7 to walinuxagent_2.0.5-0ubuntu1~12.04

Ben Howard (utlemming) wrote :

Attached debdiff of walinuxagent_2.0.4-0ubuntu2 to walinuxagent_2.0.5-0ubuntu1~14.04

Changed in walinuxagent (Ubuntu Precise):
importance: Undecided → High
Changed in walinuxagent (Ubuntu Trusty):
importance: Undecided → High
assignee: nobody → Ben Howard (utlemming)
Changed in walinuxagent (Ubuntu Precise):
assignee: nobody → Ben Howard (utlemming)
Ben Howard (utlemming) wrote :
Ben Howard (utlemming) wrote :
Ben Howard (utlemming) wrote :

Since we are upgrading WALinuxAgent from 1.3.2 to 2.0.5 for Precise, I want to be absolutely sure that this safe, so I spent the better part of day testing, retesting and confirming that this is safe.

Uploaded 2.0.5 for 12.04 and 14.04.

description: updated
Ben Howard (utlemming) on 2014-05-27
description: updated
tags: added: patch

Hello Stephen, or anyone else affected,

Accepted walinuxagent into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/walinuxagent/2.0.5-0ubuntu2~14.04.0 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in walinuxagent (Ubuntu):
status: Confirmed → Invalid
Changed in walinuxagent (Ubuntu Trusty):
status: New → Fix Committed
Changed in walinuxagent (Ubuntu Precise):
status: New → Fix Committed
Adam Conrad (adconrad) wrote :

Hello Stephen, or anyone else affected,

Accepted walinuxagent into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/walinuxagent/2.0.5-0ubuntu2~12.04.0 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Ben Howard (utlemming) wrote :

I've run through all the test cases multiple times, and did several new image builds to confirm everything is sane and works. Further, I have also looked at other SRU's validation cases to doubly make sure that things work.

Marking as verification done.

tags: added: verification-done
Stephen A. Zarkos (stevez) wrote :

We have run our network, VNET, BVT and E2E tests using the walinuxagent 2.0.5 package for Ubuntu 12.04 and found no issues.

Cloud Test Update:

* Network Tests : Completed.
[41 PASS, 1 XFAIL]
                Expected Failed Tests :
1. NETWORK-IDNS-SINGLEHS-CHANGED-HOSTNAME
Reason : After changing the hostname of another VM in same hosted service, we are unable to resolve new hostname with nslookup. This is expected behavior on Ubuntu systems as they set 'Provisioning.MonitorHostName=n' in /etc/waagent.conf.

* VNET Tests : Completed
[15 PASS, 0 FAIL]
                No issues.

* BVT Tests : Completed

* E2E Tests : Completed

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package walinuxagent - 2.0.5-0ubuntu2~12.04.0

---------------
walinuxagent (2.0.5-0ubuntu2~12.04.0) precise; urgency=medium

  * Backport from 14.10 development version to 12.04 (LP: #1321427).
    * Use 12.04 appropriate dependencies and standards version.
    * Dropped debian/postinst as incompatible with 12.04.
 -- Ben Howard <email address hidden> Mon, 26 May 2014 14:36:16 -0600

Changed in walinuxagent (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for walinuxagent has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package walinuxagent - 2.0.5-0ubuntu2~14.04.0

---------------
walinuxagent (2.0.5-0ubuntu2~14.04.0) trusty; urgency=medium

  * Straight backport to 14.04 (LP: #1321427).
    * Use 14.04 appropriate dependencies.
 -- Ben Howard <email address hidden> Mon, 26 May 2014 14:36:16 -0600

Changed in walinuxagent (Ubuntu Trusty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers