[SRU] cloud-init should handle formating the azure disks

Bug #1231490 reported by Ben Howard on 2013-09-26
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cloud-init (Ubuntu)
Medium
Ben Howard
Precise
Medium
Ben Howard
Quantal
Low
Ben Howard
Raring
Medium
Ben Howard
walinuxagent (Ubuntu)
Medium
Ben Howard
Precise
Medium
Ben Howard
Quantal
Low
Ben Howard
Raring
Medium
Ben Howard

Bug Description

[Impact]: With Cloud-init on 13.10, the ability for Cloud-init to parition and prepare the ephemeral devices was added. By default, 13.10 handles the formating of Windows Azure Cloud Images. As part of Bug: #1233315, the functionality has been backported to support SmartOS. This SRU will change the provisioning of pre-13.10 Windows Azure instances to use the same functionality for ephemeral device preparation as SmartOS.

For 12.04, this simply is enabling the ephemeral device formating support. For 12.10 and 13.04, the full Windows Azure DataSource from 13.10 has been backported and finalizes the SRU in Bug: #1037723

[Test Case]: See Comment 4 for detailed test case information
SmartOS:
- Build image with SmartOS enabled as Cloud-init datasource
- Login via SSH
- Confirm:
  - /dev/vdb mounted to /mnt
  - /dev/vdb is of type ext3, label is 'ephemeral0'

Azure:
* Upgrade:
  - Boot current image
  - install new packages
  - confirm that previous /etc/waagent.conf has provisioning functions turned on
  - make sure that /var/lib/instance/sem/config-disk-setup is present
  - place file on ephemeral drive
  - reboot
  - confirm that file is on ephemeral drive
  - look at /var/lib/cloud-init.log indicates that disk_setup was skipped
* New Image:
  - Boot image built with new packages (i.e. from PPA/proposed)
  - confirm that /etc/waagent.conf has provisioning and ephemeral disk functions disabled
  - confirm that /dev/sdb1 mounted to /mnt
  - confirm that /dev/sdb1 is of type ext4, no label
* Confirm test cases in Bug: #1231490

[Regression]: This SRU adds a default cloud-init module of "disk_setup," which will format ephemeral devices for the Azure and SmartOS datasources. Both the Azure and SmartOS datasources define default devices that should be partitioned/formated.

There are a number of safe guards to prevent accidental data-deletion. The datasources are configured to _not_ overwrite any file system and to detect if the disk is in use.

As a further safe guard, the postinst sets a semaphore for cloud-init to prevent the disk_setup module from running when it detects that a system has been previously configured.

[ORIGINAL REPORT]: With bug #1218506, cloud-init is now able to format the ephemeral disk. Currently walinuxagent handles the preperation of the ephemeral disk. Since cloud-init can handle doing that work now, this feature in walinuxagent should be disabled and enabled for cloud-init in the Windows Azure data source.

Related branches

Ben Howard (darkmuggle) on 2013-09-26
Changed in ubuntu:
importance: Undecided → Medium
status: New → In Progress
assignee: nobody → Ben Howard (utlemming)
Ben Howard (darkmuggle) wrote :

Attached branch lp:~utlemming/ubuntu/precise/cloud-init/lp123315-1231490 that has all the bits for Azure disk formating, ephermalX.Y and SmartOS backport to 12.04.

Tested on both Windows Azure, EC2 and SmartOS targets.

Ben Howard (darkmuggle) on 2013-10-17
summary: - cloud-init should handle formating the azure disks
+ [SRU] cloud-init should handle formating the azure disks
Ben Howard (darkmuggle) on 2013-10-17
description: updated

Hello Ben, or anyone else affected,

Accepted cloud-init into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/cloud-init/0.6.3-0ubuntu1.8 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Stéphane Graber (stgraber) wrote :

Hello Ben, or anyone else affected,

Accepted walinuxagent into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/walinuxagent/1.3.2-0ubuntu4~12.04.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

affects: ubuntu → walinuxagent (Ubuntu)
affects: cloud-utils (Ubuntu) → cloud-init (Ubuntu)
Changed in cloud-init (Ubuntu Precise):
status: New → Fix Committed
Changed in walinuxagent (Ubuntu Precise):
status: New → Fix Committed
Changed in walinuxagent (Ubuntu):
status: In Progress → Fix Released
Changed in cloud-init (Ubuntu):
status: New → Fix Released
Ben Howard (darkmuggle) on 2013-10-22
Changed in walinuxagent (Ubuntu Precise):
assignee: nobody → Ben Howard (utlemming)
Changed in walinuxagent (Ubuntu Raring):
assignee: nobody → Ben Howard (utlemming)
Changed in walinuxagent (Ubuntu Quantal):
assignee: nobody → Ben Howard (utlemming)
Changed in cloud-init (Ubuntu):
assignee: nobody → Ben Howard (utlemming)
Stéphane Graber (stgraber) wrote :

Hello Ben, or anyone else affected,

Accepted cloud-init into raring-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/cloud-init/0.7.2-0ubuntu0.13.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in cloud-init (Ubuntu Raring):
status: New → Fix Committed
Stéphane Graber (stgraber) wrote :

Hello Ben, or anyone else affected,

Accepted walinuxagent into raring-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/walinuxagent/1.3.2-0ubuntu2~13.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in walinuxagent (Ubuntu Raring):
status: New → Fix Committed
Ben Howard (darkmuggle) wrote :

Verified both upgrade and new image paths. Marking as verification-done.

Changed in cloud-init (Ubuntu):
importance: Undecided → Medium
Changed in cloud-init (Ubuntu Precise):
importance: Undecided → Medium
Changed in cloud-init (Ubuntu Raring):
importance: Undecided → Medium
Changed in cloud-init (Ubuntu Quantal):
importance: Undecided → Low
Changed in walinuxagent (Ubuntu Precise):
importance: Undecided → Medium
Changed in walinuxagent (Ubuntu Quantal):
importance: Undecided → Medium
Changed in walinuxagent (Ubuntu Raring):
importance: Undecided → Medium
Changed in walinuxagent (Ubuntu Quantal):
importance: Medium → Low
tags: added: cloud-images verification-done windows-azure
removed: verification-needed
Changed in cloud-init (Ubuntu Precise):
assignee: nobody → Ben Howard (utlemming)
Changed in cloud-init (Ubuntu Quantal):
assignee: nobody → Ben Howard (utlemming)
Changed in cloud-init (Ubuntu Raring):
assignee: nobody → Ben Howard (utlemming)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package walinuxagent - 1.3.2-0ubuntu4~12.04.5

---------------
walinuxagent (1.3.2-0ubuntu4~12.04.5) precise-proposed; urgency=low

  * Disable ephemeral format functions by default; this is now handled in
    cloud-init by default (LP: #1231490).
 -- Ben Howard <email address hidden> Fri, 11 Oct 2013 15:42:12 -0600

Changed in walinuxagent (Ubuntu Precise):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cloud-init - 0.6.3-0ubuntu1.8

---------------
cloud-init (0.6.3-0ubuntu1.8) precise-proposed; urgency=low

  * debian/patches/lp-1233315-add-smartos-support.patch:
    Add SmartOS DataSource, including disk format support (LP: #1233315).
  * debian/patches/lp-1231490-azure-ephemeral-format.patch:
    Format Windows Azure ephemeral disks (LP: #1231490)
  * debian/patches/lp-1233315-1231490-ephmeralX.Y-support.patch:
    Add support for referencing ephemeral devices as 'ephemeralX.Y
    (LP: #1231490, LP: #1233315)
 -- Ben Howard <email address hidden> Wed, 16 Oct 2013 08:17:35 -0600

Changed in cloud-init (Ubuntu Precise):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package walinuxagent - 1.3.2-0ubuntu2~13.04.1

---------------
walinuxagent (1.3.2-0ubuntu2~13.04.1) raring-proposed; urgency=low

  * Backport of 1.3.2-0ubuntu5 from 13.10
    * disable ephemeral disk formating by default (LP: #1231490)
    * debian/patches/shadow_permissions.patch: apply the appropriate
      permissions to /etc/shadow (LP: #1188820).
    * debian/patches/verbose_logging.patch: use the appropriate log
      faculty when using verbose logging (LP: #1193404).
    * Mark bugs fixed in 1.3.2-0ubuntu3:
      debian/patches/config_for_cloud-init.patch:
      - fix for race condition between cloud-init and waagent (LP: #1195524)
      - mount resource disk on /mnt (LP: #1193380)
      - move walinuxagent init functionality to cloud-init (LP: #1037723)
  * Add requirement of cloud-init (LP: #1037723).
 -- Ben Howard <email address hidden> Thu, 10 Oct 2013 09:24:46 -0600

Changed in walinuxagent (Ubuntu Raring):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cloud-init - 0.7.2-0ubuntu0.13.04.2

---------------
cloud-init (0.7.2-0ubuntu0.13.04.2) raring-proposed; urgency=low

  [ Ben Howard ]
  * debian/patches/lp-1233315-1231490-smartos_azure_disk_format.patch:
    Backport from upstream 0.7.4:
    * SmartOS datasource to support booting on SmartOS Cloud targets
        (LP: #1233315)
    * Support for ephemeral drive formating for SmartOS
    * Enable default ephemeral formating for Windows Azure (LP: #1231490)
    * Support for shorthand on default block mappings, i.e. ephemeral0.1
      for both mounts and disk formatting.
    * Use partition on mount directives if available (LP: #1231490).
  * debian/cloud-init.postinst: ensure that disk-setup module is not run
    on upgrade.
 -- Scott Moser <email address hidden> Mon, 21 Oct 2013 18:00:50 -0700

Changed in cloud-init (Ubuntu Raring):
status: Fix Committed → Fix Released
Ben Howard (darkmuggle) wrote :

Marking Quantal as won't fix due to the invasive changes needed to cloud-init to support user-creation. Quantal creates a default user of "ubuntu" and does not have a clean way to handle changing that.

Changed in walinuxagent (Ubuntu Quantal):
status: New → Won't Fix
Changed in cloud-init (Ubuntu Quantal):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers