[SRU] update Windows Azure WALinuxAgent to 1.3.2 (12.04.2, 12.10 and 13.04)

Bug #1158465 reported by Ben Howard on 2013-03-21
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
walinuxagent (Ubuntu)
High
Unassigned
Precise
Critical
Unassigned
Quantal
Critical
Unassigned

Bug Description

Upgrade walinuxagent to 1.3.2 to enhance logging for Azure platform issues.

SRU justification

Impact : In the case of provisioning failures on Windows Azure, Microsoft looks for the provisioning logs from the instance. Currently the provisioning logs fail do not include enough detail. Due the popularity of the of Ubuntu images, Microsoft has requested that we update the agent code to the 1.3.2 release to capture the logs for failure provisioning.

Microsoft is asking all users on Windows Azure to upgrade for 1.3.2 and has made it a requirement for partner image updates.

Test Case :
 - Create a 12.04, 12.10 Precise instance on Azure
      - Upgrade to the latest walinuxagent
      - Reboot
 - Build new images from -proposed
      - Boot to make sure it provisions

User should be able to use 'sudo' to gain administrator's privileges from the user account defined when the instance was created.

Regression : No regressions are expected. As detailed above, the changes are logging related. Microsoft released this code over a month ago and has done exhaustive testing of the 1.3.2 code. Further, the Ubuntu Azure Cloud Images have been subjected to full cycle testing (building new images with new agent) and upgrade testing.

Since walinuxagent only affects Windows Azure users and because Windows Azure is still in preview status, the impact of this SRU is miminial.

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1158465/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment

Initial packaging branches done.

Due to MS incorporating our patches into upstream, these branches _drop_ all Ubuntu modifications except that they carry our /debian directories. This means that updating to the latest is _much_easier.

affects: ubuntu → walinuxagent (Ubuntu)
Changed in walinuxagent (Ubuntu):
importance: Undecided → Critical
importance: Critical → High

Validated Precise, Quantal and Raring against PPA branch. Waiting on MP to be accepted for Raring.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package walinuxagent - 1.3.2-0ubuntu1

---------------
walinuxagent (1.3.2-0ubuntu1) raring; urgency=low

  * Updated to 1.3.2 as part of Windows Azure requirement (LP: #1158465).
  * Upstream now supports packaging; incorporated upstream packaging into
    Ubuntu Packaging.
 -- Ben Howard <email address hidden> Thu, 21 Mar 2013 12:57:08 -0600

Changed in walinuxagent (Ubuntu):
status: New → Fix Released
summary: - update Windows Azure WALinuxAgent to 1.3.2 (12.04.2, 12.10 and 13.04)
+ [SRU] update Windows Azure WALinuxAgent to 1.3.2 (12.04.2, 12.10 and
+ 13.04)
description: updated
description: updated
Changed in walinuxagent (Ubuntu Precise):
importance: Undecided → Medium
Changed in walinuxagent (Ubuntu Quantal):
importance: Undecided → Medium
Changed in walinuxagent (Ubuntu Precise):
status: New → In Progress
Changed in walinuxagent (Ubuntu Quantal):
status: New → In Progress
Changed in walinuxagent (Ubuntu Precise):
importance: Medium → Critical
Changed in walinuxagent (Ubuntu Quantal):
importance: Medium → Critical
description: updated
David Medberry (med) wrote :

Resolved. PEBCAK. Please continue.

Adam Stokes (adam-stokes) wrote :

Re: #6, what is the context of 'Resolved'? Anything you need from me to make sure this issue is actively reviewed?

David Medberry (med) wrote :

Resolved had to do with the PEBCAK and the comment I hid. I'm hoping this SRU is still under way.

Hello Ben, or anyone else affected,

Accepted walinuxagent into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/walinuxagent/1.3.2-0ubuntu1~12.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in walinuxagent (Ubuntu Precise):
status: In Progress → Fix Committed
Changed in walinuxagent (Ubuntu Quantal):
status: In Progress → Fix Committed
Adam Conrad (adconrad) wrote :

Hello Ben, or anyone else affected,

Accepted walinuxagent into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/walinuxagent/1.3.2-0ubuntu1~12.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Verified proposed packages for 12.04 and 12.10 using virgin builds.
Verified proposed packages via upgrades for 12.04 and 12.10 with published images

Marking as verifed

tags: added: verified
Colin Watson (cjwatson) wrote :

Waiving the usual seven-day waiting period due to image release urgency.

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package walinuxagent - 1.3.2-0ubuntu1~12.04.1

---------------
walinuxagent (1.3.2-0ubuntu1~12.04.1) precise; urgency=low

  * New upstream release per Microsoft request (LP: #1158465).
  * Dropped Ubuntu packaging deltas as upstream supports packaged
    versions.
 -- Ben Howard <email address hidden> Thu, 21 Mar 2013 14:52:27 -0600

Changed in walinuxagent (Ubuntu Precise):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package walinuxagent - 1.3.2-0ubuntu1~12.10.1

---------------
walinuxagent (1.3.2-0ubuntu1~12.10.1) quantal; urgency=low

  * Updated to 1.3.2 as part of Windows Azure requirement (LP: #1158465).
  * Upstream now supports packaging; incorporated upstream packaging into
    Ubuntu Packaging.
 -- Ben Howard <email address hidden> Thu, 21 Mar 2013 14:57:40 -0600

Changed in walinuxagent (Ubuntu Quantal):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers