FTBFS in edgy

Bug #65838 reported by Fabio Massimo Di Nitto on 2006-10-13
2
Affects Status Importance Assigned to Milestone
wacom-tools (Ubuntu)
High
Scott James Remnant (Canonical)

Bug Description

gcc -g -O2 -I/usr/include/tcl8.4/ -fPIC -pipe -ansi \
                -pedantic -Wall -Wpointer-arith -fno-merge-constants \
                -I. -I/usr/include/xorg -I/usr/include/xorg/../X11/ -Dlinux \
                -D_POSIX_C_SOURCE=199309L -D_POSIX_SOURCE \
                -D_XOPEN_SOURCE -D_BSD_SOURCE -D_SVID_SOURCE -D_GNU_SOURCE \
                -DSHAPE -DXINPUT -DXKB -DLBX -DXAPPGROUP -DXCSECURITY \
                -DTOGCUP -DXF86BIGFONT -DDPMSExtension -DPIXPRIV -DPANORAMIX \
                -DRENDER -DGCCUSESGAS -DAVOID_GLYPHBLT -DPIXPRIV \
                -DSINGLEDEPTH -DXFreeXDGA -DXvExtension -DXFree86LOADER \
                -DXFree86Server -DXF86VIDMODE -DXvMCExtension \
                -DSMART_SCHEDULE -DBUILDDEBUG -DXResExtension \
                -DX_BYTE_ORDER=X_LITTLE_ENDIAN \
                -DNDEBUG -DFUNCPROTO=15 \
                -DNARROWPROTO -DIN_MODULE -DXFree86Module -DLINUX_INPUT \
                -o xf86Wacom.o -c xf86Wacom.c
In file included from /usr/include/xorg/xisb.h:32,
                 from xf86Wacom.h:77,
                 from xf86Wacom.c:100:
/usr/include/unistd.h:418: error: conflicting types for ‘xf86usleep’
/usr/include/xorg/xf86_ansic.h:345: error: previous declaration of ‘xf86usleep’ was here
In file included from /usr/include/xorg/xisb.h:32,
                 from xf86Wacom.h:77,
                 from xf86Wacom.c:100:
/usr/include/unistd.h:935:29: error: macro "getpagesize" passed 1 arguments, but takes just 0
make[4]: *** [xf86Wacom.o] Error 1
make[4]: Leaving directory `/usr/src/ubuntu/foo/wacom-tools-0.7.2/linuxwacom/builddir/src'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/usr/src/ubuntu/foo/wacom-tools-0.7.2/linuxwacom/builddir/src'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/usr/src/ubuntu/foo/wacom-tools-0.7.2/linuxwacom/builddir'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/usr/src/ubuntu/foo/wacom-tools-0.7.2/linuxwacom/builddir'
make: *** [build-arch-stamp] Error 2

Changed in wacom-tools:
assignee: nobody → keybuk
importance: Undecided → High
status: Unconfirmed → Confirmed

Am sure this is an X bug, fiddling with the header include order solved this

Changed in wacom-tools:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers