Doesn't provide development headers

Bug #5918 reported by Sven Herzberg
8
Affects Status Importance Assigned to Milestone
wacom-tools (Debian)
Fix Released
Unknown
wacom-tools (Ubuntu)
Wishlist
Unassigned

Bug Description

The wacom-tools source package doesn't provide a package with headers for development.

Related branches

Revision history for this message
Sven Herzberg (herzi) wrote : Patch

A debdiff to be applied to fix this issue.

Changed in wacom-tools:
assignee: nobody → ubuntu-kernel-team
Changed in wacom-tools:
assignee: ubuntu-kernel-team → mjg59
Revision history for this message
SVAKSHA (svaksha) wrote :

Hello and thanks for reporting this bug. A debdiff patch was posted on 2005-12-19. Can you reproduce this problem with the latest Dapper source ? The beta release of Dapper is scheduled for next Thursday, 20060420 and we would like to fix bugs before the beta is publicized. -Thanks!

Changed in wacom-tools:
status: Unconfirmed → Needs Info
Revision history for this message
Sven Herzberg (herzi) wrote :

I still don't use the latest dapper packages because of bug 39526

Revision history for this message
towsonu2003 (towsonu2003) wrote :

I don't see any wacom-tools-dev packages in dapper[up-to-date if that matters] nor edgy[up-to-date if that matters]. confirming. thank you for your bug report :)

Changed in wacom-tools:
status: Needs Info → Confirmed
Revision history for this message
towsonu2003 (towsonu2003) wrote :

I think someone needs to update the assignee for this bug?

Revision history for this message
Timo Aaltonen (tjaalton) wrote :

Sven: can you file this on Debian?

Timo Aaltonen (tjaalton)
Changed in wacom-tools:
importance: Medium → Wishlist
Revision history for this message
Robert Gerlach (khnz) wrote :

Bug still exists in Hardy and Intrepid. Debian Bug #443499.

Bryce Harrington (bryce)
Changed in wacom-tools:
status: Confirmed → Triaged
Changed in wacom-tools:
status: Unknown → New
Revision history for this message
Fuzzy Lai (fuzzylai) wrote :

This bug remains in ubuntu 9.04 beta so far.

It would be a great help for tablet application development if the headers are packaged and distributed well.

Revision history for this message
Robert Gerlach (khnz) wrote :
Revision history for this message
Bryce Harrington (bryce) wrote :

Thanks. What I'll do is update the rules file, as it currently has sort of a TODO for adding a -dev package, and include a ref to the debian bug for clarification as to why a -dev is not being used. I think since input properties is a recent addition for wacom we can consider that to be a fix to this, rather than add the headers. (In hindsight, we should have carried Sven's patch at least until the input property stuff was in place for wacom.)

Changed in wacom-tools (Ubuntu):
status: Triaged → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wacom-tools - 1:0.8.4.1-0ubuntu4

---------------
wacom-tools (1:0.8.4.1-0ubuntu4) karmic; urgency=low

  * Add 106_tc1100_stylus_buttons.patch: Support TC1100 stylus buttons.
    Thanks Krzysztof!
    (LP: #377444)
  * Update note that there is not a -dev for this package because apps
    should be using input properties now, instead.
    (LP: #5918)

 -- Bryce Harrington <email address hidden> Wed, 14 Oct 2009 12:46:02 -0700

Changed in wacom-tools (Ubuntu):
status: In Progress → Fix Released
Changed in wacom-tools (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Patches

Remote bug watches

Bug watches keep track of this bug in other bug trackers.