Activity log for bug #42553

Date Who What changed Old value New value Message
2006-05-02 10:58:02 Alex bug added bug
2006-10-31 19:22:35 Manuel López-Ibáñez None: statusexplanation guess package
2006-10-31 19:24:14 Manuel López-Ibáñez title I'm getting the following error message each time I start a KDE program (and some other programs too...) X Error: BadDevice, invalid or uninitialized input device
2006-11-25 05:54:05 towsonu2003 xorg: status Unconfirmed Confirmed
2006-11-25 05:54:05 towsonu2003 xorg: statusexplanation guess package
2006-12-18 11:52:08 Manuel López-Ibáñez description My machine is Dell Inspiron 9400, with Nvidia's binary (OGL accelerated) drivers. $ konsole X Error: BadDevice, invalid or uninitialized input device 169 Major opcode: 147 Minor opcode: 3 Resource id: 0x0 Failed to open device X Error: BadDevice, invalid or uninitialized input device 169 Major opcode: 147 Minor opcode: 3 Resource id: 0x0 Failed to open device My machine is Dell Inspiron 9400, with Nvidia's binary (OGL accelerated) drivers. $ konsole X Error: BadDevice, invalid or uninitialized input device 169 Major opcode: 147 Minor opcode: 3 Resource id: 0x0 Failed to open device X Error: BadDevice, invalid or uninitialized input device 169 Major opcode: 147 Minor opcode: 3 Resource id: 0x0 Failed to open device WORKAROUND: 1) Backup your configuration: open a terminal and write: sudo cp -a /etc/X11/xorg.conf /etc/X11/xorg.conf.backup 2) Edit /etc/X11/xorg.conf : open a terminal and write: kdesu kate /etc/X11/xorg.conf 3) Comment out problematic entries. Replace: InputDevice "stylus" "SendCoreEvents" InputDevice "cursor" "SendCoreEvents" InputDevice "eraser" "SendCoreEvents" with : # InputDevice "stylus" "SendCoreEvents" # InputDevice "cursor" "SendCoreEvents" # InputDevice "eraser" "SendCoreEvents" 4) Save the file and restart the computer. 5) If you encounter any problems (the graphical interface does not load) just restore the backup with: sudo cp -a /etc/X11/xorg.conf.backup /etc/X11/xorg.conf and restart the computer.
2006-12-27 14:15:36 Duncan Lithgow bug added attachment 'xorg.conf' (xorg.conf from HP dv8220ea)
2007-03-20 20:27:26 Timo Aaltonen title X Error: BadDevice, invalid or uninitialized input device wacom input devices enabled by default, why?
2007-06-13 21:42:28 Bryce Harrington bug added attachment 'dexconf_wacom.patch' (patch to disable wacom if no wacom device is present)
2007-06-13 21:46:44 Bryce Harrington xorg: status Confirmed In Progress
2007-06-13 21:46:44 Bryce Harrington xorg: importance Medium Low
2007-06-13 21:46:44 Bryce Harrington xorg: statusexplanation Dropping priority from Med to Low since it seems to merely be cosmetic. The fix for this will depend on xserver 1.4's input hotplugging, plus support added to xorg-server-input-wacom.
2007-09-21 02:04:41 Bryce Harrington wacom-tools: status In Progress Fix Released