TC1100: Stylus-activated buttons don't work

Bug #377444 reported by Krzysztof Kosinski
38
This bug affects 7 people
Affects Status Importance Assigned to Milestone
wacom-tools (Ubuntu)
Undecided
Unassigned

Bug Description

HP Compaq TC1100 tablet PC has three stylus-activated buttons on the side which do not work with stock Wacom tools. I have created a patch that adds support for them, reporting them as mouse buttons 30, 31 and 32 and have been using it for several months along with xbindkeys with good results. I have also sent the patch to the wacom-tools mailing list, but the maintainer said he first has to get a TC1100 to test it... :/

I'm attaching the patch to the bug report. If someone knows how to make the driver report key events (XF86RotationKB? not sure which ones would be appropriate), I could use some advice how to improve it.

Related branches

Revision history for this message
Krzysztof Kosinski (tweenk) wrote :
Revision history for this message
Bryce Harrington (bryce) wrote :

Hi tweenk,

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with the latest development release of Ubuntu? (ISO CD images are available from http://cdimage.ubuntu.com/releases/)

If it remains an issue, could you also attach a new /var/log/Xorg.0.log?
Thanks in advance.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-verification
Changed in wacom-tools (Ubuntu):
status: New → Incomplete
Revision history for this message
Krzysztof Kosinski (tweenk) wrote :

Nothing has changed. The stock wacom-tools / xserver-xorg-input-wacom package still doesn't work, and the patched driver still works.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wacom-tools - 1:0.8.4.1-0ubuntu4

---------------
wacom-tools (1:0.8.4.1-0ubuntu4) karmic; urgency=low

  * Add 106_tc1100_stylus_buttons.patch: Support TC1100 stylus buttons.
    Thanks Krzysztof!
    (LP: #377444)
  * Update note that there is not a -dev for this package because apps
    should be using input properties now, instead.
    (LP: #5918)

 -- Bryce Harrington <email address hidden> Wed, 14 Oct 2009 12:46:02 -0700

Changed in wacom-tools (Ubuntu):
status: Incomplete → Fix Released
MyR (myr-jedi)
tags: removed: needs-verification
Revision history for this message
MyR (myr-jedi) wrote :

The buttons no longer work on ubuntu 10.04

Changed in wacom-tools (Ubuntu):
status: Fix Released → New
Changed in wacom-tools (Ubuntu):
status: New → Confirmed
Revision history for this message
Christian Stöveken (excogitation) wrote :

also affects Lucid (package -> xserver-xorg-input-wacom)

tags: added: lucid tc1100
tags: added: karmic
removed: lucid
Revision history for this message
Bryce Harrington (bryce) wrote :

Please don't reopen bugs without giving some evidence it is indeed regressed.

Changed in wacom-tools (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Barry Callahan (barryc-rjlsystems) wrote :

I can't comment on whether it was fixed or not, but in Precise (xserver-xorg-input-wacom), it doesn't work.

I've tried triggering all three buttons on my tc1100 while cat'ing /dev/input/* and none of 'em so much as twitch.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers