wacom pressure doesn't work in QT applications

Bug #365420 reported by basse on 2009-04-23
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
qt4-x11 (Ubuntu)
Low
Unassigned
wacom-tools (Ubuntu)
Undecided
Unassigned

Bug Description

When wacom tablet is plugged in, HAL recognizes it and gives names to each tools.
Problem is, the naming on these is very different from old style "stylus" "eraser" "pointer" ..

in Gimp/Inkscape it doesn't matter since you can configure the devices in program setup dialogs, but in QT applications, like Krita, there is no configuration available because the names are hardcoded in QT.

So, in otherwords, pressure doesn't work in any QT applications.

more information here (not a lot though)
http://wiki.koffice.org/index.php?title=Krita/Known_problem_with_packages

I'm running Kubuntu Jaunty preview.

.b

lamoda (dennisbrother) wrote :

I meet the same problem. I use Wacom Intuos 2 4x5, and I test my device using the tablet example of Qt. It can not work. Then I modify the /etc/X11/xorg.conf follow the guide on
https://help.ubuntu.com/community/WacomTroubleshooting#In%20Ubuntu%209.04%20beta%20(Jaunty%20Jackalope)
restart X. It work perfectly.

basse (basse) wrote :

well, for now, I use the trick with init.rd script that changes the names of tools before hal gets them..
I thought about going with xorg way but decided to try this one.. more information:
http://ubuntuforums.org/showthread.php?t=1122952&page=3

it's not perfect, but works.. also.

i've learned that problem is also in QT, how it uses the names (not types) of these tools.. so it should be fixed in there .. but that takes time. and i really wish these hal systems would get some sort of configuration tools instead of hacking in with scripts and text files, again.. :( mainly, because before, it just worked, and now, we are back on editing obscure configuration files.

.b

Roberto Maurizzi (r-maurizzi) wrote :

The bug IS in Qt, and it's been fixed:

 http://www.qtsoftware.com/developer/task-tracker/index_html?method=entry&id=210132

It's planned for release in Qt 4.6.0... any chances for a backport? :-)

arky (arky) on 2009-08-27
affects: ubuntu → wacom-tools (Ubuntu)
Bryce Harrington (bryce) wrote :

Hi bastian-salmela-gmail,

Please attach the output of `lspci -vvnn`, and attach your /var/log/Xorg.0.log (and maybe Xorg.0.log.old) file from after reproducing this issue. If you've made any customizations to your /etc/X11/xorg.conf please attach that as well.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-xorglog
tags: added: needs-lspci-vvnn
Changed in wacom-tools (Ubuntu):
status: New → Incomplete
Bryce Harrington (bryce) on 2009-09-02
tags: added: kubuntu
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in wacom-tools (Ubuntu):
status: Incomplete → Invalid
Roberto Maurizzi (r-maurizzi) wrote :

I can't say the situation is very clear: you asked some "bastian-salmela-gmail" -is he basse?- for a lspci for a problem that is:
- related to an USB tablet
- recognized by Trolltech to be caused by a QT bug
- it's already fixed in QT 4.6.0
- the linked ubuntu forum thread has a "hack" to fix it (it works, I've tested it)

So... what do we do?
Do you need some extra info for this? I can try to provide them for a Wacom Cintiq connected to a Dell Mini with Ubuntu 9.04.

hmm, i haven't been looking into this for some time.. is this message
directed to me especially, or is it just automatic forward?

(i am basse)

.b

2009/10/1 Roberto Maurizzi <email address hidden>

> I can't say the situation is very clear: you asked some
> "bastian-salmela-gmail" -is he basse?- for a lspci for a problem that is:
> - related to an USB tablet
> - recognized by Trolltech to be caused by a QT bug
> - it's already fixed in QT 4.6.0
> - the linked ubuntu forum thread has a "hack" to fix it (it works, I've
> tested it)
>
> So... what do we do?
> Do you need some extra info for this? I can try to provide them for a Wacom
> Cintiq connected to a Dell Mini with Ubuntu 9.04.
>
> --
> wacom pressure doesn't work in QT applications
> https://bugs.launchpad.net/bugs/365420
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “wacom-tools” package in Ubuntu: Invalid
>
> Bug description:
> When wacom tablet is plugged in, HAL recognizes it and gives names to each
> tools.
> Problem is, the naming on these is very different from old style "stylus"
> "eraser" "pointer" ..
>
> in Gimp/Inkscape it doesn't matter since you can configure the devices in
> program setup dialogs, but in QT applications, like Krita, there is no
> configuration available because the names are hardcoded in QT.
>
> So, in otherwords, pressure doesn't work in any QT applications.
>
>
> more information here (not a lot though)
> http://wiki.koffice.org/index.php?title=Krita/Known_problem_with_packages
>
> I'm running Kubuntu Jaunty preview.
>
> .b
>

Roberto Maurizzi (r-maurizzi) wrote :

It's a generic note to the bug subscribers and to Bryce Harrington that closed the bug.
IMHO the bug isn't closed, but there are both a fix and a workaround... so I'm wondering what to do now.

Loïc Martin (loic-martin3) wrote :

The bug against wacom-tools was invalid, and should have been reported against qt, not wacom-tools.

Anyway, it's fixed in Karmic, with libqtcore 4.5.2 that's in the repositories (my version is 4.5.2-0ubuntu5), tried with Krita, see attached screenshot. I don't have a clue if it would be possible to get a Stable Release Update for Jaunty or any other release though, but if someone really think there's a possibility to fix it for Jaunty too the bug should be opened against libqtcore4 (or something similar, I'm no Qt expert), not wacom-tools. Then try to find which patch fixed that in Qt, and see if the patch would also work in Jaunty, and do the rest of the SRU process.

Karmic final is only in 28 days though, and has an updated linuxwacom driver (0.8.4.1), so I'm not sure how many Wacom tablet users are going to stick with Jaunty.

m4v (m4v) wrote :

is not fixed in Karmic, the screenshot is from krita 1.6.3, kde3 app

I compiled krita trunk, and tried lastest krita packages as well, presure does not work out of the box as it does with gimp

the bug in qt is fixed in 4.6, there are any chances that I can be backported?

as a workaround, you can create the file /etc/hal/fdi/policy/10-wacom.fdi containing

<match key="input.x11_options.Type" contains="stylus">
  <merge key="info.product" type="string">stylus</merge>
</match>

and pressure will work in krita2

m4v (m4v) wrote :

I added it as affecting qt4-x11, letme know if isn't the right place.

Jonathan Thomas (echidnaman) wrote :

Without knowing which Qt commit fixed this it is unlikely that we'll be able to find the one patch that fixed this in Qt 4.6. Qt 4.6 will be included in Kubuntu 10.04, however and since a fix has been committed upstream I am marking this as fix committed.

Changed in qt4-x11 (Ubuntu):
importance: Undecided → Low
status: New → Fix Committed
Jonathan Thomas (echidnaman) wrote :

Fix released to the development version of Kubuntu 10.04. (Highly un-recommended that any one use 10.04 at this point, though)

Changed in qt4-x11 (Ubuntu):
status: Fix Committed → Fix Released
yasirli (arie-ajha) wrote :

Right i want to try it, thanks for share...

<smal>< href="http://www.anekatips.info" rel="dofollow">Aneka Tips</a></a>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers