Eraser cursor stays on the trash

Bug #356091 reported by Charles Roduit
2
Affects Status Importance Assigned to Milestone
wacom-tools (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: wacom-tools

Problem
=====

The stylus works well after the normal configuration, but the eraser always positions the cursor on the lower right corner, on the trash.

Expected behaviour
============

The cursor follows the eraser.

Work around
========

use the wacomcpl script from wacom-tools to calibrate the stylus.

Copy the values in the files generated by wacomcpl (i.e. .xinitrc) to xorg.conf :

Section "InputDevice"
        Driver "wacom"
        Identifier "eraser"
        Option "Device" "/dev/input/wacom"
        Option "Type" "eraser"
        Option "ForceDevice" "ISDV4" # Tablet PC ONLY
        Option "BottomY" "18499"
        Option "BottomX" "24601"
        Option "TopY" "-23"
        Option "TopX" "-28"
EndSection

for the stylus, eraser, and cursor.

This fixes the problem for all users and permanently.

Thank you.

System information :

Description: Ubuntu jaunty (development branch)
Release: 9.04

wacom-tools:
  Installé : 1:0.8.1.6-1ubuntu8
  Candidat : 1:0.8.1.6-1ubuntu8
 Table de version :
 *** 1:0.8.1.6-1ubuntu8 0
        500 http://ch.archive.ubuntu.com jaunty/main Packages
        100 /var/lib/dpkg/status

Related branches

Revision history for this message
Timo Aaltonen (tjaalton) wrote :

Try the version here:

https://edge.launchpad.net/~tjaalton/+archive/ppa

Calibration might be something everyone needs to do themselves, because one configuration doesn't necessarily apply to others.

Changed in wacom-tools (Ubuntu):
status: New → Incomplete
Revision history for this message
Charles Roduit (charles-roduit) wrote :

Ok, I updated the wacom package from your repositories, and commented out the options I added (BottomY, BottomX, TopY, TopX).

It works like expected.

Will this version be included in the final version of Jaunty ?

I agree that calibration might be something everyone needs to do, but the way it's done and the available documentations makes that it's not obvious.
    * Why did I have to rewrite manually to xorg.conf ?
    * Why the script doesn't told me that something useful was written in the .xinitrc file ??
    * Why did I had to change the name of the options to make it correct (bottomy in the .xinitrc generated --> BottomY in xorg.conf) ?

When performing a calibration it should at least tell me what I have to do to make it work properly... I had to go to the man page of wacom and deduce the options to change. For me it's not a problem, I was used to configure xorg.conf. But for a newby or a "desktop user" it's really not obvious.

Nevertheless, the new version works properly.

Thank you a lot !

Package information :

wacom-tools:
  Installé : 1:0.8.2.2-0ubuntu0.2
  Candidat : 1:0.8.2.2-0ubuntu0.2

Revision history for this message
Timo Aaltonen (tjaalton) wrote :

The new version was acked to be uploaded, so it'll be in jaunty today, thanks for testing!

There will be a gui for the calibration some time, possibly for 9.10. Hopefully the values are runtime configurable by then, so no configfile editing would be necessary.

Changed in wacom-tools (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Triaged
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wacom-tools - 1:0.8.2.2-0ubuntu1

---------------
wacom-tools (1:0.8.2.2-0ubuntu1) jaunty; urgency=low

  * New upstream release. (LP: #355340)
  * Patch 100_allow_eraser.patch dropped, included in this version.
  * 100_fedora-fix-build.diff
    - Make the driver to build against xserver 1.6.
  * 101_fedora-fix-mapping.diff
    - No button 0 in the server, all offsets have to begin at 1.
  * 102_fedora-wcmmaxx.diff
    - Don't assign priv->wcmMaxX/Y back into common->wcmMaxX/Y.
  * 103_fedora-hal-setup.diff
    - Add a hal callout program to set up the device.
    (LP: #215689, #356091)
  * 104_revert-check.diff
    - Don't check the serial number, it breaks some devices.
  * Modify 10-wacom.fdi to include changes from Fedora. Should allow
    hotplugging (built-in) serial tablets. (LP: #337112)
  * rules:
    - Run autoreconf on build
    - xserver-xorg-input-wacom includes /usr/lib/hal/hal-setup-wacom
  * control:
    - autoreconf: add automake, libtool to build-deps.
    - hal-setup-wacom: add libhal-dev to build-deps.

 -- Timo Aaltonen <email address hidden> Tue, 24 Mar 2009 10:06:54 +0200

Changed in wacom-tools (Ubuntu):
status: Triaged → Fix Released
Revision history for this message
Charles Roduit (charles-roduit) wrote : Re: [Bug 356091] Re: Eraser cursor stays on the trash

Thank's a lot for your fast answer and your solution !

2009/4/7 Timo Aaltonen <email address hidden>:
> The new version was acked to be uploaded, so it'll be in jaunty today,
> thanks for testing!
>
> There will be a gui for the calibration some time, possibly for 9.10.
> Hopefully the values are runtime configurable by then, so no configfile
> editing would be necessary.
>
> ** Changed in: wacom-tools (Ubuntu)
>   Importance: Undecided => Medium
>
> ** Changed in: wacom-tools (Ubuntu)
>       Status: Incomplete => Triaged
>
> --
> Eraser cursor stays on the trash
> https://bugs.launchpad.net/bugs/356091
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Revision history for this message
Timo Aaltonen (tjaalton) wrote :

wacom-tools (1:0.8.2.2-0ubuntu1) jaunty; urgency=low

  * New upstream release. (LP: #355340)
  * Patch 100_allow_eraser.patch dropped, included in this version.
  * 100_fedora-fix-build.diff
    - Make the driver to build against xserver 1.6.
  * 101_fedora-fix-mapping.diff
    - No button 0 in the server, all offsets have to begin at 1.
  * 102_fedora-wcmmaxx.diff
    - Don't assign priv->wcmMaxX/Y back into common->wcmMaxX/Y.
  * 103_fedora-hal-setup.diff
    - Add a hal callout program to set up the device.
    (LP: #215689, #356091)
  * 104_revert-check.diff
    - Don't check the serial number, it breaks some devices.
  * Modify 10-wacom.fdi to include changes from Fedora. Should allow
    hotplugging (built-in) serial tablets. (LP: #337112)
  * rules:
    - Run autoreconf on build
    - xserver-xorg-input-wacom includes /usr/lib/hal/hal-setup-wacom
  * control:
    - autoreconf: add automake, libtool to build-deps.
    - hal-setup-wacom: add libhal-dev to build-deps.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers