[FFe] Please allow a new version of wacom-tools

Bug #355340 reported by Timo Aaltonen on 2009-04-04
66
This bug affects 6 people
Affects Status Importance Assigned to Milestone
wacom-tools (Ubuntu)
Wishlist
Unassigned
Jaunty
Wishlist
Unassigned

Bug Description

Binary package hint: wacom-tools

I've prepared an updated version of wacom-tools which, most importantly, offers proper hotplug support for wacom tablets AND builtin serial wacom touchscreens (215689, 337112). There are two success reports so far, which isn't a lot but considering that the patches have been included upstream (0.8.3.2) and Fedora means that they work.

This is what the wacom users have been waiting for since the configuration was dropped from the default xorg.conf (and which wouldn't have worked with input-hotplug anyway).

Related branches

Timo Aaltonen (tjaalton) wrote :

right, the version in my ppa is 0.8.2.2 (stable branch), and the current version is 0.8.1.6 (devel branch):

https://edge.launchpad.net/~tjaalton/+archive/ppa

Changed in wacom-tools (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
Timo Aaltonen (tjaalton) wrote :

current version in jaunty, damnit..

sam tygier (samtygier) wrote :

I have tested the package from the PPA, and it did allow hot plugging, detecting the pen, eraser and scroll wheel on a wacom bamboo fun. i testing in gimp and the pressure sensitivity worked. i did not spot any regressions. (i am probably one of the successful reports that timo mentioned)

m0ntels (lovemyls) wrote :

Just installed the new drivers and now hotplug, pressure, pen and eraser work on my Bamboo. Eraser was the only one of those that hadn't been working in Jaunty. I don't know what tilt is so I can't comment on that, and I can't get any f the buttons on the pad or the scroll wheel to work. The buttons on the pen work like a right or left click. I've never used a tablet before and I haven't ever used it in Windows, so I don't really know what's missing. The girlfriend is the artist...I just fix the computer :)

Bryce Harrington (bryce) wrote :

+1 from me. The hotplug support in Jaunty would be a huge improvement and would eliminate a major regression we've carried since Hardy I think.

Changed in wacom-tools (Ubuntu Jaunty):
status: Confirmed → Triaged
Steve Langasek (vorlon) wrote :

Freeze exception approved.

Please note that freeze exception bugs are procedural bugs; marking them as confirmed or triaged if you are not a member of the release team makes it difficult to see which ones are still in need of approval.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wacom-tools - 1:0.8.2.2-0ubuntu1

---------------
wacom-tools (1:0.8.2.2-0ubuntu1) jaunty; urgency=low

  * New upstream release. (LP: #355340)
  * Patch 100_allow_eraser.patch dropped, included in this version.
  * 100_fedora-fix-build.diff
    - Make the driver to build against xserver 1.6.
  * 101_fedora-fix-mapping.diff
    - No button 0 in the server, all offsets have to begin at 1.
  * 102_fedora-wcmmaxx.diff
    - Don't assign priv->wcmMaxX/Y back into common->wcmMaxX/Y.
  * 103_fedora-hal-setup.diff
    - Add a hal callout program to set up the device.
    (LP: #215689, #356091)
  * 104_revert-check.diff
    - Don't check the serial number, it breaks some devices.
  * Modify 10-wacom.fdi to include changes from Fedora. Should allow
    hotplugging (built-in) serial tablets. (LP: #337112)
  * rules:
    - Run autoreconf on build
    - xserver-xorg-input-wacom includes /usr/lib/hal/hal-setup-wacom
  * control:
    - autoreconf: add automake, libtool to build-deps.
    - hal-setup-wacom: add libhal-dev to build-deps.

 -- Timo Aaltonen <email address hidden> Tue, 24 Mar 2009 10:06:54 +0200

Changed in wacom-tools (Ubuntu Jaunty):
status: Triaged → Fix Released
kaha (kaha) wrote :
Download full text (10.3 KiB)

Hello.

I have two tablet PC.
On the Toshiba M200 with Serial wacom it work well.
But on my HP pavillon tx 2500 it didn't work. It have a usb touch + elecromagnetic wacom device.

With Intrepid, I had to compile the linuxwacom 0.8.1.6. This one give me 2 distinct input (something like ""/dev/input/by-path/pci-0000:00:14.5-usb-0:2:1.0-event-mouse" and "/dev/input/by-path/pci-0000:00:14.5-usb-0:2:1.1-event-"). But now in jaunty there is only one input created ("/dev/input/wacom-touch") ...

kaha@yan-solo:~$ dmesg | grep acom
[ 17.910903] wacom: probe of 7-2:1.0 failed with error -113
[ 17.913328] input: Wacom ISDv4 93 as /devices/pci0000:00/0000:00:14.5/usb7/7-2/7-2:1.1/input/input7
[ 17.948807] usbcore: registered new interface driver wacom
[ 17.948852] wacom: v1.49:USB Wacom Graphire and Wacom Intuos tablet driver

kaha@yan-solo:~$ lsusb -v -d 056a:
Bus 007 Device 003: ID 056a:0093 Wacom Co., Ltd
Device Descriptor:
  bLength 18
  bDescriptorType 1
  bcdUSB 1.10
  bDeviceClass 0 (Defined at Interface level)
  bDeviceSubClass 0
  bDeviceProtocol 0
  bMaxPacketSize0 8
  idVendor 0x056a Wacom Co., Ltd
  idProduct 0x0093
  bcdDevice 3.73
  iManufacturer 1 Tablet
  iProduct 2 ISD-V4
  iSerial 0
  bNumConfigurations 1
  Configuration Descriptor:
    bLength 9
    bDescriptorType 2
    wTotalLength 59
    bNumInterfaces 2
    bConfigurationValue 1
    iConfiguration 0
    bmAttributes 0xe0
      Self Powered
      Remote Wakeup
    MaxPower 0mA
    Interface Descriptor:
      bLength 9
      bDescriptorType 4
      bInterfaceNumber 0
      bAlternateSetting 0
      bNumEndpoints 1
      bInterfaceClass 3 Human Interface Device
      bInterfaceSubClass 1 Boot Interface Subclass
      bInterfaceProtocol 2 Mouse
      iInterface 0
        HID Device Descriptor:
          bLength 9
          bDescriptorType 33
          bcdHID 1.10
          bCountryCode 0 Not supported
          bNumDescriptors 1
          bDescriptorType 34 Report
          wDescriptorLength 143
          Report Descriptor: (length is 143)
            Item(Global): Usage Page, data= [ 0x01 ] 1
                            Generic Desktop Controls
            Item(Local ): Usage, data= [ 0x02 ] 2
                            Mouse
            Item(Main ): Collection, data= [ 0x01 ] 1
                            Application
            Item(Global): Report ID, data= [ 0x01 ] 1
            Item(Local ): Usage, data= [ 0x01 ] 1
                            Pointer
            Item(Main ): Collection, data= [ 0x00 ] 0
                            Physical
            Item(Global): Usage Page, data= [ 0x09 ] 9
                            Buttons
            Item(Local ): Usage Minimum, data= [ 0x01 ] 1
                            Button 1 (Primary)
            Item(Local ): Usage Maximum, data= [ 0x02 ] 2
       ...

I can confirm the correct operation of the ppa version (1:0.8.2.2-0ubuntu0.2) with my elderly USB Wacom Graphire ET-0405-U A6 size tablet, under Jaunty beta updated to 7th April.

Hotplugging is fine, both plug in and unplug, and the eraser and stylus are reported separately and can be configured with appropriate tools in Gimp.

I look forward to this entering the main repository in the next few days. Thanks Timo for bringing it forward for acceptance.

Neil

Golam (golam) wrote :

An upgrade to Jaunty beta (on 5th Apr) led both stylus and eraser of my Thinkpad X61 tablet to stop working. Thanks to Timo's PPA, its now working again without any tweaking! Great job.

Pietro Battiston (toobaz) wrote :

@kaha: notice I opened a new bug to track our issue:
https://bugs.launchpad.net/ubuntu/+source/wacom-tools/+bug/357709

Ola Lindberg (olalindberg) wrote :

Worked fine for me (on a Graphire4) as well!

Not sure for how to remap the keys on the pen yet but I'll give it a go. Thanks for the help.

Golam (golam) wrote :

Here are more details on my test with Timo's package. I am using Xournal to
take notes with stylus (Thinkpad X61 tablet, Kubuntu 9.04 beta),

(1) Click with pen nib --> behaves as Button 1 --> (Left click) [Working]
(2) Click (with middle
          button pressed) --> behaves as Button 2 --> (Middle click) [Working]

(3) Click with eraser tip --> behaves as Button 1 --> (Left click) [NOT WORKING (Button 3 expected)]

So currently, it doesn't emit any signal as Button 3. Consequently, I can't access any
menu that usually requires "right click" (with mouse). IMO, its serious issue as in Tablet
mode there are no other way to generate "right click". I also cheked this behavior with
dolphin and there too I can't do "right click".

The problem can be partly solved if Button 2 is mapped to Button 3. Does anyone
know how to do that?

Thanks!

Loïc Martin (loic-martin3) wrote :

Golam, on Tablet PC the right click button is obtained by pressing the pen nib with the side button pressed, not with the eraser (first because some TabletPC don't have an eraser, but more important because having to return the pen each time you need to open a contextual menu would be completely over the top). So if something has to be corrected, it's (2) in your summary.
(Wacoms tablets only differ in that the right click is by default obtained with just the side button, no need to press the nib at the same time)

Golam (golam) wrote :

Thanks Loïc, I agree that getting right click by pressing pen nib while keeping
side-button pressed is more convenient. In fact, I was using the same earlier
but I had to remap them in xorg.conf. So here is updated wishlish

(2) click (while side button pressed) --> Button 3 (right click)
(3) Click with eraser tip (for those who have it) --> Button 2 (middle click)

Timo: could you please check at least the right click issue? This will make
the package even better. Thanks.

Loïc Martin (loic-martin3) wrote :

Golam, I'm not sure many people would want the eraser to default to a middle button. It's always been a left button, else there's not much use for it in drawing/witting programs.

Golam (golam) wrote :

Hi Loïc, may be I am missing your point. Could you please explain bit more: why should
the eraser tip behave just like another pen nib by default? If so, then what is the point
of having a separate "eraser tip" in the stylus?

Personally, I often use the eraser tip to erase notes in Xournal (exactly the way
one would do on a paper with a pencil by turning its head down).

IMHO, if a stylus can generate 3 different type of clicks then it make sense to map
them to 3 different buttons by default rather than crippling its full functionality.

Loïc Martin (loic-martin3) wrote :

Stylus and eraser are mapped by default to a left "click button" because even then applications can still assign them to two different actions (since they can distinguish between a pressure from the pen tip and one from the eraser, the same way they can distinguish a left click from a mouse and the "left click" from the pen tip - they don't all do that, but then it's a deficiency of the application, which is also there when you would want a mouse and the pen tip to be assigned to two different tools in a program). Assigning one of them to something different might not make sense since you then won't be able to use the eraser to "draw" or erase in some application, where the middle click has a specific action. In drawing programs like Gimp or Inkscape, using the middle mouse button you can't draw anything (for example on Inkscape using the middle mouse button drags the page, hardly what the eraser is made for).

The middle mouse button, like the right click, is better addressed by means that don't require you to flip the pen, since that would break your workflow. And the eraser is, in people's mind, there to erase (that's why it's put there at the opposite of the pen tip, even though it means you need to flip the pen to use it, instead of just addind another side button that modify the pen tip behaviour). Assigning it to the middle mouse button would mean it won't be able to erase (at least in most programs I can think of).

Golam (golam) wrote :

Hi Loïc

> The middle mouse button, like the right click, is better addressed by means that don't require you to flip the
> pen, since that would break your workflow.

OK, how do you propose to do "middle click" when users are in tablet mode?

Do you want users, for every middle click they need, to pull the latch, pull up the screen,
rotate it 180 degree, use regular middle button to do middle click and then repeat the
steps in reverse? Do you even think these steps are faster compared to simply turning the
pen upside down?

BTW, I am happy as long as there are ways to change the button maps easily.

Geir Ove Myhr (gomyhr) wrote :

I'm sorry, but I may have regression on this one. After updating today, X crashes on logout and it seems wacom related. I've put a preliminary bug report at bug 358643 with logs, backtrace and core-dump, but I'll try to look further into it tonight (e.g. try downgrading) and update the report.

I hope it's not for real, because it would be really nice with better tablet support in Jaunty.

Geir Ove Myhr (gomyhr) wrote :

Confirming that bug 358643 was because of the upgrade of wacom-tools. Fortunately, removing my xorg.conf which had the tablet configuration that was needed to make the tablet work with previous versions stopped the crashes and the corrupted VTs.

So the upgraded package works for me now, but this may be a problem for people who are upgrading a working Intrepid tablet to Jaunty (and also anyone running the same configuration as me on Jaunty). My bug report was marked as a duplicate of bug 357331 by the retrace service, but since that bug report is private, I can't check if it has more duplicates. Something for the release notes, or is it possible to make an upgrade go smoothly?

Ola Lindberg (olalindberg) wrote :

I copied the Relative.fdi file from https://help.ubuntu.com/community/Wacom.fdi and when I restarted my computer it froze before I could log in.

Removed the tablet. Rebooted, logged in and deleted Relative.fdi file. Restarted my computer again and it worked. Not sure why or what...

Gregor Burger (burger-gregor) wrote :

I have a x200t Tablet PC. Hotplug worked for the pen (left click) after I installed the xorg wacom driver. But neither the eraser, right click on the side of the stick nor the touch is working. Anything I missed?

On Sat, Apr 11, 2009 at 01:23:11PM -0000, Gregor Burger wrote:
> I have a x200t Tablet PC. Hotplug worked for the pen (left click) after
> I installed the xorg wacom driver. But neither the eraser, right click
> on the side of the stick nor the touch is working. Anything I missed?

Hotplug is supported now, but autoconfiguration is not yet supported.
You'll still need to manually configure to get the advanced features of
your particular hardware.

gali98 (korylp) wrote :

Okay, I have a tx2000z (which is a usb tablet pc) that I finally got working using hal.
However, I had to fix a few things.
This thread outlines a lot of it:
http://ubuntuforums.org/showthread.php?t=1038949
(near the end.)
The kernel module included with the current kernel just doesn't work (it gives error 113 as some people have already posted.) So I compiled the newest version of linux-wacom (8.3-2) and replaced JUST the module. I then had to edit the fdi file and replace it with my custom one (I attached it below: working.fdi)
That got everything working: Calibrated touch and stylus and eraser with pressure.
But I think I hit the brick wall. Now correct me if I'm wrong, but using this method, you can only pass options for one device (i.e. the first device you specify.) The others can only be added as devices - they can't be configured.
I would love to be wrong, but that's how it looks to me.
Anywho, any comments, questions, advice ask/tell away. Thanks
Kory

gali98 (korylp) wrote :

As another note I forgot to mention, my Graphire4 worked perfect with the intial setup, and it still works with my setup now (the pad and cursor do not work, but I am sure that it I add those entries to the fdi file they will work.)
Kory

Roger E Critchlow Jr (rec) wrote :

My problem with the wacom-tools-0.8.2.2 package with my x200 tablet has been that it doesn't use the same names for stylus, eraser, and touch devices so neither xsetwacom nor wacomcpl work at all. As a consequence, none of the screen rotation scripts work, and I cannot interactively recalibrate my tablet when it drifts.

The problem is that the hotplug named my tablet inputs as: 'PnP Device (WACf008)', 'PnP Device (WACf008) touch', and 'PnP Device (WACf008) eraser'. I found that out by running xinput, because 'xsetwacom list dev' and wacomcpl both returned empty lists.

It turns out that I can fix those problems with a script that edits the hal configuration before the xserver starts. (If you run the script after the xserver starts, then the settings won't take effect until you logout and allow the xserver to restart.)

I write /etc/init.d/wacom and link it as /etc/rc{2,3,4,5}.d/S27wacom, so it runs after hal and before gdm:

    # find any wacom devices
    for udi in `hal-find-by-property --key input.x11_driver --string wacom`
    do
    type=`hal-get-property --udi $udi --key input.x11_options.Type`
    # rewrite the names that the Xserver will use
    hal-set-property --udi $udi --key info.product --string $type
    case $type in
    stylus|eraser)
    # map stylus button 2 to mouse button 3
    hal-set-property --udi $udi --key input.x11_options.Button2 --string 3
    ;;
    esac
    done

So that works for renaming the input devices back to what wacomcpl and xsetwacom expect them to be, so rotation and interactive calibration work, and it also enables context menus off the stylus button.

Now, some of those things can be fixed by changing the fdi file or changing the way that the Xserver interprets the information it gets from hal.

But, as gali98 points out, there are some configurations that can't be easily specified in the fdi file. If I understand him correctly, I could modify the fdi file to map the stylus button2 to button 3, but I couldn't remap the eraser button in the fdi file because the eraser is a sub-device.

So this gives us a place to put that sort of stuff until hal is taught how to deal with these problems.

-- rec --

gali98 (korylp) wrote :

Just some food for thought:
If xsetwacom can get to the devices (and therefore wacomcpl) I don't think it would matter if the device is a hal sub-device or not. As long as you run the file wacomcpl creates (~/.xinitrc) as a session (or as jaunty calls them "startup applications") it should keep calibration and options on reboot. I will report back as soon as I get home to test this out. This looks like a wonderful idea!
Kory

gali98 (korylp) wrote :

Okay it works pretty well... Please see this forum (at the end) for detailed progress and what not.
Kory

gali98 (korylp) wrote :

Sorry! I forgot the link... (Thanks Favux!) We really need an edit :\
Anyways here it is:
http://ubuntuforums.org/showthread.php?t=1122952
Kory

Golam (golam) wrote :

Thanks Roger! your script works like a charm in my X61 tablet. Finally, I am able to do right click with my pen. IMHO, it will be great to update the current fdi file so that at least the right click works out of the box!

Psy[H[] (vovik-wfa) wrote :

With current latest wacom-tools only one end of stylus and buttons on it work on Grafire4
Eraser, pad buttons and wheel do not.

Psy[H[] (vovik-wfa) wrote :

Correction: with wacom-tools 1:0.8.2.2-0ubuntu2 everything worked after second try on live-flash, on another machine.
I'll try investigating...

gali98 (korylp) wrote :

I got everything working on My USB Tablet PC!
What's more, with the way I found, it gets rid of all the extraneous devices. Calibration, Rotation, and wacomcpl work great!
Thanks so much to Rec and Favux! (And Timo for all his hard work!)
See Posts 102 and 104 for all the info, and a small (well not so small) how-to on this page:
http://ubuntuforums.org/showthread.php?t=1038949&page=11
Thanks!
Kory

Don't know if this helps but just installed 9.04 on my Lenovo X61 tablet and the tablet worked without any config. This is very nice only thing is the right click button seems to work as the eraser in xournal. Hope this helps

Dread Knight (dread.knight) wrote :

I have Toshiba Portege m400.

Everything works out of the box, except right click using the stylus button.... so not cool... and i can't even manage to configure it with wacom-tools.

Psy[H[] (vovik-wfa) wrote :

ok, now tested my Grafire 4 on all my machines...
stylus is fully functional on both ends and with buttons.
but buttons and wheel on the pad aren't working.

Jesse B. Hannah (jbhannah) wrote :

Roger—your script worked perfectly on my Thinkpad X60 Tablet. One hint to simplify setting it to run between HAL and gdm, from gali98's tutorial:

sudo update-rc.d wacom defaults 27

Reboot, or run the script and log out and back in, and it works fine; devices show up in wacomcpl, and eraser works in Xournal. For pressure sensitivity in GIMP remember to check the extended input device preferences and set your tablet device from "disabled" to "screen"…took me forever to realize that was why pressure sensitivity didn't seem to be working when I would test it in GIMP. >_< Works fine in Xournal without extra configuration though.

coppertop (peter-podgorski) wrote :

I've tested wacom-tools version 1:0.8.2.2-0ubuntu2 from Jaunty repos. I'm on 32 bits and I have a Wacom Bamboo One. There's only stylus in that tablet, and it works well - pressure and buttons alike ootb. Thanx very much :D.

Wacom Graphire 4 here - Pad scroll and buttons DO NOT work!

How do i fix this?

Not sure whether here is the right place to post this but, It doesn't work completely for me.
I'm using a Graphire 4 A6 the wacom-tools and xserver-xorg-input-wacom packages from jaunty's repos ver. 1:0.8.2.2-0ubuntu2 plus a selfcompiled driver from linuxwacom-0.8.3-2 (configured with --enable-quirk-tablet-rescale) as previous versions didn't support my kernel version of 2.6.28-11. xorg-server 2:1.6.0-0ubuntu14

The problem: the tablet is stretched across both monitors and I can't configure it for my twinview since wacomcpl doesn't list any of my wacom devices. wacdump /dev/input/wacom only confirms
MODEL=Wacom Graphire4 4x5 ROM=4.0-3
CLS=USB VNDR=Wacom DEV=Graphire4 SUB=CTE_440
but registers no pen movments or button events. Similary sudo xxd /dev/input/wacom produces no output.
Pressuresensivity + scrollwheel work fine.

since this was, as I understood, aiming to enable tablets without specifying anything in xorg.conf, for above I commented out everything wacom related in xorg.conf.
With the appropriated lines in xorg.conf I DO get the devices listed by wacomcpl and can configure them for twinview. However, they only ever get restricted to my first monitor and won't ever switch to the second as they did in intrepid. With one of the pad-keys set to Display Toogle the only difference I could spot was getting a few pixles further onto the second one with desktop, while screen1 and screen0 restricted me to screen0 only.

Without both packages and with linuxwacom-0.8.3-2 (configured with --enable-quirk-tablet-rescale(!)) compiled and installed from source + xorg.conf with wacom devices listed works like a charm though.
(I was going through all possibilities while writing this. this was my last hope and even though it works now for me, it still seems to confirm that this package might need some further tweaking.)

Regarding Todor's and some other peeps problems with pad buttons and scrollwheel. Try configuring them through wacomcpl. If it doesn't list your devices, add them to xorg.conf as described here: http://linuxwacom.sourceforge.net/index.php/howto/inputdev
In wacomcpl, choose pad->Tablet Controls and configure the keys as needed
Tips: set Wheel Up to fifth and Wheel Down to Fourth and test them in other applications than gimp, such as firefox, as gimp tends to ignore the wheel.
If wacomcpl gives an error on accessing .xinitrc you might have to chmod ~/.xinitrc for it to have permission to write.

wacomcpl DOES NOT work under jaunty- it doesnt pick tablet device at all.

I tried editing xinitrc file by hand,that got me the pad buttons to work, but the pad scroll wheel does not want to act as a mouse scroller- even if i set it to "4" and "5"

sam tygier (samtygier) wrote :

this is not a good place to be posting these issues. please file new bugs.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers