wacom stylus on TC1100 tablet does not work out of the box

Bug #337112 reported by MyR
4
Affects Status Importance Assigned to Milestone
hal (Ubuntu)
Invalid
Undecided
Unassigned
wacom-tools (Ubuntu)
Fix Released
Medium
Timo Aaltonen

Bug Description

Binary package hint: xorg

Using the stylus on the screen does nothing.

running the latest Jaunty
Linux ubuntu 2.6.28-8-generic #26-Ubuntu SMP Wed Feb 25 04:28:54 UTC 2009 i686 GNU/Linux
$ ubuntu-bug -p xorg
Warning: Could not load keyboard geometry for :0
                  BadAlloc (insufficient resources for operation)
                  Resulting keymap file will not describe geometry

I will be happy to provide further information.
Thank you

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
Package: xorg 1:7.4~5ubuntu12
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersion: Linux version 2.6.28-8-generic (buildd@rothera) (gcc version 4.3.3 (Ubuntu 4.3.3-3hostname5) ) #26-Ubuntu SMP Wed Feb 25 04:28:54 UTC 2009
SourcePackage: xorg
Uname: Linux 2.6.28-8-generic i686

Related branches

Revision history for this message
MyR (myr-jedi) wrote :
Bryce Harrington (bryce)
Changed in xorg:
status: New → Confirmed
Revision history for this message
Timo Aaltonen (tjaalton) wrote :

Please try the package from my PPA:

https://launchpad.net/~tjaalton/+archive/ppa

Changed in wacom-tools (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Revision history for this message
MyR (myr-jedi) wrote :

I installed the package wacom-tools (1:0.8.2.2-0ubuntu0.2) from your ppa on a Jaunty Alpha 5 live CD and the stylus still doesn't work.

Revision history for this message
Timo Aaltonen (tjaalton) wrote :

ok, attach the Xorg.0.log you get from it, and the output of "lshal > lshal.txt". It might need some changes to the hal fdi file.

Revision history for this message
MyR (myr-jedi) wrote :

How do I get the Xorg.0.log ?

Revision history for this message
Loïc Martin (loic-martin3) wrote :

The Xorg.0.log should be in your /var/log/ folder.

Revision history for this message
MyR (myr-jedi) wrote :
Revision history for this message
MyR (myr-jedi) wrote :

before restarting x

Revision history for this message
MyR (myr-jedi) wrote :

after restarting x (via logout & login)

Revision history for this message
MyR (myr-jedi) wrote :

I also have the earlier logs attached above from the original report if those are helpful.

Revision history for this message
Timo Aaltonen (tjaalton) wrote :

This is enough, thanks. The logfile has

(WW) config/hal: no driver or path specified for /org/freedesktop/Hal/devices/pnp_WACf005

and lshal:

udi = '/org/freedesktop/Hal/devices/pnp_WACf005'
  info.capabilities = {'input', 'input.tablet', 'input.tablet.tabletPC'} (string list)
  info.linux.driver = 'serial' (string)
  info.parent = '/org/freedesktop/Hal/devices/computer' (string)
  info.product = 'Wacom Serial Tablet PC Pen Tablet/Digitizer' (string)
  info.subsystem = 'pnp' (string)
  info.udi = '/org/freedesktop/Hal/devices/pnp_WACf005' (string)
  input.x11_driver = 'wacom' (string)
  input.x11_options.Type = 'stylus' (string)
  linux.hotplug_type = 2 (0x2) (int)
  linux.subsystem = 'pnp' (string)
  linux.sysfs_path = '/sys/devices/pnp0/00:06' (string)
  pnp.description = 'Wacom Serial Tablet PC Pen Tablet/Digitizer' (string)
  pnp.id = 'WACf005' (string)
  pnp.serial.irq = 4 (0x4) (int)
  pnp.serial.port = '0x300' (string)

udi = '/org/freedesktop/Hal/devices/pnp_WACf005_serial_platform_0'
  access_control.file = '/dev/ttyS0' (string)
  access_control.type = 'modem' (string)
  info.callouts.add = {'hal-acl-tool --add-device'} (string list)
  info.callouts.remove = {'hal-acl-tool --remove-device'} (string list)
  info.capabilities = {'serial', 'access_control'} (string list)
  info.category = 'serial' (string)
  info.parent = '/org/freedesktop/Hal/devices/pnp_WACf005' (string)
  info.product = 'Wacom Serial Tablet PC Pen Tablet/Digitizer' (string)
  info.subsystem = 'tty' (string)
  info.udi = '/org/freedesktop/Hal/devices/pnp_WACf005_serial_platform_0' (string)
  linux.device_file = '/dev/ttyS0' (string)
  linux.hotplug_type = 2 (0x2) (int)
  linux.subsystem = 'tty' (string)
  linux.sysfs_path = '/sys/devices/pnp0/00:06/tty/ttyS0' (string)
  serial.device = '/dev/ttyS0' (string)
  serial.originating_device = '/org/freedesktop/Hal/devices/pnp_WACf005' (string)
  serial.port = 0 (0x0) (int)
  serial.type = 'platform' (string)

it should use the latter device, but the x11_driver key was appended to the wrong hal device. I'll try to come up with something.

Changed in wacom-tools (Ubuntu):
status: Incomplete → Triaged
assignee: nobody → tjaalton
Revision history for this message
Timo Aaltonen (tjaalton) wrote :

I actually think this is a bug in our version of HAL. The same rule works on Fedora, where the rule was copied from. The versions are not too different though, so it should be possible to identify a fix. Here is the rule that's not honored:

    <match key="info.capabilities" contains="serial">
      <match <email address hidden>:pnp.id" contains_outof="WACf001;WACf002;WACf003;WACf004;WACf005;WACf006;WACf007;WACf008;WACf009;WACf00a;WACf00b;WACf00c;FUJ02e5">
        <append key="info.capabilities" type="strlist">input</append>
        <merge key="input.x11_driver" type="string">wacom</merge>
        <merge key="input.x11_options.Type" type="string">stylus</merge>
        <merge key="input.x11_options.ForceDevice" type="string">ISDV4</merge>
        <merge key="input.device" type="copy_property">serial.device</merge>
        <append key="info.callouts.add" type="strlist">hal-setup-wacom</append>
        <append key="wacom.types" type="strlist">eraser</append>
        <match <email address hidden>:pnp.id" contains_outof="WACf008;WACf009">
          <!-- Serial tablets with touch capabilities -->
          <append key="wacom.types" type="strlist">touch</append>
        </match>
      </match>
    </match>

why did it stop at x11_options.Type and didn't merge the rest?

Revision history for this message
Timo Aaltonen (tjaalton) wrote :

I'll check the fdi file first, it could be broken.

Changed in hal (Ubuntu):
status: New → Invalid
Revision history for this message
Timo Aaltonen (tjaalton) wrote :

ok, the fdi file is flawed. Could you try changing the first matching rule like this:

- <match key="info.capabilities" contains="input">
+ <match key="info.category" contains="input">

and try again. It should work then.

Revision history for this message
Timo Aaltonen (tjaalton) wrote :

Could you attach your /usr/share/hal/fdi/policy/20thirdparty/10-wacom.fdi ? The version from my package should already be fixed..

Revision history for this message
MyR (myr-jedi) wrote :

here it is before installing your package

Revision history for this message
MyR (myr-jedi) wrote :

here it is after installing your wacom-tools

Revision history for this message
MyR (myr-jedi) wrote :

I installed your xserver-xorg-input-wacom_0.8.2.2-0ubuntu0.2_i386.deb (in addition to your wacom-tools), restarted x, and now the stylus works. However it does not have right click functionality with the stylus button. The button is recognized because it does something. For example, using the button and clicking a title bar causes the window to lose focus. Pressure sensitivity works fine.

Revision history for this message
MyR (myr-jedi) wrote :

Attached my xorg log.
On ubuntu 8.10 the button2 option needed to be added to the xorg.conf like this in order for the button to work.
Section "InputDevice"
   Identifier "stylus"
   Driver "wacom"
   Option "Type" "stylus"
   Option "Device" "/dev/input/wacom"
   Option "ForceDevice" "ISDV4"
   Option "Button2" "3"
EndSection

hope this helps. thank you very much for working on this!

Revision history for this message
Timo Aaltonen (tjaalton) wrote :

Thanks for confirming that it works! I became worried that the package was faulty somehow, since I knew it _should_ work.

The button mapping can be set in an fdi file in /etc/hal/fdi/policy, you can copy 10-wacom.fdi there and edit it so that it has only the bits you need. The driver doesn't support input properties yet, so you can't change the settings on the fly (by using xinput or the API).

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wacom-tools - 1:0.8.2.2-0ubuntu1

---------------
wacom-tools (1:0.8.2.2-0ubuntu1) jaunty; urgency=low

  * New upstream release. (LP: #355340)
  * Patch 100_allow_eraser.patch dropped, included in this version.
  * 100_fedora-fix-build.diff
    - Make the driver to build against xserver 1.6.
  * 101_fedora-fix-mapping.diff
    - No button 0 in the server, all offsets have to begin at 1.
  * 102_fedora-wcmmaxx.diff
    - Don't assign priv->wcmMaxX/Y back into common->wcmMaxX/Y.
  * 103_fedora-hal-setup.diff
    - Add a hal callout program to set up the device.
    (LP: #215689, #356091)
  * 104_revert-check.diff
    - Don't check the serial number, it breaks some devices.
  * Modify 10-wacom.fdi to include changes from Fedora. Should allow
    hotplugging (built-in) serial tablets. (LP: #337112)
  * rules:
    - Run autoreconf on build
    - xserver-xorg-input-wacom includes /usr/lib/hal/hal-setup-wacom
  * control:
    - autoreconf: add automake, libtool to build-deps.
    - hal-setup-wacom: add libhal-dev to build-deps.

 -- Timo Aaltonen <email address hidden> Tue, 24 Mar 2009 10:06:54 +0200

Changed in wacom-tools (Ubuntu):
status: Triaged → Fix Released
Revision history for this message
MyR (myr-jedi) wrote :

How do I add the right click button in hal then?

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers