Wacom tablet hotplug is no longer enabled by default

Bug #282203 reported by Alexia Death on 2008-10-12
72
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Oliver Grawert
wacom-tools (Ubuntu)
Medium
Timo Aaltonen

Bug Description

Binary package hint: xserver-xorg-input-wacom

The topic was raised at another bugs discussion but it merits its own bug.
The previous discussion can be found at at the end of
https://bugs.launchpad.net/ubuntu/+source/wacom-tools/+bug/260675

The issue is that fdi file that makes hot-plug work for stylus on all wacom tablets is no longer installed by default making the devices completely nonfunctional without complicated X setup or doing a cryptic file copy like this:

sudo cp /usr/share/doc/xserver-xorg-input-wacom/10-wacom.fdi
/etc/hal/fdi/policy/10-wacom.fdi

Surely, it is sensible to allow for new users to have hotplug and partial functionality over a totally nonfunctional device.

The only negative side-effect I see is that it interferes with the set-up of any people who have their devices already configured in X conf file. And those people are more than capable of removing the fdi file. Or they may, as I have, actually opt to using the device as hot-plug and with partial capabilities rather than permanently configured and requiring X restart when you did not have it plugged in at X start.

Related branches

Charlie Jolly (charlie-jolly) wrote :

>>Surely, it is sensible to allow for new users to have hotplug and partial functionality over a totally nonfunctional device.<<

I agree with this but can someone explain why the advanced settings for tablets can't be used with the hotplug. Restarting X to change settings seems like the stone age!!!

Alexia Death (alexiade) wrote :

Right now, its stuck at hal capabilities and the tablets special 1:n mapping between the kernel device and X device. One device from kernel end needs to be presented to X as at least styus and eraser + some more devices depending on what model you have. Hal cant do that. there might be a way to do this through DBUS, but looking at X in ubuntu packages the X dbus config interface is not enabled at build time, so I could not test this method.

Otherwise, it might be possible to use the HAL device add signal to configure the remaining devices through DBUS, but as is, that cant be done.

+1 for enabling the device out-of-the-box. I'll probably reconfigure my setup for full functionality later on, but I'd rather have partial functionality directly after installation than none at all.

I have the same problem.

My wacom sapphire tablet is not working on intrepid, it doesn't work as a mouse even right now. It made very strange things one week ago with previous intrepid releases, and it worked very well before with proper xorg configuration on Hardy.

 A lot of people uses tablets these days and for me is a huge problem. When intrepid goes out I will solve it using whatever esoteric means as necessary , but people is not going to go by it.

Trond Thorbjørnsen (tthorb) wrote :

I agree with Alexia - the hotplug out of the box should be prioritized.

Actually - my Wacom doesn't work at all with my old Hardy setup (where it works fine):

Oct 19 11:03:26 fanon kernel: [ 2540.344690] usbcore: registered new interface d
river wacom
Oct 19 11:03:26 fanon kernel: [ 2540.348374] wacom: v1.49:USB Wacom Graphire and Wacom Intuos tablet driver

Trond Thorbjørnsen (tthorb) wrote :

Actually, it works as in Hardy, I just forgot to comment out some lines in xorg.conf.

Alexia Death (alexiade) wrote :

@Trond Thorbjørnsen - I was just about to recommend checking your X conf, because now, that kernel packages are patched, theres no reason for the static conf to not work.

@Jose Hevia - the odd behaviour was caused by a missmatch between kernel and X driver versions. It is now corrected. All you need to do to get your stylus working is to copy that fdi file as listed in my first post or to get full function but no hotplug set up your X conf as it was in hardy.

filsd (filsdd) wrote :

I agree with Alexia on this to. I prefer only the stylus working out of the box instead of nothing. Hopefully this will be the last time we have this issues... I hope that the Ubuntu 9.04 is much better in this respect. ;)

Timo Aaltonen (tjaalton) wrote :

just copy the file to /etc/hal/fdi/policy (not in /usr/share/hal, that's reserved for packages) and be happy. There simply isn't a way to satisfy all users with the current wacom driver. It cannot be fully configured with the fdi file, and the interweb is full of examples of how to copypaste the correct information to xorg.conf. We won't be changing the default anymore for intrepid, so hopefully for Jaunty the driver supports proper configuring with HAL.

Changed in wacom-tools:
importance: Undecided → Wishlist
status: New → Triaged
Loïc Martin (loic-martin3) wrote :

The interweb is full of examples for previous Xorg releases - simply copy/pasting the correct information will hose X, since the InputDevice has to be added to Section "ServerLayout". However, that section isn't present in Ubuntu's xorg.conf anymore, and when the users will add this section with only InputDevice parts, X will fail to load.

It took me a few days to get this working, and only half-working - the keyboard reverted to an American keyboard in X (that would prevent login in, for example).

OTOH, thanks for pointing the proper location for the fdi file.

On Mon, Oct 20, 2008 at 12:43 PM, Timo Aaltonen <email address hidden>wrote:

> just copy the file to /etc/hal/fdi/policy (not in /usr/share/hal, that's
> reserved for packages) and be happy.

Ok, place amended, but issue remains. Its a cryptic file copy for no good
reason.

There simply isn't a way to satisfy
> all users with the current wacom driver. It cannot be fully configured
> with the fdi file, and the interweb is full of examples of how to
> copypaste the correct information to xorg.conf.

A) Its simple to hose your X with that,
B) it is NOT a hotplug conf.

> We won't be changing the
> default anymore for intrepid, so hopefully for Jaunty the driver
> supports proper configuring with HAL.

I would really like to hear the justification for this decision...

--Alexia

description: updated

@Alexia: I guess the justification for this decision is, that, according to the release schedule (https://wiki.ubuntu.com/IntrepidReleaseSchedule), Intrepid is past final freeze now. Since this is neither a security problem nor a release critical bug it's sadly not going to be in 8.10.

While I agree that the workaround as such (copy file from a to b) is simple, the required knowledge (that the workaround is, in fact, a simple file copy) is not easy to come by. When I first went looking for information on how to enable my table in Hardy I found a lot of outdated (mis-)information. I'm quite convinced that a lot of people will use said information for Intrepid unless they happen across this bug report.

Alexia Death (alexiade) wrote :

It was enabled for previous betas and it was DISABLED after the freeze. I am interested in the why behind the decision. I see no downsides to enabling it by default now that the driver incompatibility issue has been solved. the decision could have made some sense, if there were still issues on the driver front but as it is... It is beyond my comprehension why disable a feature like that... Hotplug for only stylus is better than no functionality at all... and for some, like me, its even better than a static X conf without hotplug.

Matteo Settenvini (tchernobog) wrote :

Probably the best thing up this point, is setting up a nice page on wiki.ubuntu.com, so that people can at least find the workaround easily.

Note that I did not say "the solution", but "the workaround", because I think that the approach used to close the issue in the first place was flawed. That means, for Ubuntu 9.04 there'd better be a proper fix.

Alexia Death (alexiade) wrote :

Also, if it is enabled by default, the wacom tablets stylus would simply, out of the box, work with live CD-s allowing anybody simply to use their tablet as opposed to not getting any reaction from it in current state for no good reason at all, since it is actually supported...

Loïc Martin (loic-martin3) wrote :

@Matteo Settenvini : wouldn't that be https://help.ubuntu.com/community/Wacom ;) ?

AaronPeterson (alpeterson) wrote :

I have a serial wacom device on my tablet pc...
I was mislead by all this fdi stuff and thought that mine might be a USB one and all I needed to do was copy that fdi file...
I ended up copying an xorg.conf from gentoo wiki and had to delete a whole lot of font configuration and stuff like that to get it to work.

So, What we can do is provide a program in a package that that lists known hardware issues / configurations, lets us click the hardware, opens a text X session

and does the file copy for us / tweaks the xorg.conf, / does the riskier hardware probes for that specific hardware that we selected from the list.

I believe something like this already exists...

Timo Aaltonen (tjaalton) wrote :

Aaron: Jaunty will likely have a full-fledged configurator for X.

I'm reverting the change since it appears that stylus is what most are using. The release team will decide if and when it'll go in the archive.

Changed in wacom-tools:
assignee: nobody → tjaalton
importance: Wishlist → Medium
milestone: none → ubuntu-8.10
milestone: ubuntu-8.10 → none
Julius Bloch (jbloch) wrote :

Hi I tried to copy the .fdi file. For me it is no solution.
I still need an extra xorg.conf file. See attached file.

My notebook is a x41 tablet.

Julius Bloch (jbloch) wrote :

I also want to add that this xorg.conf is not my working xorg.conf from Hardy. The xorg.conf from Hardy was not working with wacom support.
I have attached the old xorg.conf which was working well on Hardy.

Steve Langasek (vorlon) wrote :

these two attachments make it clear to me that getting full tablet support will require manual futzing in intrepid for /all/ users, whether upgrading or new installs, and therefore enabling the fdi by default doesn't hurt us. accepting, and adding a task to document this in the release notes.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wacom-tools - 1:0.8.1.4-0ubuntu3

---------------
wacom-tools (1:0.8.1.4-0ubuntu3) intrepid; urgency=low

  * debian/rules: Enable the fdi file again. (LP: #282203)

 -- Timo Aaltonen <email address hidden> Tue, 21 Oct 2008 18:11:01 +0300

Changed in wacom-tools:
status: Triaged → Fix Released
Alexia Death (alexiade) wrote :

I can see the one weakness of hal based hotplug why it does not work for tabletPC-s. There is no hotplug event. If I have my tablet connected at X start I need to replug it and that is not possible for tabletPC-s.

IMHO the only sane solution to allow for full functionality in the future is to make full use of the X dbus config interface and run a helper script to load user setup for the wacom both at log-in, checking for the presence of the device, and when HAL does a device add for the stylus, that then this helper will remove, and add devices as user wants them. The HAL setup alone ensures sufficient functionality for GDM and unconfigured user cases and everybody is happy.

Steve Langasek (vorlon) on 2008-10-22
Changed in ubuntu-release-notes:
assignee: nobody → ogra
Steve Langasek (vorlon) wrote :

Preliminary release notes entry at <https://wiki.ubuntu.com/IntrepidReleaseNotes#Limited%20support%20for%20Wacom%20tablet%20hotplugging>. This could use some improvement, though.

Changed in ubuntu-release-notes:
status: New → In Progress
Dave M G (martin-autotelic) wrote :

As a graphics developer and not a technical person, I'm struggling with the new settings for my Wacom.

It does, as described here, automatically detect the tablet and allow use of the stylus only, with no options for configuration.

However, this limited functionality is not sufficient for the graphics that I do with Ubuntu, so I wanted to get my xorg.conf settings back in action.

I was led to believe that this was possible by the notes on this web page:
https://help.ubuntu.com/community/Wacom

"Option B" states that "you can configure the tablet using the old method". But at the same time, it says "you risk hosing X", without any tangible advice on what the causes and possible workarounds for why X gets hosed and how that might be avoided.

I have discovered that, so far as I can tell, any attempt to modify xorg.conf, makes X unbootable. I get an error which gives me three options of reconfigure X, proceed with current settings, or one other that I can't recall. In any case, no matter what I choose, the screen flickers and it ends up back at the same choices. The only way I can regain control of my system is to book into a text mode and restore my backup of xorg.conf.

This whole situation is very frustrating, given that Wacom tablets have long been difficult to set up and configure. Now, after years of finally getting to a point of usability, the situation seems to have been pushed back to square one.

The note at the top of this page says "The only negative side-effect I see is that it interferes with the set-up of any people who have their devices already configured in X conf file. And those people are more than capable of removing the fdi file". Unfortunately, I think that's over estimating those of us who struggled to configure xorg.conf in the first place.

I have no idea what an fdi file is, or half of the comments and instructions on this page mean. I am wary of experimenting because I've already crashed X by following instructions.

Can someone perhaps break it down into everyday speech as to what, exactly, a non-expert user does to regain the Wacom use they had in Hardy?

Thank you for your help.

Alexia Death (alexiade) wrote :

fdi file is a hal policy file that tells hal to tell Xorg about your tablet you just plugged in. its located at /usr/share/hal/fdi/policy/20thirdparty/10-wacom.fdi

You had the X configured in Hardy and you did a dist-upgrade? That means you have done this before and you had a working X configuration from there. It should be usable with minimal change. Without knowing what went wrong its hard to help you. You said you can restore your backup X conf from command line. From command line you can also see the X log to know what is wrong. to see run:

tail -f /var/log/Xorg.0.log

And see the lines at the end of the output marked (EE). They should point you in the right direction.

Its easy to hose your X with changing a conf file simply because it is a conf file and because of that, a single tiny mistake can make X unable to function with it. It has always been the same, hotplug or no hotplug.

To make it clear, the hotplug capacity ONLY kicks in if you plug in your tablet AFTER you have started X. It does nothing for tabletPC-s and you wont be bothered by it if your tablet is connected at all times. So you can have the fdi file that the this bug is about without any inconvenience.

Theres only one place where having both X conf and the hotplug fdi file is troublesome, and thats the wacom drivers workaround for hotplug. I you had the tablet at startup, unpluged and repluged it then now changing virtual terminals wont restore the full functionality for you because hotplug grabs the device, you need to restart x with your tablet already connected to avoid that.

Dave M G (martin-autotelic) wrote :

Alexia,

Thank you for taking the time to explain the situation clearly.

I'm relieved to know that the new HAL settings apply to devices that are added and removed after booting the computer. My Wacom is permanently attached, so I guess I can safely side step the HAL issues.

Whoever is making documentation might do well to make this clear so that newbies like myself don't panic. I thought a new, less functional, regime that I could not avoid was being imposed on me.

As far as fixing it goes...

To make a long story short, instead of editing my xorg.conf to try and figure out what settings should be commented out and which ones included, I simply restored a backed up version from about three months ago.

It seems to work fine. I am currently enjoyed a working Wacom tablet again.

With much relief, thank you.

Dave M G

I had the same problem as Dave MG. I know about computers, I program them, but I the fdi files are not my area of interest, I didn't know what they meant either. So Alexia, you had been very helpful with me too(and the people that will read this in the future).

I had an xorg file that worked fine in feisty, but it made my 800x1200(portrait or rotated mode) to display an 800x600 one(error recovery mode) because X had errors understanding wacom options. I created a new slim xorg file with dexconf and it worked, but if I try to include the wacom configuration it makes x to load ErrorRM again.

It seems like if I only include sections "Inputdevice" it needs a ServerLayout, an if I include the {Section "ServerLayout"}of feisty, X crashes. The serverlayout was also the problem in the initial xconf file.

Well, I don't like changing "general configuration" files on ubuntu. Every time I update the automatic configuration doesn't work(Your XXX file has changed.Do you want to replace it...).

Now, my tablet hotplugging works, but I simply want to rotate the tablet, so the aspect ratio of the screen is the same as the tablet, as I did in feisty. How can I do that without playing xorg files.

With feisty I had the device "stylus" that I could rotate with xsetwacom.

Today, with xsetwacom I see:
$$xsetwacom list
SynPS/2 Synaptics TouchPad touch

I can't see stylus, or eraser, so I can't rotate it.

Alexia Death (alexiade) wrote :

Jose: You can do the copy outlined in the first post

sudo cp /usr/share/doc/xserver-xorg-input-wacom/10-wacom.fdi
/etc/hal/fdi/policy/10-wacom.fdi

And edit /etc/hal/fdi/policy/10-wacom.fdi to include your options that you would usually put in your device section. I used this option once to force the hotplugged tablet to log verbose error messages.

Basically you need to add as merge statements for options you would usually put in X like this:

        <merge key="input.x11_options.Debug" type="string">11</merge>

and thats that...

Alexia:
Thanks, but I don't see a 10-wacom.fdi in /usr/share/doc/xserver-xorg-input-wacom

$$ ls /usr/share/doc/xserver-xorg-input-wacom

changelog.Debian.gz copyright

$$ ls /etc/hal/fdi/policy/

preferences.fdi

Alexia Death (alexiade) wrote :

OK, it seems it was moved from there when it was re-enabled, not copied as I assumed.

That changes the command to:
sudo cp /usr/share/hal/fdi/policy/20thirdparty/10-wacom.fdi
/etc/hal/fdi/policy/10-wacom.fdi

Theoreticly you should not need to change the file at /usr/share/hal/fdi/policy/20thirdparty/10-wacom.fdi, and editing the copy is enough, but I have not tested that myself. I learned about that theory after needing to debug the wacom driver on hotplug...

Loïc Martin (loic-martin3) wrote :

@Jose Hevia
I think that was the old location, now it's enabled by default you should find it in /usr/share//hal/fdi/policy/20thirdparty/10-wacom.fdi

Note : I you can't find it, just go to the root of your filesystem and, in this case :
sudo find | grep wacom.fdi
(which should take a while but you'll have chacked thoroughly ;), just make sure you have wacom-tools installed ).

@Dave M G
What's the problem with the documentation at https://help.ubuntu.com/community/Wacom ?
It's community maintained, which means if you have any suggestions you can add them (just keep the structure of the page organised) or ask at http://ubuntuforums.org/showthread.php?p=6084069 so we can edit the guide accordingly.

Alexia Death (alexiade) wrote :

A note about searching: Theres a better way than find. Locate is very fast, so "locate wacom.fdi" gives a quick answer. The only downside of locate is that it indexes files on a regular basis and so does not find files created very recently.

Alexia: IT WORKS!!!!!!!

Finaly I can use my note taking programs again.

If Anyone is interested in rotating the tablet, that's my fdi file:

<?xml version="1.0" encoding="UTF-8"?> <!-- -*- SGML -*- -->

<deviceinfo version="0.2">

  <device>
    <match key="info.capabilities" contains="input">
      <match key="info.product" contains="Wacom">
  <merge key="input.x11_driver" type="string">wacom</merge>
  <merge key="input.x11_options.Type" type="string">stylus</merge>
  <merge key="input.x11_options.Rotate" type="string">CCW</merge>
      </match>

      <match key="info.product" contains="WALTOP">
  <merge key="input.x11_driver" type="string">wacom</merge>
  <merge key="input.x11_options.Type" type="string">stylus</merge>
      </match>
    </match>
    <!-- N-Trig Duosense Electromagnetic Digitizer -->
    <match key="info.product" contains="HID 1b96:0001">
      <match key="info.parent" contains="if0">
       <merge key="input.x11_driver" type="string">wacom</merge>
       <merge key="input.x11_options.Type" type="string">stylus</merge>
      </match>
    </match>
  </device>

</deviceinfo>

Loic Martin: No problem with documentation. I searched tablet, not wacom, you can try and see what you find. Dave didn't understood what a fdi was, me either. And until very recently hotplug didn't work as documentation says.

Thank you Alexia and Loic.

Steve Langasek (vorlon) wrote :

This is as documented as it's going to get for intrepid, now; closing this bug out.

Changed in ubuntu-release-notes:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers