/dev/input/wacom device missing for Bamboo Fun in Hardy

Bug #195636 reported by Michael Chang on 2008-02-26
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linux
Invalid
Undecided
Unassigned
linux (Ubuntu)
Medium
Unassigned
wacom-tools (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: wacom-tools

In Hardy, with my Bamboo Fun 4x5 tablet plugged in at startup, /dev/input/wacom devices are not created and the wacom module is not loaded. If I manually execute "sudo modprobe wacom" the devices are still not created.

In Gutsy, I had to manually build wacom-tools 0.7.9 from source and replace the kernel module with the one built by the wacom-tools compile process. I would assume that after the upload of wacom-tools 0.7.9 in Hardy, this would be fixed, but it doesn't appear to be.

It appears this is because the wacom module in the Hardy kernel is older than the module included with the Linux Wacom Project's source. (The earliest versions of the wacom tools source to include a module with support the Bamboo Fun are 0.7.7-12 and 0.7.8-3.) According to Fedor Isakov (see comment below), the earliest vanilla kernel with support for the Bamboo Fun is 2.6.25-rc7.

ProblemType: Bug
Architecture: i386
Date: Mon Feb 25 20:30:46 2008
DistroRelease: Ubuntu 8.04
Package: wacom-tools 1:0.7.9.3-2ubuntu2
PackageArchitecture: i386
SourcePackage: wacom-tools
Uname: Linux pineapple 2.6.24-8-generic #1 SMP Thu Feb 14 20:40:45 UTC 2008 i686 GNU/Linux

Michael Chang (thenewme91) wrote :
Michael Chang (thenewme91) wrote :
Michael Chang (thenewme91) wrote :
Michael Chang (thenewme91) wrote :

contains the output of
dpkg -l 'linux-*'

Michael Chang (thenewme91) wrote :

contains the output of
dpkg -l 'wacom-*'

Michael Chang (thenewme91) wrote :
Michael Chang (thenewme91) wrote :
Michael Chang (thenewme91) wrote :
Michael Chang (thenewme91) wrote :
Michael Chang (thenewme91) wrote :
Brian Murray (brian-murray) wrote :

I'm invalidating the upstream kernel task at this point in time as the bug may not need forwarding upstream.

Changed in linux:
status: New → Invalid
Michael Chang (thenewme91) wrote :

Okay; thank you. (Actually, the adding of the upstream task was accidental; I was trying to add the linux package, not the linux upstream task, and I wasn't sure what to do with the upstream task afterwards.)

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: New → Triaged
Marat Dyatko (marat-dyatko) wrote :

So.. fucking bamboo doesn't work at fucked Hardy..
I need re-install system?!

Michael Chang (thenewme91) wrote :

@vectart:
1. Please don't swear.
2. As far as I am aware, the bamboo fun has never worked "out of the box" on either Gutsy or Hardy. It is possible to get them to work by manually compiling and installing the driver. However, I am surprised this is necessary for this hardware considering the driver in hardy should be new enough to support the Bamboo Fun. Hence I filed this bug.
3. Hardy is meant for experienced users and should not be used except for testing purposes until its release in April.

Fedor Isakov (fisakov) wrote :

The version of wacom driver in the kernel source tree is vastly outdated. The earliest kernel version at kernel.org that includes support for Bamboo Fun is 2.6.25-rc7. I guess it's unlikely the new driver is going to make it into Hardy final.

Why is that it took so long for the new version to propagate into the kernel? The changes that make Bamboo Fun work were committed 5 months ago, according to cvs history: http://linuxwacom.cvs.sourceforge.net/linuxwacom/linuxwacom-dev/src/2.6.19/wacom_wac.c?r1=1.4&r2=1.5 .

Michael Chang (thenewme91) wrote :

Ah, that would explain it.

As far as I'm aware, Ubuntu prefers to manage as few patches as possible against the linux kernel tree, even if it means waiting for drivers to go from patches to the vanilla kernel to packages.

Although it's somewhat surprising when tools' package versions don't match the driver versions in the kernel source.

Personally, I'll probably just compile the modules from source this time around and recheck this bug in Hardy+1.

Timo Aaltonen (tjaalton) wrote :

This is not an issue with the wacom-tools package, so closing the bug for this component.

Changed in wacom-tools:
status: New → Invalid
NakedNous (nakednous) wrote :

I can confirm what Michael Chang suggested. I compiled the module (linuxwacom-0.7.9-7.tar.bz2) with --enable-wacom and just replaced wacom.ko with the compiled one. My bamboo began to work again.

description: updated
description: updated
description: updated

Care to test the Intrepid Ibex 8.10 kernel? It was most recently rebased with the upstream 2.6.25 kernel and is currently available in the following PPA:

https://edge.launchpad.net/~kernel-ppa/+archive

If you are not familiar with how to install packages from a PPA basically do the following . . .

Create the file /etc/apt/sources.list.d/kernel-ppa.list to include the following two lines:

deb http://ppa.launchpad.net/kernel-ppa/ubuntu hardy main
deb-src http://ppa.launchpad.net/kernel-ppa/ubuntu hardy main

Then run the command: sudo apt-get update

You should then be able to install the linux-image-2.6.25 kernel package. After you've finished testing you can remove the kernel-ppa.list file and run 'sudo apt-get update' once more. Please let us know your results. Thanks

Changed in linux:
status: Triaged → Incomplete
Michael Chang (thenewme91) wrote :

Okay, I'm installing linux-image-2.6.25-1-generic (version 2.6.25-1.2ubuntu5) and linux-ubuntu-modules-2.6.25-1-generic (version 2.6.25-1.1ubuntu8); I'll report the results in this thread in a few moments.

Michael Chang (thenewme91) wrote :

Yes, the new Intrepid Ibex kernel based on 2.6.25 in the kernel PPA creates the /dev/input/wacom device, both with the device plugged in on startup, and when it is plugged in while the system is running.

Notes: With the new kernel, the X server provides the expected behavior as documented in wacom-tools upstream; i.e. that the X server must be (re-)started after the Bamboo Fun is plugged in. (This is not the kernel's fault; it creates the devices correctly now.) Potentially relevant to anyone who reads this later: The Wacom-related sections of my X.Org config are from Gutsy; I did not try this with a config-less X.org setup.

Hi Michael,

Thanks for testing and the feedback. I'm marking this "Fix Committed" against the Intrepid kernel. Thanks.

Changed in linux:
status: Incomplete → Fix Committed

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Intrepid was released back in Oct 2008. Marking this Fix Released.

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers