Ubuntu

no wacom tablet driver (no autoprobe, patch available)

Reported by Coz on 2008-02-03
36
This bug affects 2 people
Affects Status Importance Assigned to Milestone
wacom-tools (Ubuntu)
Medium
Unassigned

Bug Description

Just installed hardy alpha4. There is no wacom tablet driver or and no settings in xorg.conf for wacom.
 Will this be remedied before realease?
i persoanlly cant use a mouse with much precision.
 coz

SK (stephantom) wrote :

Thank you for taking the time to report this bug!
This report had no package assiged. Since the wacom driver is provided through the xserver-xorg-input-wacom package (which is in turn built from wacom-tools), I am assigning it now.

Justin Dugger (jldugger) wrote :

Coz, have you installed the wacom-tools package?

Coz (cosimo321) wrote :

hello justin
yes I have installed the wacom-tools package however the xorg.conf still has no wacom settings at all.
Of course what I am going on are the settings that have been in the xorg.conf for the previous three versions of ubuntu, ie. Section "InputDevice"
    Identifier "stylus"
    Driver "wacom"
    Option "Device" "/dev/input/wacom"
    Option "Type" "stylus"
    Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection
 etc etc.
 I have attached the current hardy xorg.conf.
I should point out that this is a clean install of hardy not an upgrade.
coz

Justin Dugger (jldugger) wrote :

Does it work for you if you add the above sections to xorg.conf?

Coz (cosimo321) wrote :

Hey Justin,
  No it doesnt work at all in fact it will not boot with the added entries in xorg.conf.
coz

Shadows_Friend (shadows-friend) wrote :

The problem results from an incompatibility between Xorg 7.3 and the driver that is supplied by the Ubuntu package. The newest development version (0.7.9-7 at the moment) contains a temporary workaround for Xorg 7.3.

Therefore a workaround for the bug is: Download the most recent development sources from the Linux Wacom Project ( http://linuxwacom.sourceforge.net/ ), compile and install them.

However the workaround provided by the sources is not that perfect. The lines I draw in Xournal are very ugly. I managed to reolve this issue by deactivating "Use XInput" in the Options tab.

Santiago Pence (alphonse-isaac) wrote :

Hardy version of wacom driver actually is 0.7.9.3, it has some workaround for X.org 7.3 , but the latest is 0.7.9.8 and it has better support for X.org 7.3 than the actual package on hardy (my Bamboo tablet seems to be fully functional with this version), the mantainer of wacom-tools and xorg-input-wacom should upgrade it as fast as possible before the final release.

PS: X.org 7.3 seems to have improved hotplugin for input devices, I think that´s the reason beacuse there aren´t any entries on xorg.conf configuration file.

Vincenzo Ciancia (vincenzo-ml) wrote :

In my case just taking the xorg.conf that I had on gutsy solved the problem and made my pen work. Hardy does not autoconfigure the tablet pc input, this is a very bad regression from gutsy, since it took 2 releases (dapper and edgy) to get the thing right and have autoconfiguration in feisty if I recall correctly (or was it gutsy?).

Justin Dugger (jldugger) wrote :

As far as I know, X.org has never supported autoconfiguration of wacom. We have had wacom by default on xorg.conf files, but never working X + wacom without xorg.conf knowing about it. I think this change has been a long time coming, as the default gutsy xorg.conf simply had the wacom lines commented out. I believe the goal is to ship hardy without xorg.conf by default. Obviously this is a large flaw.

What's really needed here is either wacom autodetection (and intelligent defaults) or a script to modify to xorg.conf files. I suspect neither one is trivial.

I've the same problem in Samsung Q1 (UMPC) with Hardy Heron Beta. The tablet screen is not recognized at all.

Sven Herzberg (herzi) wrote :

The latest upstream has autodetection, Ubuntu just doesn't package updates any quickly.

Daniel Hahler (blueyed) wrote :

Sven: do you mean the latest upstream of wacom-tools?
Is it possible to extract only this particular feature as a patch?

Justin Dugger (jldugger) wrote :

I can't be sure (how I hate CVS) but it looks like development release 7.9.9 added a patch for autoprobing two weeks ago. With a scant two weeks to go until release, you'd have a hard time arguing that the risk to breaking wacom to bring in auto detection patches can be mitigated. If anyone's interested in hunting down the patches, here's a clue from the upstream Changelog:

2008-03-30 Ping Cheng <email address hidden>
  * Updated configure.in for keystrokes (Magnus Vigerlöf)
  * Added touch support for serial TabletPC (ISDv4)
  * Added autoprobe patch (Matthias Hopf @ Suse)
 * Label 0.7.9-9

Daniel Hahler (blueyed) on 2008-04-13
Changed in wacom-tools:
importance: Undecided → Medium
status: New → Triaged
  • unnamed Edit (1.5 KiB, text/html; charset=ISO-8859-1)

Hey guys,
 i was under the impression, reading at linux wacom project that xcb is the
reason there is no wacom tablet driver in hardy and only a patch exists that
apparenlty doesnt always work.
 Unless Linus wacom project has updated the driver i dont think there is a
way to have wacom on hardy which for me persoanlly would mean going back to
Feisty.
   Unless you guys at ubuntu are planning some work around, we will have to
wait for an xcb compliant driver from Linus wacom project.
Correct me if I am wrong about this!!!
coz

On Sun, Apr 13, 2008 at 11:51 AM, Daniel Hahler <email address hidden>
wrote:

> ** Changed in: wacom-tools (Ubuntu)
> Importance: Undecided => Medium
> Status: New => Triaged
>
> ** Summary changed:
>
> - no wacom tablet driver
> + no wacom tablet driver (no autoprobe, patch available)
>
> --
> no wacom tablet driver (no autoprobe, patch available)
> https://bugs.launchpad.net/bugs/188787
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Justin Dugger (jldugger) wrote :

Wacom works for me, after pulling up an xorg.conf from gutsy / feisty. Others are complaining in this bug that wacom isn't autodetected. This is different than not working at all. Coz, is your bug that you can't get wacom-tools to work at all?

  • unnamed Edit (2.6 KiB, text/html; charset=ISO-8859-1)

Hey Justin,
 well wacom tools is installed but that does nothing if the driver isnt
there unless you are saying that wacom tools is the driver??? Which would
completely surprise me!
 Look..if I have to drag out a feisty or gutsy xorg to run this then its
useless.. There is no reason anyone should have to do this. considering the
blazing speed at which ubuntu improves it seems like a huge step backwards
for wacom NOT to be autodetected and the settings in xorg set by default.
No , my tablet does not work with wacom tools and even though I put in the
xorg settings for wacom still nothing .
 In hardy cat event6 is for wacom and even that , along with the settings in
xorg do nothing.
Auto detection is imperative... the drivers need to be installed by default.

I have argued this way back when wacom was not installed or autodetected. If
someone decides to use ubuntu in a graphics house no wacom is a real mark
against its use or if someone who is handicapped has to jump through hoops
to get this running then again it is useless.
No, my tablet, an intuos III, is not running, wacom tools installed and all.
so my suggestion is to get autodetection back up and running
there are no alternatives to this!!
without it ubuntu cannot brag about accessibility features
Now... if you feel I am missing something, which is certainly possible, let
me know :)
By the way I am not angry or anything just very determined not to allow
something like this to get passed by by developers. Autodetection is
absolutely necessary.. and no way is it a proper action to have to borrow
something from another version's xorg to get this up and running.

coz

On Sun, Apr 13, 2008 at 4:48 PM, Justin Dugger <email address hidden> wrote:

> Wacom works for me, after pulling up an xorg.conf from gutsy / feisty.
> Others are complaining in this bug that wacom isn't autodetected. This
> is different than not working at all. Coz, is your bug that you can't
> get wacom-tools to work at all?
>
> --
> no wacom tablet driver (no autoprobe, patch available)
> https://bugs.launchpad.net/bugs/188787
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Timo Aaltonen (tjaalton) wrote :

The entries were dropped because they introduced some accessibility issues (which, I can't remember).

Vincenzo Ciancia (vincenzo-ml) wrote :

A solution must be discussed soon, things can't just remain like that: it took a long time to get a working wacom setup by default, and seeing that now the tablet is disabled for a reason nobody knows is like saying that everybody who reported wacom bugs related to out-of-the-box setup (including the infamous "wacom-tools not installed by default" that finally was fixed in edgy) wasted his/her time.

Many people just thinks that "linux can't handle tablets". Giving them an ubuntu cd that disables the tablet by default will convince everybody that it is so.

Justin Dugger (jldugger) wrote :

As I recall, KDE/Qt has a viciously hard time dealing with tablet devices listed in Xorg but not physically present. Enough that several developers have blamed tablet users for making it impossible to debug KDE and calling the addition a move by idiots. Timo may be correct that it also affects some usability tools.

Like I said before, what's needed to fix this is either a post-inst script to modify xorg.conf or a patch to wacom tools to support autoprobing / configuration. Re-adding the entries by default simply breaks someone else's use case.

Vincenzo Ciancia (vincenzo-ml) wrote :

KDE broken is a good motivation. Let's discuss a possible way to autoprobe:

/etc/init.d/xserver-xorg-input-wacom

already sets up the link /dev/input/wacom whenever a wacom tablet exists. Problem is that wacom-tools are no longer installed by default by ubuntu so the autoconfigure script cannot be there. In my opinion it should go into the dexconf script, do you think it's wise? Will xserver-xorg-input-wacom be installed and configured before or after xserver-xorg postinst in default installation? I can attempt to provide a patch to dexconf, seems reasonably easy.

Vincenzo Ciancia (vincenzo-ml) wrote :

Please take a look to the following patch proposal to /usr/bin/dexconf. It generates proper wacom configuration whenever /dev/input/wacom exists. If xserver-xorg-input-wacom is installed and /etc/init.d/xserver-xorg-input wacom is run, before configuration of xserver-xorg, then this could be consider a proper fix. Or else dexconf could be run by the xserver-xorg-input-wacom post installation script.

Vincenzo Ciancia (vincenzo-ml) wrote :

I also attach the patched dexconf so that everyone can test. To test it, just give it execution permissions and run "sudo ./dexconf" in the directory where you saved it (not "sudo dexconf" without "./", that would run the system version). Then log out and kill X using ctrl+alt+backspace, tablet should work.

Vincenzo Ciancia (vincenzo-ml) wrote :

Hi people,
A quick word of warning...

I went ahead and got Vicenzo's dexconf, and ran it.

Voila, the grapphire 2 tablet worked as a charm. However, I was back to 800x600 resolution on a 22' widescreen LDC monitor :(
Basically, dexconf overwrote xorg.conf, resetting it to the most basic setup possible, with a working tablet.

Of course, i was rushing, and did not backup xorg.conf before. Grumble... A quick nvidia-xconfig (in my case) created a working xorg.conf to which the relevant sections from the dexconf generated files could copy-pasted into. Now everything works fine, including the tablet.

So first, Vicenzo thanks for the fix! Second, please warn people this will happen ( indeed, if this is the intended behaviour) and/or create a backup of the xorg.conf before overwriting it. If this is not supposed to happen, please consider it a bug report :)

Cheers
igor

p.s. I attached the xorg.conf created by the dexconf, maybe it is useful...

Vincenzo Ciancia (vincenzo-ml) wrote :

This is a bug in how I suggested to test the patch. I am very sorry for that. Explanation: to reconfigure the xserver one should not run dexconf directly but rather

dpkg-reconfigure -phigh xserver-xorg

which answers something like:

xserver-xorg postinst warning: overwriting possibly-customised configuration
   file; backup in /etc/X11/xorg.conf.20080424203010

So the proper way to test is to rename old /usr/bin/dexconf to something else, substitute it with new version, chmod 755 it, and then run "dpkg-reconfigure -phigh xserver-xorg". This will properly backup existing xorg.conf. In any case dexconf should have configured X correctly as it did the first time you installed ubuntu. I don't own an nvidia card (or better I own it but i never reconfigured *that* machine :)) so I don't know why this happened. Perhaps you just had to reconfigure also the package containing the nvidia driver after running dexconf.

Igor Nikolic (i-nikolic) wrote :

Ah, I see.

Thanks for the quick reply.

The main problem here is that the dpkg-reconfigure -phigh xserver-xorg does not detect the card at all, and defaults to the lowest possible setting. I must run the nvidia tool to get everything up an running. So I guess your script actually did work, but my dpkg can not figure this setup out. At any rate, thanks for the clarification !

Greetings
Igor

Bodinux (bodinux) wrote :

Vincenzo,

Thanks for the patch, it is working for me.

Install 8.04, install wacom-tools, launch your patch as you described, restartX, works.

Coz (cosimo321) wrote :

Hey guys,
  Well I did the Vincenzo patch and, with nvidia, Igor is correct it did not maintain the nvidia settings in xorg and they had to be copied and pasted in .
  however, as nicely as this works, it is not enough !!
This is unacceptable for handicapped individuals who require a wacom tablet to function on a computer.
 This is having someone jump through hoops which is the opposite of offering accessibility features!!!
 excuse me if I sound a bit irritated, however this lighting speed every six month approach to ubuntu , at least in this case, is out of hand. I think anyone who uses or "requires" wacom tablets would have been more than willing to wait until auto detection was fixed. This patch is nice and it works with some adjustments using nvidia, however i would never expect any of my handicapped clients finding their way with this patch, which from their point of view, would require them to pay me to fix the issue.
  I dont know who creates the "agenda" list for the next version of ubuntu, however when it comes to things that have already been implimented, ie wacom tabelts autodetection, and it is not working on the new version of ubuntu, then that particular issue should be high on the list of fixes, otherwise there is no need for a new version if it steps backwards.
 I apologize if i sound "picky" or aggressive here, but I do have handicapped clients and I do tend to get very agressive when i see something like this occur. In my opinion , this is mind boggling. Accessibility features must not be seen as secondary issues to the working of the OS, it must be at the top of the list of requirements for the system to be realesed.
  I think it's irrelevant that it would push the release date to 8 months instead of 6.

Vincenzo Ciancia (vincenzo-ml) wrote :

I added the fix to the ubuntu-quickfix ppa archive. This is an open team I created that should allow launchpad users to upload simple fixes to the current distribution. Installing the .deb packages there should automatically reconfigure xorg correctly, can someone test? Please back up your xorg.conf first!

Add the sources.list from

https://edge.launchpad.net/~ubuntu-quickfix/+archive

then update the list of packages (e.g. by hitting reload in synaptic), and upgrade the system. If you don't want the other fixes or don't want to subscribe to the ubuntu-quickfix archive, simply click on the xorg debs for your architecture and install those (in particular take care of installing x11-common).

Bodinux (bodinux) wrote :

It didn't work here.

My /etc/X11/xorg.conf was not modified by the update. This is maybe due
to the fact that there were also some updates from the main repositories
at the same time (x11-common for example was named twice)?

Now the quickfix packages on my system are :
x11-common, xbase-clients, xorg, xserver-xorg, xserver-xorg-input-all,
xserver-xorg-video-all, xutils

Vincenzo Ciancia (vincenzo-ml) wrote :

Bodinux: did you modify your Xorg.conf manually before upgrading? If so you have to "dpkg-reconfigure -phigh xserver-xorg" manually, the system will not do that automatically because reconfiguring destroys user modifications.

Bodinux (bodinux) wrote :

Vincenzo : I didn't modify xorg.conf. I only made a cp on it for a backup.

Am I the only one who tried your quickfix ?

Vincenzo Ciancia (vincenzo-ml) wrote :

Bodinux: as far as I can tell from documentation, xserver-xorg upgrade should trigger the reconfiguration. The only difference with the original package is the updated dexconf, so this is either my misconception about how and when reconfiguration is triggered, or a bug in xorg package, and I vote for the first. Anybody can comment on this? Do you have the new dexconf or the old one right now?

Bodinux (bodinux) wrote :

Vincenzo : I guess I have the new one :
-rwxr-xr-x 1 root root 11452 2008-04-22 23:07 /usr/bin/dexconf

See attachement.

Wladston Viana (wladston) wrote :

Thanks Vicenzo, it worked for me, I have a Toshiba Satellite R20 Tablet pc.

Please, put this fix on the updates, it should be preventing non-tech-savy artists from trying to use Ubuntu ....

Vincenzo Ciancia (vincenzo-ml) wrote :

In intrepid things have changed. In current alpha 6 one can still configure the tablet with the Xorg.conf that I attach, but this functionality will be dropped, this means that we will not be able to use tablet PCs in intrepid. This decision was taken because autoconfiguration is the future but without any attention to end-users who already use a tablet pc in the present. In any case I attach my current working configuration.

Vincenzo Ciancia (vincenzo-ml) wrote :

My last comment was caused by misinformation. Indeed there will be the possibility to configure X by hand either on a per-device basis or globally as in the good old times. Sorry for confusion.

The following message clarifies things:

https://lists.ubuntu.com/archives/ubuntu-devel-discuss/2008-September/005778.html

Wladston Viana (wladston) wrote :

still an issue on 8.10 - someone PLEASE fix this!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions