Need input-hotplug - Genius Tablet (used to work as wacom) does not work anymore on hotplug

Bug #120262 reported by Markus Kienast on 2007-06-13
4
Affects Status Importance Assigned to Milestone
wacom-tools (Ubuntu)
Medium
Bryce Harrington

Bug Description

My Genius WizardPen 5x4 Pen Tablet used to work as a wacom tablet in Ubuntu. Now in Feisty it does not work after hotplug anymore. Dmesg says it is recognized as Tablet but there is also something about an Xbox controller (xpad) in there, which I definitively have not plugged in, since I don't even own one. (Would never buy one just for that one reason ...).

I will attach an lshw, dmesg and the Xorg.log output.

Markus Kienast (elias1884) wrote :
Markus Kienast (elias1884) wrote :
Markus Kienast (elias1884) wrote :
Markus Kienast (elias1884) wrote :
Paul Dufresne (paulduf) wrote :

Hi, I am a bug triager making sure the bug is complete enough for knowing what is needed to be fixed.

I extracted from your Xorg.0.log:
(**) Option "Device" "/dev/wacom"
(EE) xf86OpenSerial: Cannot open device /dev/wacom
 No such file or directory.

This leads me to conclude that the problem is that the device is not created, which, as far as I know
is udev responsability, which leads me to assign this bug to udev.

We have never created /dev/wacom, perhaps you mean a particular device under /dev/input?

Xorg bug

My Genius WizardPen 5x4 Pen Tablet worked in Ubuntu 7.04 Feisty perfectly by just plugging it in but in Ubuntu 7.10 gutsy it is totally useless. This is really disappointing since I'll have to delete Ubuntu 7.10 gutsy and go back to feisty If I can't fix this.
Also I don't normally report any problems or bugs so I don't know whether to report a problem with gnome-ppp dialer and vodafone huwei E220 modem. It works perfectly with Ubuntu Ultimate1.4 and 1.5 (based on feisty).
With Gutsy its easy enough to configure and get working at first, but after using the modem for a day or even sometimes a few hours, via gnome-ppp dial, it goes from finding the modem and connecting to the net to not recognizing the modem at all and its a total lottery whether it finds it again at all. I went a full two days without gnome-ppp dialer (Ubuntu Gutsy) being able to connect to the net or find the modem at all.
This is a major problem for me. Any help would be appreciated, but even better is that people are aware of and are working on these problems.
Also with compiz effects activated in Gutsy if you view a picture/image file in full screen mode the screen flickers (black) on and off uncontrollably. There are also other compiz irritations/errors too numerous to mention. Why does compiz / Aiglx work so well in Beryl (almost perfectly) but the standard versions of Ubuntu has so much trouble with 3d effects.

Have you tried the Ubuntu Wizardpen guide? (Most Genius tablets are Wizardpen compatible)

https://help.ubuntu.com/community/TabletSetupWizardpen

Bryce Harrington (bryce) on 2008-07-04
Changed in xorg:
status: Confirmed → Triaged
Bryce Harrington (bryce) wrote :

Someone lent me this hardware and I can reproduce the issue. input-hotplug hasn't completely fixed the problems. I'll look into it more as I have time.

Changed in xorg:
assignee: nobody → bryceharrington
importance: Undecided → Medium
Timo Aaltonen (tjaalton) wrote :

the output of lshal should reveal if the hotplug is working and what device id to add to the fdi if not.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers