package w3c-markup-validator (not installed) failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

Bug #1247116 reported by Chealdo Ortiga on 2013-11-01
30
This bug affects 6 people
Affects Status Importance Assigned to Milestone
w3c-markup-validator (Debian)
Fix Released
Unknown
w3c-markup-validator (Ubuntu)
Undecided
Unassigned

Bug Description

installation failed

ProblemType: Package
DistroRelease: Ubuntu 13.10
Package: w3c-markup-validator (not installed)
ProcVersionSignature: Ubuntu 3.11.0-12.19-generic 3.11.3
Uname: Linux 3.11.0-12-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.12.5-0ubuntu2.1
Architecture: amd64
Date: Fri Nov 1 21:08:54 2013
DuplicateSignature: package:w3c-markup-validator:(not installed):subprocess installed post-installation script returned error exit status 1
ErrorMessage: subprocess installed post-installation script returned error exit status 1
InstallationDate: Installed on 2013-10-22 (10 days ago)
InstallationMedia: Xubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016)
MarkForUpload: True
SourcePackage: w3c-markup-validator
Title: package w3c-markup-validator (not installed) failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: No upgrade log present (probably fresh install)

Chealdo Ortiga (scriptwarlock) wrote :
tags: removed: need-duplicate-check
Ben Hockley (oohbuntu) wrote :

The underlying problem seems to be that the package installer assumes the existence of the (recently deprecated?) /etc/apache2/conf.d/ directory - so installation likely to be broken on fresh installations or upgrades from recent versions.

From googling, it looks like /etc/apache2/conf.d/ was replaced by /etc/apache2/conf-available/ in apache 2.4 - so it is the change to apache that has broken this package, I guess?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in w3c-markup-validator (Ubuntu):
status: New → Confirmed
Changed in w3c-markup-validator (Debian):
status: Unknown → New
Changed in w3c-markup-validator (Debian):
status: New → Fix Released
Ben Coleman (b-coleman) wrote :

This problem still exists in 14.04.

Janus (ysangkok+launchpad) wrote :

Super annoying issue on 14.04, makes the package unusable.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.