fix 8VSB & 16VSB channel xine dump for ATSC channel scan

Bug #771786 reported by Michael Krufky on 2011-04-27
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
w-scan (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Daniel T Chen
Maverick
Undecided
Daniel T Chen
Natty
Undecided
Daniel T Chen

Bug Description

Binary package hint: w-scan

SRU impact statement / TEST CASE:
Xine formatted output from w_scan is incorrect for 8VSB and 16VSB modulations. The output should read "8VSB" and "16VSB" rather than "VSB_8" and "VSB_16"

Unfortunately, from what I can tell, this applies to w-scan in *every* version of Ubuntu -- the last non-broken upstream w_scan release was 20081106 -- the bug was present in all releases thereafter.

Patch / Resolution:
Michael's patch has been accepted and is currently in Oneiric's version.

Patches for lucid-proposed (https://bugs.launchpad.net/ubuntu/+source/w-scan/+bug/771786/+attachment/2219549/+files/w-scan_20091230-1ubuntu0.1.debdiff), maverick-proposed (https://bugs.launchpad.net/ubuntu/+source/w-scan/+bug/771786/+attachment/2219550/+files/w-scan_20100316-3ubuntu0.1.debdiff), and natty-proposed (https://bugs.launchpad.net/ubuntu/+source/w-scan/+bug/771786/+attachment/2219551/+files/w-scan_20101001-1ubuntu0.1.debdiff) are attached.

Regression risk:
Slim to none. No code paths are altered by this patch.

Additional information from original description:
Side note: The program is actually called w_scan with an underscore (_). The author makes note of this explicitly in his changelog: "ChangeLog:28: - NOTE@maintainers: it's called 'w_scan', not 'w-scan' or 'wscan'."

I've attached a patch that solves this bug. The patch has already been sent upstream, and shall be included in the next release of w_scan.

tags: added: patch
Daniel T Chen (crimsun) wrote :

Oneiric has 20110616-1, which contains the fix. Marking Oneiric as fixed.

Changed in w-scan (Ubuntu):
status: New → Fix Released
tags: added: patch-accepted-upstream
removed: patch
Daniel T Chen (crimsun) wrote :
Daniel T Chen (crimsun) wrote :
description: updated
Changed in w-scan (Ubuntu Natty):
assignee: nobody → Daniel T Chen (crimsun)
Changed in w-scan (Ubuntu Maverick):
assignee: nobody → Daniel T Chen (crimsun)
Changed in w-scan (Ubuntu Lucid):
assignee: nobody → Daniel T Chen (crimsun)
Chris Halse Rogers (raof) wrote :

SRU team ack for lucid- and maverick-proposed packages.

The natty-proposed package is a 3.0 (quilt) package, and the changes have been applied as an autogenerated debian-changes patch. Although it's largely a stylistic matter I'd prefer to have a proper patch header and patch name.

I'm still calibrating my SRU-accept-meter, so if other members of the SRU team disagree with this I'm happy for natty-proposed to go through too.

Hello Michael, or anyone else affected,

Accepted w-scan into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in w-scan (Ubuntu Lucid):
status: New → Fix Committed
tags: added: verification-needed
Changed in w-scan (Ubuntu Maverick):
status: New → Fix Committed
Martin Pitt (pitti) wrote :

Hello Michael, or anyone else affected,

Accepted w-scan into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Martin Pitt (pitti) wrote :

I agree; the maverick update has a proper patch name; for the natty one you'd just need to rename the patch and update the patch header accordingly.

Daniel T Chen (crimsun) wrote :
Clint Byrum (clint-fewbar) wrote :

For the record I think the patch name and description are still a little weak (The description should be of the actual change the patch makes). However, the bug reference is correct and the patch is extremely straight forward, so I'll accept it.

Changed in w-scan (Ubuntu Natty):
status: New → Fix Committed
Clint Byrum (clint-fewbar) wrote :

Hello Michael, or anyone else affected,

Accepted w-scan into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Daniel T Chen (crimsun) wrote :

Thanks, Clint. Since the natty-proposed source FTBFS (ugh) because of a header change, I'll go ahead and fix up the patch name and description as well for the next upload.

Daniel T Chen (crimsun) wrote :

I've addressed Clint's concerns in a reworked SRU proposal and uploaded to natty-proposed; see bug 815500 for the FTBFS fix.

Clint Byrum (clint-fewbar) wrote :

Hello Michael, or anyone else affected,

Accepted w-scan into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: testcase

The fix for this bug has been awaiting testing feedback in the -proposed repository for lucid for more than 90 days. Please test this fix and update the bug appropriately with the results. In the event that the fix for this bug is still not verified 15 days from now, the package will be removed from the -proposed repository.

Changed in w-scan (Ubuntu Maverick):
status: Fix Committed → Triaged
status: Triaged → Won't Fix
Changed in w-scan (Ubuntu Natty):
status: Fix Committed → Won't Fix
tags: added: removal-candidate
Brian Murray (brian-murray) wrote :

The version of w-scan in lucid-proposed has been removed as this bug report was not verified in a timely fashion.

tags: removed: verification-needed
tags: removed: removal-candidate
Changed in w-scan (Ubuntu Lucid):
status: Fix Committed → Triaged
Rolf Leggewie (r0lf) wrote :

lucid has seen the end of its life and is no longer receiving any updates. Marking the lucid task for this ticket as "Won't Fix".

Changed in w-scan (Ubuntu Lucid):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers