loader: Fix GetDeviceProcAddr with terminators

Bug #1813002 reported by Sai Kiran Korwar on 2019-01-23
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
vulkan (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Timo Aaltonen

Bug Description

[Impact]
Currenty Bionic still uses vulkan loader version 1.1.70. The later version 1.1.73 which is available with Cosmic and Disco has some necessary fixes to support Vulkan 1.1.

The loader v1.1.70 returns function pointers to some extensions which have not been enabled, which is in violation of the latest vulkan spec.
This issue has been fixed in loaders v1.1.73 and higher.

[Test case]
check that vulkan apps still work, and the issue is fixed

[Regression potential]
This is a single backported commit, should not cause other issues.

Timo Aaltonen (tjaalton) on 2019-01-24
Changed in vulkan (Ubuntu):
status: New → Invalid
Timo Aaltonen (tjaalton) wrote :

"urgent" would still mean roughly a couple of weeks until it's in bionic-updates

Sai Kiran Korwar (skirank) wrote :

Thanks for taking it up.

Couple of weeks might just do it for us.

Timo Aaltonen (tjaalton) on 2019-01-24
description: updated
Changed in vulkan (Ubuntu Bionic):
assignee: nobody → Timo Aaltonen (tjaalton)
status: New → In Progress
Sai Kiran Korwar (skirank) wrote :

No, that is not the one, here is the change that I actually need, which is included with the 1.1.73

https://github.com/KhronosGroup/Vulkan-LoaderAndValidationLayers/commit/72eb69da597fc245a607280e93212d658401eda2#diff-d6c5855a62cf32a4dadbc2831f0f295f

Timo Aaltonen (tjaalton) wrote :

cool, I've added that commit to the current package in bionic, and you can check if it fixes the issue by installing it from this ppa:

https://launchpad.net/~tjaalton/+archive/ubuntu/test

Sai Kiran Korwar (skirank) wrote :

Thanks, I will test it and let you know.

BTW Is this a temporary measure due to the urgency? or do we not plan to move to more recent versions for bionic?

Sai Kiran Korwar (skirank) wrote :

Hi Timo,

I need the build for aarch64, as that is the platform I need to test on.

Timo Aaltonen (tjaalton) wrote :

It is a temporary one which should be easier to SRU. We'll likely move to a newer version for 18.04.3 based on what 19.04 releases with, the packaging has changed quite a bit and getting that in bionic takes more time.

I've pushed it here too, which does arm64 builds

https://launchpad.net/~canonical-x/+archive/ubuntu/testing

Sai Kiran Korwar (skirank) wrote :

I verified that the new package from https://launchpad.net/~canonical-x/+archive/ubuntu/testing fixes my issue.

Timo Aaltonen (tjaalton) wrote :

thanks for testing, I've uploaded it to the queue

summary: - Update vulkan loader in Bionic to v1.1.73
+ loader: Fix GetDeviceProcAddr with terminators
description: updated
Alka Mohite (amohite) on 2019-02-07
tags: added: bionic-updates
Sai Kiran Korwar (skirank) wrote :

Hi Timo,

Will this fix be available in the bionic updates? How can I know when it is happening?

Timo Aaltonen (tjaalton) wrote :

first someone needs to review it from the queue, then after verifying the fix it takes a week to get in updates

Łukasz Zemczak (sil2100) wrote :

I will conditionally accept this into -proposed because the bug reported closely follows this bug and can perform the validation.
But the test-case of this bug is not really acceptable from the SRU POV so I'd like it to be fixed before the validation can be approved (and package released into -update). For instance, what vulkan apps are to be checked if they're still working? Please give at least some example apps. What does 'and the issue is fixed' mean? How can that be checked? What should a tester do to check if the issue is fixed? The test case should be clear and executable by any interested testing party.

Changed in vulkan (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic

Hello Sai, or anyone else affected,

Accepted vulkan into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/vulkan/1.1.70+dfsg1-1ubuntu0.18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Sai Kiran Korwar (skirank) wrote :

For test cases: You can test vulkaninfo or vulkan-smoketest or the Vulkan CTS test.
The test case that is fixed in this bug is a CTS test namely "dEQP-VK.api.version_check.entry_points" that can be run with the cts binary.

./glcts --deqp-case=dEQP-VK.api.version_check.entry_points

I have tested the libvulkan-dev, libvulkan1 and vulkan-utils packages from version 1.1.70+dfsg1-1ubuntu0.18.04.1 with the above apps and found that the issue is fixed and there are no regressions seen.

Added the verification-done-bionic tag to the bug as well.

tags: added: verification-done-bionic
removed: verification-needed-bionic
Adam Conrad (adconrad) on 2019-02-15
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vulkan - 1.1.70+dfsg1-1ubuntu0.18.04.1

---------------
vulkan (1.1.70+dfsg1-1ubuntu0.18.04.1) bionic; urgency=medium

  * fix-getdeviceprocaddr-with-terminators.diff: Don't return function
    pointers to unenabled extensions. (LP: #1813002)
  * control: Add python3-distutils to build-depends.

 -- Timo Aaltonen <email address hidden> Fri, 25 Jan 2019 09:39:57 +0200

Changed in vulkan (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for vulkan has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers