vte2.91 0.62.0-1ubuntu1 source package in Ubuntu

Changelog

vte2.91 (0.62.0-1ubuntu1) groovy; urgency=medium

  * Merge with debian. Remaining changes:
    - Add 91_keep_fds.patch since gdebi still requires it (LP: #1756238)
    - 0001-Add-the-style-context-provider-with-FALLBACK-priorit.patch:
      + Keep as it is required for the Ubuntu theming
    - Breaks/Replaces with libvte-2.91-0 (<= 0.60.0-2ubuntu1)
    - Ubuntu gbp.conf and debian/control VCS informations
  * debian/control: Don't build-depend on libicu-dev:
    - This is an optional dependency and we explicitly disable it in rules, so
      does debian, so let's not diverge here.
  * d/p/0001-Add-the-style-context-provider-with-FALLBACK-priorit.patch:
    - Add clarification about why this is needed
  * d/p/91_keep_fds.patch:
    - Refactor as per upstream spawning system changes, fixes issue causing
      some FDs not to be non-closed at all.
    - Clarify what this is needed for

vte2.91 (0.62.0-1) unstable; urgency=medium

  * Team upload
  * d/watch: Watch for git tags, not for upstream tarball releases.
    The upstream maintainer of vte does not always upload tarballs to
    download.gnome.org.
  * New upstream stable release
    - Translation updates
    - Fix ABI regression (previously avoided in Debian via a patch)
  * Drop patch, applied upstream
  * d/watch: Only watch for stable (even-numbered) releases
  * Release to unstable

vte2.91 (0.61.91-1) experimental; urgency=medium

  * Team upload
  * d/watch: Watch for development versions
  * New upstream release
  * Drop patch 01_scroll_notebook.patch.
    This never went upstream, and is intended to work with a corresponding
    patch in GTK 3 that was rejected upstream and disabled in Debian's
    GTK packaging in 2012.
  * Don't install NEWS, no longer provided
  * Disable icu support for the udeb
  * Build udeb with -static-libgcc -static-libstdc++
    There's no libstdc++ udeb, and vte exports a C ABI but is C++ internally,
    so this might be a way to make the udeb installable.
  * Add proposed patch to revert an ABI break
  * Update symbols file

vte2.91 (0.60.3-1) unstable; urgency=medium

  * New upstream stable release

 -- Marco Trevisan (Treviño) <email address hidden>  Tue, 22 Sep 2020 20:37:48 +0200

Upload details

Uploaded by:
Marco Trevisan (Treviño) on 2020-09-22
Uploaded to:
Groovy
Original maintainer:
Ubuntu Developers
Architectures:
any all
Section:
misc
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section
Groovy release on 2020-09-23 main misc

Downloads

File Size SHA-256 Checksum
vte2.91_0.62.0.orig.tar.gz 588.8 KiB 6b4246f3855553b71756e6b3070fd0d5b865d33ca8bef9a6b99b726d8c1f56ca
vte2.91_0.62.0-1ubuntu1.debian.tar.xz 25.0 KiB aeacea4c1a36d512ce0daceb515e6f9d3eef2342d8e33df54006b8c4f15ce24b
vte2.91_0.62.0-1ubuntu1.dsc 3.0 KiB 130cc9cda43d0f8f366503103f99a9495601375b6089435bdedb1b43e72fa4d3

Available diffs

View changes file

Binary packages built by this source

gir1.2-vte-2.91: GObject introspection data for the VTE library

 This package contains introspection data for VTE, a terminal emulator
 widget for GTK+.
 .
 It can be used by interpreters understanding the GIRepository format to
 write programs using the VTE widget for GTK+ 3.0.

libvte-2.91-0: Terminal emulator widget for GTK+ 3.0 - runtime files

 The VTE library provides a terminal emulator widget VteTerminal for
 applications using the GTK+ toolkit. It also provides the VtePTY object
 containing functions for starting a new process on a new
 pseudo-terminal and for manipulating pseudo-terminals.
 .
 This package contains the runtime library, needed by programs using the
 VTE widget with GTK+ 3.0.

libvte-2.91-0-dbgsym: debug symbols for libvte-2.91-0
libvte-2.91-0-udeb: Terminal emulator widget for GTK+ 3.0 - minimal runtime

 The VTE library provides a terminal emulator widget VteTerminal for
 applications using the GTK+ toolkit. It also provides the VtePTY object
 containing functions for starting a new process on a new
 pseudo-terminal and for manipulating pseudo-terminals.
 .
 This package contains the minimal runtime library for GTK+ 3.0 needed
 by the Debian installer.

libvte-2.91-common: Terminal emulator widget for GTK+ 3.0 - common files

 The VTE library provides a terminal emulator widget VteTerminal for
 applications using the GTK+ toolkit. It also provides the VtePTY object
 containing functions for starting a new process on a new
 pseudo-terminal and for manipulating pseudo-terminals.
 .
 This package contains internationalization files for the VTE library
 and common files for the GTK+ 3.x version.

libvte-2.91-common-dbgsym: debug symbols for libvte-2.91-common
libvte-2.91-dev: Terminal emulator widget for GTK+ 3.0 - development files

 The VTE library provides a terminal emulator widget VteTerminal for
 applications using the GTK+ toolkit. It also provides the VtePTY object
 containing functions for starting a new process on a new
 pseudo-terminal and for manipulating pseudo-terminals.
 .
 This package contains development files for the VTE library and its
 Python bindings. It is needed to develop and build programs using the
 VTE widget with GTK+ 3.0.

libvte-2.91-doc: Terminal emulator widget for GTK+ 3.0 - documentation

 The VTE library provides a terminal emulator widget VteTerminal for
 applications using the GTK+ toolkit. It also provides the VtePTY object
 containing functions for starting a new process on a new
 pseudo-terminal and for manipulating pseudo-terminals.
 .
 This package contains documentation files for the VTE library for GTK+
 3.x.