[SRU] gnome-terminal to 3.36.2 and vte2.91 to 0.60.3

Bug #1883015 reported by Ken VanDine on 2020-06-10
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-terminal (Ubuntu)
Status tracked in Groovy
Focal
Low
Ken VanDine
Groovy
Undecided
Unassigned
vte2.91 (Ubuntu)
Status tracked in Groovy
Focal
Low
Ken VanDine
Groovy
Undecided
Unassigned

Bug Description

[ Description ]

Update as part of the GNOME 3.36 stable release series

[ QA ]

Check you can launch the terminal and use it. Maybe check that different themes, launching a custom command, custom terminal launchers, etc work.

There is a standing SRU exception for GNOME:

https://wiki.ubuntu.com/StableReleaseUpdates/GNOME

[ Regresison potential ]

If the update causes issues they should be pretty apparent when running gnome-terminal.

Changed in gnome-terminal (Ubuntu Groovy):
status: New → Fix Released
Changed in vte2.91 (Ubuntu Groovy):
status: New → Fix Released
Changed in gnome-terminal (Ubuntu Focal):
importance: Undecided → Low
Changed in vte2.91 (Ubuntu Focal):
importance: Undecided → Low
assignee: nobody → Ken VanDine (ken-vandine)
Changed in gnome-terminal (Ubuntu Focal):
assignee: nobody → Ken VanDine (ken-vandine)
status: New → Triaged
Changed in vte2.91 (Ubuntu Focal):
status: New → Triaged
summary: - [SRU] gnome-terminal to 3.36.2 and vte2.91 to 0.60.2
+ [SRU] gnome-terminal to 3.36.2 and vte2.91 to 0.60.3

Hello Ken, or anyone else affected,

Accepted vte2.91 into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/vte2.91/0.60.3-0ubuntu1~20.04 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in vte2.91 (Ubuntu Focal):
status: Triaged → Fix Committed
tags: added: verification-needed verification-needed-focal
Brian Murray (brian-murray) wrote :

Hello Ken, or anyone else affected,

Accepted gnome-terminal into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-terminal/3.36.2-1ubuntu1~20.04 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in gnome-terminal (Ubuntu Focal):
status: Triaged → Fix Committed
Sebastien Bacher (seb128) wrote :

Updating to g-t 3.36.2-1ubuntu1~20.04 and vte 0.60.3-0ubuntu1~20.04 works correctly

tags: added: verification-done verification-done-focal
removed: verification-needed verification-needed-focal
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vte2.91 - 0.60.3-0ubuntu1~20.04

---------------
vte2.91 (0.60.3-0ubuntu1~20.04) focal; urgency=medium

  * No-change backport from groovy to focal. (LP: #1883015)

vte2.91 (0.60.2-1) unstable; urgency=medium

  * Team upload
  * New upstream stable release

 -- Ken VanDine <email address hidden> Thu, 11 Jun 2020 13:44:25 -0400

Changed in vte2.91 (Ubuntu Focal):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-terminal - 3.36.2-1ubuntu1~20.04

---------------
gnome-terminal (3.36.2-1ubuntu1~20.04) focal; urgency=medium

  * No-change backport from groovy to focal. (LP: #1883015)

gnome-terminal (3.36.2-1) unstable; urgency=medium

  * Team upload
  * New upstream release
    - Return to 3.36.0 behaviour of inheriting all environment variables
      sent to the original tab/window into the second and subsequent
      tabs/windows. This is likely to change in the 3.37/3.38 cycle,
      because it introduces an inconsistency between new windows/tabs
      created from another window/tab, and new windows/tabs created
      via the CLI or a .desktop file (see upstream issue 253).
      (Closes: #958502, #959188 - at least in the short term)
    - Drop patches that came from upstream
    - d/control.in: Update vte dependency

gnome-terminal (3.36.1.1-3) unstable; urgency=medium

  * BD on gnome-shell-common which is arch:all and enable search provider on
    all architectures

gnome-terminal (3.36.1.1-2) unstable; urgency=medium

  * Team upload
  * d/patches: Update from upstream gnome-3-36 branch, commit
    3.36.1.1-7-g11f0ad63
    - Under `systemd --user`, don't kill processes that were launched
      by gnome-terminal (e.g. a web browser from clicking on a link)
      when the last terminal closes
    - Don't log debug messages (from dconf etc.) if not --verbose
    - Translation updates

 -- Ken VanDine <email address hidden> Wed, 10 Jun 2020 21:40:18 -0400

Changed in gnome-terminal (Ubuntu Focal):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for vte2.91 has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers