[SRU] 0.56.2

Bug #1827207 reported by Iain Lane on 2019-05-01
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
vte2.91 (Ubuntu)
Undecided
Unassigned
Disco
Undecided
Iain Lane

Bug Description

[ Description ]

Upstream point release, uploaded under the GNOME MRE. This is a crash fix (see the linked Red Hat bug).

commit 9a079492ea698f573dfc7129f1c79e4a865803b4
Author: Christian Persch <email address hidden>
Date: Sat Apr 20 19:41:46 2019 +0200

    parser: glue: Correct parameter collection

    If the minimum value is greater than the maximum_value (which can happen e.g.
    when the minimum is 1 and the maximum is m_column_count - cursor.column),
    the parameter collection should return the minimum value, not the maximum value.

    (cherry picked from commit 8afa5e46905492779027ed2c04e8a63e30cd74df)

 src/parser-glue.hh | 11 +++++++----
 1 file changed, 7 insertions(+), 4 deletions(-)

commit d08b9d0e4c3dbca586496d1807da9b430de0aadc
Author: Christian Persch <email address hidden>
Date: Sat Apr 20 19:41:46 2019 +0200

    Revert "parser: glue: Use std::clamp"

    This reverts commit 1a84c427cd2ea05939b86eb47c21a437d0ce6d79.

    https://bugzilla.redhat.com/show_bug.cgi?id=1701590
    (cherry picked from commit d4da2ac7417c710bc7e9824062ab09d1187e815a)

 src/parser-glue.hh | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

[ QA ]

Test various terminal emulators, e.g. GNOME terminal, MATE terminal, and tilix. Make sure they all still work properly - e.g. multi window, multi tab, running commands, ...

[ Regression potential ]

It's reverting a commit back to the state the code had previously, so this doesn't feel very risky. If it's bad then the worst thing that could happen is that anything using Vte breaks.

Iain Lane (laney) on 2019-05-01
Changed in vte2.91 (Ubuntu):
status: New → Fix Released
Changed in vte2.91 (Ubuntu Disco):
status: New → In Progress
assignee: nobody → Iain Lane (laney)

Hello Iain, or anyone else affected,

Accepted vte2.91 into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/vte2.91/0.56.2-1ubuntu1~19.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-disco to verification-done-disco. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-disco. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in vte2.91 (Ubuntu Disco):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-disco
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers