Crash related to hyperlinks

Bug #1772506 reported by Egmont Koblinger on 2018-05-21
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
vte2.91 (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Iain Lane

Bug Description

[ Description ]

A crash was discovered recently in VTE, triggered by the combination of explicit hyperlinks (a new feature of vte-0.50) and a non-aligned window size (e.g. Tilix, or maximized GNOME Terminal) due to a missing trivial boundary check.

Since GNOME Terminal handles all of its terminals in a single process, a crash causes all its terminals to disappear, making the consequences even worse.

Mainstream bugreport with technical details and steps to reproduce: https://bugzilla.gnome.org/show_bug.cgi?id=795826

Fix (for vte-0.52.x): https://git.gnome.org/browse/vte/commit/?h=vte-0-52&id=5966e8bfb

Bionic ships 0.52.1. Mainstream 0.52.2 has been released with this code change only (apart from the version as reported by VTE itself), so instead of patching you could probably just simply bump the version number.

Older Ubuntu release are unaffected, since they didn't yet have support for explicit hyperlinks.

Jeremy & others, could you please release a fixed package as an update for Bionic LTS? Thanks a lot!

[ QA ]

Under the GNOME micro release exception, you can believe this bug is fixed. Please just test as outlined in bug #1774167

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: libvte-2.91-0 0.52.1-1ubuntu1
ProcVersionSignature: Ubuntu 4.15.0-20.21-generic 4.15.17
Uname: Linux 4.15.0-20-generic x86_64
ApportVersion: 2.20.9-0ubuntu7
Architecture: amd64
CurrentDesktop: Unity:Unity7:ubuntu
Date: Mon May 21 22:06:38 2018
InstallationDate: Installed on 2016-11-09 (557 days ago)
InstallationMedia: Ubuntu 16.10 "Yakkety Yak" - Release amd64 (20161012.2)
SourcePackage: vte2.91
UpgradeStatus: Upgraded to bionic on 2018-03-14 (67 days ago)

Egmont Koblinger (egmont-gmail) wrote :
Iain Lane (laney) on 2018-05-30
description: updated
Changed in vte2.91 (Ubuntu):
status: New → Fix Committed
Changed in vte2.91 (Ubuntu Bionic):
status: New → In Progress
assignee: nobody → Iain Lane (laney)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vte2.91 - 0.52.2-1ubuntu1

---------------
vte2.91 (0.52.2-1ubuntu1) cosmic; urgency=medium

  [ Iain Lane ]
  * Merge with Debian. Remaining changes:
    - debian/rules:
      + Use --without-pcre2
    - Add revert-pcre2.patch:
      + Revert changes that require PCRE2 since it's not in main
        (see MIR #163666)
    - Add 91_keep_fds.patch since gdebi still requires it (LP: #1756238)
    - 0001-Add-the-style-context-provider-with-FALLBACK-priorit.patch:
      + Keep as it is required for the Ubuntu theming
  * debian/gbp.conf: Update for Ubuntu

   [ Rico Tzschichholz ]
   * revert-pcre2.patch:
     - Don't revert unrelated g-i annotation changes to avoid unnecessary
       gir/vapi API changes compared to upstream (LP: #1765389)
  * revert-pcre2.patch: Refresh, fix a conflict.
  * debian/control{,.in}: Update Vcs-* for LP git

vte2.91 (0.52.2-1) unstable; urgency=medium

  [ Iain Lane ]
  * New upstream release 0.52.2 (LP: #1774167):
    + [5966e8b] ring: Proper boundary checking for hyperlink position.
      This fixes a rare crash around hyperlinks in a non grid aligned VTE
      widget when the mouse enters the extra padding at the bottom. (LP:
      #1772506)
    + [7322c27] all: Fix spelling

 -- Iain Lane <email address hidden> Wed, 30 May 2018 13:09:28 +0100

Changed in vte2.91 (Ubuntu):
status: Fix Committed → Fix Released

Hello Egmont, or anyone else affected,

Accepted vte2.91 into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/vte2.91/0.52.2-1ubuntu1~18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in vte2.91 (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic
Iain Lane (laney) wrote :

Seems OK per the main bug

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vte2.91 - 0.52.2-1ubuntu1~18.04.1

---------------
vte2.91 (0.52.2-1ubuntu1~18.04.1) bionic; urgency=medium

  * debian/{gbp.conf,control{,.in}}: Update for bionic.
  * Backport from cosmic to bionic.

vte2.91 (0.52.2-1ubuntu1) cosmic; urgency=medium

  [ Iain Lane ]
  * Merge with Debian. Remaining changes:
    - debian/rules:
      + Use --without-pcre2
    - Add revert-pcre2.patch:
      + Revert changes that require PCRE2 since it's not in main
        (see MIR #163666)
    - Add 91_keep_fds.patch since gdebi still requires it (LP: #1756238)
    - 0001-Add-the-style-context-provider-with-FALLBACK-priorit.patch:
      + Keep as it is required for the Ubuntu theming
  * debian/gbp.conf: Update for Ubuntu

   [ Rico Tzschichholz ]
   * revert-pcre2.patch:
     - Don't revert unrelated g-i annotation changes to avoid unnecessary
       gir/vapi API changes compared to upstream (LP: #1765389)
  * revert-pcre2.patch: Refresh, fix a conflict.
  * debian/control{,.in}: Update Vcs-* for LP git

vte2.91 (0.52.2-1) unstable; urgency=medium

  [ Iain Lane ]
  * New upstream release 0.52.2 (LP: #1774167):
    + [5966e8b] ring: Proper boundary checking for hyperlink position.
      This fixes a rare crash around hyperlinks in a non grid aligned VTE
      widget when the mouse enters the extra padding at the bottom. (LP:
      #1772506)
    + [7322c27] all: Fix spelling

 -- Iain Lane <email address hidden> Wed, 30 May 2018 13:19:02 +0100

Changed in vte2.91 (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for vte2.91 has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers