[FFe] Drop unrelated changes from revert-prce2.patch

Bug #1765389 reported by Rico Tzschichholz on 2018-04-19
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
vte2.91 (Ubuntu)
Low
Iain Lane
Bionic
Low
Iain Lane

Bug Description

[Impact]

 * revert-prce2.patch includes some unrelated reverts which are
   changing the gir/vapi API in unnecessary ways compared to
   vanilla upstream. Therefore projects using this binding will
   require distro-patching to accommodate for that.
   Users of vte-2.91.vapi and Vte-2.91.gir/typelib are such candidates.
 * vte-2.91.vapi is a buildtime dependency
 * Vte-2.91.typelib is a runtime dependency with immediate effect on users.

[Test Case]

 * https://bugs.launchpad.net/ubuntu/+source/vte2.91/+bug/1765389/+attachment/5122590/+files/vte-2.91.vapi.diff shows the current unwanted changes of the vala bindings

[Regression Potential]

 * This change breaks the API of vala bindings and the API/ABI of
   Vte-2.91.typelib
 * Packages using this specific API would have already received
   distro-patches which should be dropped.
 * I am currently not aware of such packages in the archive.

[Other Info]

 * Test-Build: https://launchpad.net/~ricotz/+archive/ubuntu/staging/+sourcepub/8991295/+listing-archive-extra

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in vte2.91 (Ubuntu):
status: New → Confirmed
Egmont Koblinger (egmont-gmail) wrote :

Yes please :)

Copying from a previous email, for public record:

"""
I honestly don't _exactly_ know what the revert-pcre2 patch does (how it influences the API etc.), I only ported it from 0.48 to 0.52. The parts you're pointing to were already present in the 0.48 version. I have no clue how and why they got there.

That being said, they are indeed irrelevant to the pcre2 issue, and if those changes are required for whatever reason then they should at the very least reside in a separate patch, pointing to its bug entry at the top of the file. My best guess is that this was introduced accidentally and is simply a bug – as you confirm it causes troubles for you in the gir/vapi binding.
"""

Jeremy Bicha (jbicha) on 2018-05-07
Changed in vte2.91 (Ubuntu Bionic):
importance: Undecided → Low
status: New → Triaged
Changed in vte2.91 (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
tags: added: bionic
Iain Lane (laney) on 2018-05-24
Changed in vte2.91 (Ubuntu):
assignee: nobody → Didier Roche (didrocks)
Changed in vte2.91 (Ubuntu Bionic):
assignee: nobody → Didier Roche (didrocks)
Iain Lane (laney) wrote :

Stealing this, since I have to upload vte for the new gnome-terminal anyways.

Changed in vte2.91 (Ubuntu):
assignee: Didier Roche (didrocks) → Iain Lane (laney)
Changed in vte2.91 (Ubuntu Bionic):
assignee: Didier Roche (didrocks) → Iain Lane (laney)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vte2.91 - 0.52.2-1ubuntu1

---------------
vte2.91 (0.52.2-1ubuntu1) cosmic; urgency=medium

  [ Iain Lane ]
  * Merge with Debian. Remaining changes:
    - debian/rules:
      + Use --without-pcre2
    - Add revert-pcre2.patch:
      + Revert changes that require PCRE2 since it's not in main
        (see MIR #163666)
    - Add 91_keep_fds.patch since gdebi still requires it (LP: #1756238)
    - 0001-Add-the-style-context-provider-with-FALLBACK-priorit.patch:
      + Keep as it is required for the Ubuntu theming
  * debian/gbp.conf: Update for Ubuntu

   [ Rico Tzschichholz ]
   * revert-pcre2.patch:
     - Don't revert unrelated g-i annotation changes to avoid unnecessary
       gir/vapi API changes compared to upstream (LP: #1765389)
  * revert-pcre2.patch: Refresh, fix a conflict.
  * debian/control{,.in}: Update Vcs-* for LP git

vte2.91 (0.52.2-1) unstable; urgency=medium

  [ Iain Lane ]
  * New upstream release 0.52.2 (LP: #1774167):
    + [5966e8b] ring: Proper boundary checking for hyperlink position.
      This fixes a rare crash around hyperlinks in a non grid aligned VTE
      widget when the mouse enters the extra padding at the bottom. (LP:
      #1772506)
    + [7322c27] all: Fix spelling

 -- Iain Lane <email address hidden> Wed, 30 May 2018 13:09:28 +0100

Changed in vte2.91 (Ubuntu):
status: Triaged → Fix Released
description: updated

Hello Rico, or anyone else affected,

Accepted vte2.91 into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/vte2.91/0.52.2-1ubuntu1~18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in vte2.91 (Ubuntu Bionic):
status: Triaged → Fix Committed
tags: added: verification-needed verification-needed-bionic
Iain Lane (laney) wrote :

This looks good to me - please yell if not.

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers