AltGr key doesn't work properly in xfce4-terminal and gnome-terminal with Maori layout, and Hawaiian is not supported

Bug #929054 reported by Peter Belew
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
console-setup (Ubuntu)
Confirmed
Undecided
Unassigned
vte (Ubuntu)
Confirmed
Undecided
Unassigned

Bug Description

I just installed xfce4-xkb-plugin in order to select various keyboard layout. I soon found out that the AltGr key isn't working properly in xfce4-terminal, gnome-terminal and pterm. I am running the 64-bit version of xubuntu 11.10 and 12.04 on my Compaq computer, and the 32-bit version of 12.04 on a Shuttle computer.

.............
Updated 2012-04-03:
This also affects 32-bit versions of Ubuntu and Xubuntu 11.10 and 12.04 beta-2. It also affects the current Linux Mint. ALSO, note that other layouts with AltGr now work properly when Maori is not in the list. Also I have added lack of Hawaiian support to this bug. I am now updated to the Beta-2 version of xubuntu on the Compaq 12.04 system, and Ubuntu 12.04 beta-2 on the shuttle.
.............

For example, select the Maori keyboard layout. This layout enters vowels with macrons like āēīōūĀĒĪŌŪ when the AltGr key is held on. (This does work in Firefox, which I'm using to enter this report, and also in xterm, but also fails in pterm. It does work in AbiWord). Various other layouts use AltGr, for example the US alt-intl layout uses AltGr plus the minus key as a dead key for entering vowels with macrons - those do not work under xfce4-terminal and pterm, but do work in various other apps. These layouts DO work with gvim, which is useful to me.

When I try to enter characters with AltGr + vowel in the shell from xfce4-terminal (using the Maori layout), I get little diamonds with questions marks. In vim, I get various strange effects, but no vowels with macrons.

This is the 64-bit version of xfce4-terminal:
$ file /usr/bin/xfce4-terminal
/usr/bin/xfce4-terminal: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.15, stripped

Ubuntu version and kernel version
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=11.10
DISTRIB_CODENAME=oneiric
DISTRIB_DESCRIPTION="Ubuntu 11.10"
Linux compaq 3.0.0-15-generic #26-Ubuntu SMP Fri Jan 20 17:23:00 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
model name : AMD Athlon(tm) 64 Processor 3800+
cpu MHz : 1000.000

$ apt-show-versions xfce4-terminal
xfce4-terminal/oneiric uptodate 0.4.8-1

I don't have a computer available to try the 32-bit version of xubuntu 11.10, unfortunately.

BTW my main goal is to enter Hawaiian text, which also uses macrons.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: xfce4-terminal 0.4.8-1
ProcVersionSignature: Ubuntu 3.0.0-15.26-generic 3.0.13
Uname: Linux 3.0.0-15-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
Date: Wed Feb 8 10:56:01 2012
InstallationMedia: Xubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: xfce4-terminal
UpgradeStatus: Upgraded to oneiric on 2011-12-09 (61 days ago)

Revision history for this message
Peter Belew (peterbe) wrote :
Revision history for this message
Peter Belew (peterbe) wrote :

The "? - in diamond" characters mentioned in #1 are hex 81

Revision history for this message
Peter Belew (peterbe) wrote :

I also booted the Xubuntu 11.10 i386 live cd on another computer, and found the same problem in xfce4-terminal, after installing xfce4-xkb-plugin and the Maori layout. However the AltGr + vowel combinations worked in Pidgin, which I tried.

So this problem is not confined to the 64-bit version.

Revision history for this message
Peter Belew (peterbe) wrote :

Yesterday I booted the Xubuntu 12.04 i386 Alpha-2 live CD on the Compaq computer described in #1, installed xfce4-xkb-plugin, added the link for that in the top panel, and tried various keyboard layouts, including Maori and USA Alternative International, and observed the same problem - using key combinations which use the AltGr key in combinations or as a dead key do not work in the default terminal program, but do work in xterm and various GUI programs, such as FireFox or GVim.

I did update Xubuntu 12.04 beta-2 after booting it - that was necessary in order to install xfce4-kkb-plugin.

description: updated
Revision history for this message
Peter Belew (peterbe) wrote :

As of today's updates, this is still the case, in ...

Ubuntu version and kernel version
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=11.10
DISTRIB_CODENAME=oneiric
DISTRIB_DESCRIPTION="Ubuntu 11.10"
Linux compaq 3.0.0-16-generic #28-Ubuntu SMP Fri Jan 27 17:44:39 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
model name : AMD Athlon(tm) 64 Processor 3800+
cpu MHz : 1000.000

Revision history for this message
Peter Belew (peterbe) wrote :

As of yesterday (2012-03-07), the situation is as follows:

Other layouts which use AltGr combinations work Ok. For example, French, Portuguese,Brazilian,German, Croatian, any US-international layout using AltGr, various UK/GB keyboards and so on. I can install any four of those and switch between them and have them work.

However, if the Maori layout is installed with any 1, 2, or 3 of the others, NONE of the layouts work properly with the AltGr key. This is with all the xkb packages reinstalled for 12.04.

Earlier, I had tried installing the /usr/share/X11/xkb files with an additional layout for Hawaiian in the rules/evdev.xml and symbols/us files. This layout differs from the Maori layout only by the addition of an ´okina (glottal stop) character on the single/double quote key of the US layout. That worked well. I am not sure why the Maori layout has such a problem.

Revision history for this message
Peter Belew (peterbe) wrote :

Here is a diff file showing my addition to /usr/share/X11/xkb/rules/evdev.xml for a Hawaiian layout.

Revision history for this message
Peter Belew (peterbe) wrote :

Here is a diff file showing my addition to /usr/share/X11/xkb/symbols/us for a Hawaiian layout.

Revision history for this message
Peter Belew (peterbe) wrote :

The current situation is that the problem only occurs (for me) if the Maori keyboard layout is installed in the Keyboard Layouts Plugin. If it is not, then most layouts that use AltGr combinations do work, such as Croatian, German, French, US International layouts, etc. For example, with the Croatian layout, I can type characters like \|€¶ŧ←↓→øþ÷× on the top row with AltGr depressed. If the Maori keyboard is in the list, and I have the Croatian layout selected, I get the diamond characters when I use the AltGr key (and also if I actually select the Maori layout).

The other issue is that there is no Hawaiian layout in the list. As mentioned above, I created one which is similar to the Maori layout with the addition of the symbol for a glottal stop, called "ʻokina" in Hawaiian. Hereʻs a wikipedia link regarding this:

https://en.wikipedia.org/wiki/%CA%BBOkina#The_new_standard_and_transitional_problems

Here is a new diff file for /usr/share/X11/xkb/symbols/us with the ʻokina supported.

Revision history for this message
Peter Belew (peterbe) wrote :

Here is the diff file for /usr/share/X11/xkb/symbols/us

This and the following patch are a solution for the lack of Hawaiian keyboard support.

Revision history for this message
Peter Belew (peterbe) wrote :

Here is a new copy of the patch to /usr/share/X11/xkb/rules/evdev.xml, adding the <variant> for the Hawaiian layout.

summary: - AltGr key doesn't work properly in xfce4-terminal
+ AltGr key doesn't work properly in xfce4-terminal with Maori layout, and
+ Hawaiian is not supported
Peter Belew (peterbe)
description: updated
Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

The attachment "Patch adding Hawaiian layout" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Revision history for this message
Peter Belew (peterbe) wrote : Re: AltGr key doesn't work properly in xfce4-terminal with Maori layout, and Hawaiian is not supported

In addition, regarding the Hawaiian layout, the file /usr/share/X11/xkb/rules/evdev.lst needs to have a line for Hawaiian added to it, for example:

   lv Latvian
  haw Hawaiian
  mao Maori

Also, to improve finding the layout when setting up alternate layouts in various Ubuntu variants (Kubuntu, Xubuntu, etc.) the file evdev in the same directory should be modified, but I donʻt know exactly how that works, and have not made any changes to it.

Regarding the problems when the Maori layout is installed, that has existed in some form since 11.04 - for example in Ubuntu 11.04 as updated through today, there is no problem any more with gnome-terminal/natty 2.32.1-0ubuntu3 (AltGr keys work fine with the Maori layout, my Hawaiian layout, and others Iʻve tried recently, but not with pterm/natty 0.60+2010-12-08-1, where AltGr combinations appear to turn into something like a dot on the Maori layout, and on other layouts (such as Croatian) when the Maori layout is installed.

Evan (ev)
Changed in xfce4-terminal (Ubuntu):
status: New → Invalid
Revision history for this message
Peter Belew (peterbe) wrote :

I just upgraded to Ubuntu 11.10 from 11.04 on a Shuttle computer and gnome-terminal is having the same problem when the Maori layout is installed. I currently have the English (US), Spanish, and Maori layouts installed, and key combinations with AltGr on both the Spanish and Maori layouts produce the same 'question mark in diamond' character on the screen.

Ubuntu version and kernel version
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=11.10
DISTRIB_CODENAME=oneiric
DISTRIB_DESCRIPTION="Ubuntu 11.10"
Linux shuttle 3.0.0-17-generic #30-Ubuntu SMP Thu Mar 8 17:34:21 UTC 2012 i686 athlon i386 GNU/Linux
model name : AMD Athlon(tm) XP 2500+
cpu MHz : 1825.704

$ apt-show-versions gnome-terminal
gnome-terminal/oneiric uptodate 3.0.1-0ubuntu3

Entry of such characters works with other programs, such as web browsers, and also xterm. I haven't tried pterm on this system.

$ apt-show-versions xterm
xterm/oneiric uptodate 271-1ubuntu2

So the bug occurs with gnome-terminal as well as the xfce terminal program. I do not have my Hawaiian layout installed, only what comes with 11.10. This computer did not have that installed in 11.04 - it had been idle for a number of months before this upgrade.

I plan to upgrade to the 12.04 beta2 (plus current updates) overnight.

Revision history for this message
Peter Belew (peterbe) wrote :

Regarding behavior with xubuntu 12.04 beta2 (with updates through a few minutes ago) and the xfce terminal:

xfce4-terminal/precise uptodate 0.4.8-1

I have both the Maori layout and the ES (Spanish) layout installed. If I select the ES layout and type the top row I see

�������������]

on the screen.

If the Maori layout is NOT install and I type the top row in the xfce terminal, I see

@ł€¶ŧ←↓→øþ[]

and if I type the same thing into this Launchpad window I get

@ł€¶ŧ←↓→øþ[]

which is the same (and correct) thing.

So the bug is not fixed for Xubuntu 12.04 beta2 updated to today.

Revision history for this message
Peter Belew (peterbe) wrote :

I just upgraded Ubuntu on a Shuttle Computer to 12.04 beta 2 (plus today's updates). I started with 11.04, upgraded to 11.10, then to 12.04 beta 2.

The computer is:

# dmidecode -t 2
# dmidecode 2.11
SMBIOS 2.3 present.

Handle 0x0002, DMI type 2, 8 bytes
Base Board Information
 Manufacturer: Shuttle Inc
 Product Name: FX43V10
 Version:
 Serial Number:

 Ubuntu version and kernel version
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=12.04
DISTRIB_CODENAME=precise
DISTRIB_DESCRIPTION="Ubuntu precise (development branch)"
Linux shuttle 3.2.0-21-generic #34-Ubuntu SMP Thu Mar 29 22:13:29 UTC 2012 i686 athlon i386 GNU/Linux
model name : AMD Athlon(tm) XP 2500+
cpu MHz : 1825.944

$ apt-show-versions gnome-terminal
gnome-terminal/precise uptodate 3.4.0.1-0ubuntu1

I have the ES Spanish and Maori layouts installed in the keyboard layout switcher. In THIS window, if I type the top row with AltGr, and the ES layout selected, I get

@ł€¶ŧ←↓→øþ[]

but in the gnome terminal window, I get

 �������������]

If I remove the Maori layout and type the top line as before, with AltGr depressed, I get

@ł€¶ŧ←↓→øþ[]

With Xterm, with ES selected but with Maori in the list, I get

@ł€¶ŧ←↓→øþ[]

Also, the Māori layout AltGr combinations work in xterm and in Firefox but not in gnome-terminal.

Revision history for this message
Peter Belew (peterbe) wrote :

I haven't installed my Hawaiian layout in this Shuttle computer.

Perhaps I should move the request for a Hawaiian layout to a separate bug.

At least the issues with the Maori layout applies to the main terminal programs for Ubuntu and Xubuntu from versions from 11.04 through 12.04 Beta 2, and to some versions of xterm and pterm.

Peter Belew (peterbe)
description: updated
summary: - AltGr key doesn't work properly in xfce4-terminal with Maori layout, and
- Hawaiian is not supported
+ AltGr key doesn't work properly in xfce4-terminal and gnome-terminal
+ with Maori layout, and Hawaiian is not supported
Revision history for this message
Peter Belew (peterbe) wrote :

Note - today I checked the OS X Hawaiian layout on a Macintosh computer. It is the same as the layout I created, except that the OS X layout uses the Option key instead the PC AltGr key. The same Unicode character is used for the ʻokina (glottal stop), using the quote key (otherwise the single/double quote key on the standard US keyboard). This is "ʻ".

Revision history for this message
Peter Belew (peterbe) wrote :

This affects at least xfce4-terminal and gnome-terminal, when the Maori layout is in the selection list. It does not affect the KDE Konsole program.

Changed in xfce4-terminal (Ubuntu):
status: Invalid → New
Revision history for this message
Peter Belew (peterbe) wrote :

I am running KUBUNTU 11.04 beta, 2012-04-09 daily build. This problem does not affect the Konsole terminal program in KDE as of that build: I have the US, Spanish (ES), and Maori (mao) layouts installed, and all 3 layouts work properly.

So only the xfce and gnome terminal programs have this problem, among the default terminal programs I have tested.

I haven't tried my Hawaiian layout under KDE, as yet.

$ uname -a
Linux kubuntu 3.2.0-22-generic-pae #35-Ubuntu SMP Tue Apr 3 20:37:36 UTC 2012 i686 athlon i386 GNU/Linux

I'm running the 32-bit i386 version on a Compaq system with a 64-bit cpu:

kubuntu@kubuntu:~$ cat /proc/cpuinfo
processor : 0
vendor_id : AuthenticAMD
cpu family : 15
model : 47
model name : AMD Athlon(tm) 64 Processor 3800+
stepping : 2
cpu MHz : 1000.000
cache size : 512 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 1
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 syscall nx mmxext fxsr_opt lm 3dnowext 3dnow up pni lahf_lm
bogomips : 2004.14
clflush size : 64
cache_alignment : 64
address sizes : 40 bits physical, 48 bits virtual
power management: ts fid vid ttp tm stc

affects: xfce4-terminal (Ubuntu) → vte (Ubuntu)
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in console-setup (Ubuntu):
status: New → Confirmed
Changed in vte (Ubuntu):
status: New → Confirmed
Revision history for this message
Kendon Bell (kendonb) wrote :

I am potentially facing this bug. When I type Alt-a, expecting a with a macron, I find that the system executes select all, just like Ctrl-a would.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers