Ubuntu

Alt stopped working as Meta in gnome-terminal with gtk+3.0 3.2.2-0ubuntu1

Reported by Anders Kaseorg on 2011-11-15
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Gnome Virtual Terminal Emulator
Fix Released
Medium
gtk+3.0 (Ubuntu)
Undecided
Unassigned
vte (Ubuntu)
Undecided
Unassigned

Bug Description

My Alt key no longer acts as Meta in gnome-terminal on my precise system as of today. So for example in bash, Alt+b no longer moves back a word, Alt+Backspace no longer deletes a word, etc. These keystrokes now act as if Alt was not pressed.

Other libvte-based terminals like xfce4-terminal are not affected.

I traced this to the upload of gtk+3.0 3.2.2-0ubuntu1. After downgrading libgtk-3-0, libgail-3-0, libgail-3-common, gir1.2-gtk-3.0, libgtk-3-bin from 3.2.2-0ubuntu1 to 3.2.0-0ubuntu3 and restarting gnome-terminal, the problem goes away.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: gnome-terminal 3.0.1-0ubuntu3
ProcVersionSignature: Ubuntu 3.1.0-2.3-generic 3.1.0
Uname: Linux 3.1.0-2-generic x86_64
NonfreeKernelModules: openafs
ApportVersion: 1.26-0ubuntu1
Architecture: amd64
Date: Tue Nov 15 01:53:57 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20101202)
SourcePackage: gnome-terminal
UpgradeStatus: No upgrade log present (probably fresh install)

Anders Kaseorg (anders-kaseorg) wrote :
tags: added: regression-release
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-terminal (Ubuntu):
status: New → Confirmed
Changed in gtk+3.0 (Ubuntu):
status: New → Confirmed
Luke Yelavich (themuso) wrote :

There is a proposed patch in the upstream bug. I've built a vte test package, and the patch works for me.

affects: gnome-terminal (Ubuntu) → vte (Ubuntu)
Changed in vte (Ubuntu):
status: Confirmed → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vte - 1:0.28.2-0ubuntu3

---------------
vte (1:0.28.2-0ubuntu3) precise; urgency=low

  * debian/patches/gtk32-meta-map.patch: Patch from upstream bugzilla to
    deal with the new meta mapping in GTK 3.2.2+ (LP: #890555)
 -- Luke Yelavich <email address hidden> Wed, 16 Nov 2011 21:38:44 +1100

Changed in vte (Ubuntu):
status: Triaged → Fix Released
Martin Pitt (pitti) on 2011-11-16
Changed in gtk+3.0 (Ubuntu):
status: Confirmed → Invalid
Changed in vte:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in vte:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.